summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-06-21 08:23:13 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-06-21 08:23:13 +0000
commit0c6b4c5b2fc6350ec67ed5509beda92d55bfc7aa (patch)
treeb747dd593fd7c3b95bff741d5f341aeeadfed404 /net-misc/hsc/hsc-0.929.ebuild
parentnew package: an HTML preprocessor using standard ML syntax. (diff)
downloadgentoo-2-0c6b4c5b2fc6350ec67ed5509beda92d55bfc7aa.tar.gz
gentoo-2-0c6b4c5b2fc6350ec67ed5509beda92d55bfc7aa.tar.bz2
gentoo-2-0c6b4c5b2fc6350ec67ed5509beda92d55bfc7aa.zip
new package: an HTML preprocessor using standard ML syntax.
Diffstat (limited to 'net-misc/hsc/hsc-0.929.ebuild')
-rw-r--r--net-misc/hsc/hsc-0.929.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/hsc/hsc-0.929.ebuild b/net-misc/hsc/hsc-0.929.ebuild
new file mode 100644
index 000000000000..dc71ed354943
--- /dev/null
+++ b/net-misc/hsc/hsc-0.929.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hsc/hsc-0.929.ebuild,v 1.1 2003/06/21 08:22:41 george Exp $
+
+DESCRIPTION="An HTML preprocessor using ML syntax"
+HOMEPAGE="http://www.linguistik.uni-erlangen.de/~msbethke/software.html"
+SRC_URI="http://www.linguistik.uni-erlangen.de/~msbethke/binaries/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gzcat ${FILESDIR}/Makefile.${PF}.patch.gz|patch -p1 Makefile || die "patch failed"
+}
+
+src_compile() {
+ #The patch ensures this line works.
+ make || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/share
+ #This makefile uses INSTDIR instead of DESTDIR
+ make INSTDIR=${D}/usr/ install || die
+}
+
+pkg_postinst() {
+ einfo Documentation and examples for HSC are available in
+ einfo /usr/share/doc/${P}/
+}