summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-07-08 02:12:02 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-07-08 02:12:02 +0000
commitb8a53616f0e45a2fddfa3078c830a8d7ca3de6bf (patch)
treeae010f36c2e2b367ce01a209fdcfa137b12718fc /net-misc/hylafax
parentAdd ~x86-fbsd keyword, wrt #230517. (diff)
downloadgentoo-2-b8a53616f0e45a2fddfa3078c830a8d7ca3de6bf.tar.gz
gentoo-2-b8a53616f0e45a2fddfa3078c830a8d7ca3de6bf.tar.bz2
gentoo-2-b8a53616f0e45a2fddfa3078c830a8d7ca3de6bf.zip
updated with gcc 4.3.1 fixes and corrected/simplified mgetty use logic;
added latest 4.3.x release (Portage version: 2.2_rc1/cvs/Linux 2.6.25.6 x86_64)
Diffstat (limited to 'net-misc/hylafax')
-rw-r--r--net-misc/hylafax/ChangeLog9
-rw-r--r--net-misc/hylafax/hylafax-4.3.1.ebuild55
-rw-r--r--net-misc/hylafax/hylafax-4.3.7.ebuild182
3 files changed, 222 insertions, 24 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index 0f584059df3d..115ca2cfb860 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/hylafax
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.79 2008/02/04 09:49:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.80 2008/07/08 02:12:02 nerdboy Exp $
+
+*hylafax-4.3.7 (08 Jul 2008)
+
+ 08 Jul 2008; Steve Arnold <nerdboy@gentoo.org> hylafax-4.3.1.ebuild,
+ +hylafax-4.3.7.ebuild:
+ Updated with gcc 4.3.1 fixes and corrected/simplified mgetty use logic; see
+ bugs 229263 and 175973 for more info. Updated to latest Hylafax 4.3.x rel.
04 Feb 2008; Christian Faulhammer <opfer@gentoo.org> hylafax-4.3.1.ebuild:
revamp logic to pkg_setup(); add another built_with_use check for USE=fax on
diff --git a/net-misc/hylafax/hylafax-4.3.1.ebuild b/net-misc/hylafax/hylafax-4.3.1.ebuild
index 2fd79b59501c..0bce59c78a4c 100644
--- a/net-misc/hylafax/hylafax-4.3.1.ebuild
+++ b/net-misc/hylafax/hylafax-4.3.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.3.1.ebuild,v 1.8 2008/02/04 09:49:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.3.1.ebuild,v 1.9 2008/07/08 02:12:02 nerdboy Exp $
inherit eutils multilib pam flag-o-matic toolchain-funcs
-IUSE="faxonly jbig pam mgetty html"
+IUSE="jbig pam mgetty html"
-DESCRIPTION="Client-server fax package for class 1 and 2 fax modems."
+DESCRIPTION="Enterprise client-server fax package for class 1 and 2 fax modems."
HOMEPAGE="http://www.hylafax.org"
SRC_URI="ftp://ftp.hylafax.org/source/${P}.tar.gz"
@@ -14,8 +14,7 @@ SLOT="0"
LICENSE="hylafax"
KEYWORDS="~x86 ~sparc ~hppa ~amd64 ~ppc"
-DEPEND="!faxonly? ( net-dialup/mgetty )
- >=sys-libs/zlib-1.1.4
+DEPEND=">=sys-libs/zlib-1.1.4
virtual/ghostscript
>=media-libs/tiff-3.8.2
media-libs/jpeg
@@ -30,31 +29,33 @@ RDEPEND="${DEPEND}
export CONFIG_PROTECT="${CONFIG_PROTECT} /var/spool/fax/etc /usr/lib/fax"
pkg_setup() {
- if use faxonly; then
- if use mgetty; then
- eerror "You cannot set both faxonly and mgetty, please remove one."
- die "invalid USE flags"
- fi
- fi
-
- if built_with_use --missing true net-dialup/mgetty fax; then
+ if use mgetty; then
+ if built_with_use net-dialup/mgetty fax; then
eerror "net-dialup/mgetty must be installed without USE=fax"
die "merge net-dialup/mgetty without USE=fax"
+ fi
fi
if use jbig; then
- einfo "Checking for tiff compiled with jbig support..."
- if built_with_use media-libs/tiff jbig; then
- einfo "Found jbig support; continuing..."
- else
- ewarn "Tiff (media-libs/tiff) must be compiled with jbig support."
- einfo "Please re-emerge tiff with the jbig USE flag or disable it."
- die "Tiff not merged with jbig USE flag"
- fi
+ einfo "Checking for tiff compiled with jbig support..."
+ if built_with_use media-libs/tiff jbig; then
+ einfo "Found jbig support; continuing..."
+ else
+ ewarn "Tiff (media-libs/tiff) must be compiled with jbig support."
+ einfo "Please re-emerge tiff with the jbig USE flag or disable it."
+ die "Tiff not merged with jbig USE flag"
+ fi
fi
}
src_compile() {
+ # gcc standard C++ header changes
+ if [ $(gcc-major-version) -eq 4 ] && [ $(gcc-minor-version) -ge 3 ] ; then
+ sed -i -e 's:"new.h":<new>:g' configure util/Types.h || die "sed failed"
+ sed -i -e 's:"iostream.h":<iostream>\n using namespace std;:g' \
+ configure || die "sed failed"
+ fi
+
# Hylafax doesn't play nice with gcc-3.4 and SSP (bug #74457)
# so drop the flags until a better solution comes along
[ $(gcc-major-version) -eq 3 ] && [ $(gcc-minor-version) -ge 4 ] \
@@ -94,6 +95,7 @@ src_compile() {
--with-PATH_VGETTY=/usr/sbin/vgetty"
else
my_conf="${my_conf} \
+ --with-PATH_GETTY=/bin/false \
--with-PATH_EGETTY=/bin/false \
--with-PATH_VGETTY=/bin/false"
fi
@@ -105,8 +107,6 @@ src_compile() {
fi
fi
- use faxonly && my_conf="${my_conf} --with-PATH_GETTY=/bin/false
- --with-PATH_VGETTY=/bin/false"
#--enable-pam isn't valid
use pam || my_conf="${my_conf} $(use_enable pam)"
@@ -156,6 +156,15 @@ src_install() {
pkg_postinst() {
elog
+ elog "The faxonly USE flag has been removed; since Hylafax does not"
+ elog "require mgetty, and certain fax files conflict, you must build"
+ elog "mgetty without fax support if you wish to use them both. You"
+ elog "may want to add both to package.use so any future updates are"
+ elog "correctly built:"
+ elog
+ elog " net-dialup/mgetty -fax"
+ elog " net-misc/hylafax [-mgetty|mgetty]"
+ elog
elog "There are additional files included in the hylafax/files dir."
elog
elog "Note 1: hylafax.cron is provided for vixie-cron users and"
diff --git a/net-misc/hylafax/hylafax-4.3.7.ebuild b/net-misc/hylafax/hylafax-4.3.7.ebuild
new file mode 100644
index 000000000000..99e66b58074d
--- /dev/null
+++ b/net-misc/hylafax/hylafax-4.3.7.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.3.7.ebuild,v 1.1 2008/07/08 02:12:02 nerdboy Exp $
+
+inherit eutils multilib pam flag-o-matic toolchain-funcs
+
+DESCRIPTION="Enterprise client-server fax package for class 1 and 2 fax modems."
+HOMEPAGE="http://www.hylafax.org"
+SRC_URI="ftp://ftp.hylafax.org/source/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="hylafax"
+KEYWORDS="~x86 ~sparc ~hppa ~amd64 ~ppc"
+
+IUSE="jbig pam mgetty html"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ virtual/ghostscript
+ >=media-libs/tiff-3.8.2
+ media-libs/jpeg
+ jbig? ( media-libs/jbigkit )
+ sys-apps/gawk
+ pam? ( virtual/pam )
+ mgetty? ( net-dialup/mgetty )"
+
+RDEPEND="${DEPEND}
+ net-mail/metamail"
+
+export CONFIG_PROTECT="${CONFIG_PROTECT} /var/spool/fax/etc /usr/lib/fax"
+
+pkg_setup() {
+ if use mgetty; then
+ if built_with_use net-dialup/mgetty fax; then
+ eerror "net-dialup/mgetty must be installed without USE=fax"
+ die "merge net-dialup/mgetty without USE=fax"
+ fi
+ fi
+
+ if use jbig; then
+ einfo "Checking for tiff compiled with jbig support..."
+ if built_with_use media-libs/tiff jbig; then
+ einfo "Found jbig support; continuing..."
+ else
+ ewarn "Tiff (media-libs/tiff) must be compiled with jbig support."
+ einfo "Please re-emerge tiff with the jbig USE flag or disable it."
+ die "Tiff not merged with jbig USE flag"
+ fi
+ fi
+}
+
+src_compile() {
+ # gcc standard C++ header changes
+ if [ $(gcc-major-version) -eq 4 ] && [ $(gcc-minor-version) -ge 3 ] ; then
+ sed -i -e 's:"new.h":<new>:g' configure util/Types.h || die "sed failed"
+ sed -i -e 's:"iostream.h":<iostream>\n using namespace std;:g' \
+ configure || die "sed failed"
+ fi
+
+ # Hylafax doesn't play nice with gcc-3.4 and SSP (bug #74457)
+ # so drop the flags until a better solution comes along
+ [ $(gcc-major-version) -eq 3 ] && [ $(gcc-minor-version) -ge 4 ] \
+ && filter-flags -fstack-protector -fstack-protector-all
+
+# epatch "${FILESDIR}/gentoo-gcc-version.patch" || die "epatch failed"
+
+ local my_conf="
+ --with-DIR_BIN=/usr/bin
+ --with-DIR_SBIN=/usr/sbin
+ --with-DIR_LIB=/usr/$(get_libdir)
+ --with-DIR_LIBEXEC=/usr/sbin
+ --with-DIR_LIBDATA=/var/lib/fax
+ --with-DIR_LOCKS=/var/lock
+ --with-DIR_MAN=/usr/share/man
+ --with-DIR_SPOOL=/var/spool/fax
+ --with-DIR_HTML=/usr/share/doc/${P}/html
+ --with-DIR_CGI="${WORKDIR}"
+ --with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax
+ --with-PATH_IMPRIP=\"\"
+ --with-SYSVINIT=no
+ --with-REGEX=yes
+ --with-LIBTIFF=\"-ltiff -ljpeg -lz\"
+ --with-OPTIMIZER=\"${CFLAGS}\"
+ --with-DSO=auto"
+
+ if use html; then
+ my_conf="${my_conf} --with-HTML=yes"
+ else
+ my_conf="${my_conf} --with-HTML=no"
+ fi
+
+ if use mgetty; then
+ my_conf="${my_conf} \
+ --with-PATH_GETTY=/sbin/mgetty \
+ --with-PATH_EGETTY=/sbin/mgetty \
+ --with-PATH_VGETTY=/usr/sbin/vgetty"
+ else
+ my_conf="${my_conf} \
+ --with-PATH_GETTY=/bin/false \
+ --with-PATH_EGETTY=/bin/false \
+ --with-PATH_VGETTY=/bin/false"
+ fi
+
+ if [ -h /etc/localtime ]; then
+ local continent=$(readlink /etc/localtime | cut -d / -f 5)
+ if [ "${continent}" == "Europe" ]; then
+ my_conf="${my_conf} --with-PAGESIZE=A4"
+ fi
+ fi
+
+ #--enable-pam isn't valid
+ use pam || my_conf="${my_conf} $(use_enable pam)"
+
+ myconf="CC=$(tc-getCC) CXX=$(tc-getCXX) ${my_conf}"
+
+ # eval required for quoting in ${my_conf} to work properly, better way?
+ eval ./configure --nointeractive ${my_conf} || die "./configure failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/{bin,sbin} /usr/$(get_libdir)/fax /usr/share/man
+ dodir /var/spool /var/spool/recvq
+ fowners uucp:uucp /var/spool/fax
+ fperms 0600 /var/spool/fax
+ dodir /usr/share/doc/${P}/html
+
+ make \
+ BIN=${D}/usr/bin \
+ SBIN=${D}/usr/sbin \
+ LIBDIR=${D}/usr/$(get_libdir) \
+ LIB=${D}/usr/$(get_libdir) \
+ LIBEXEC=${D}/usr/sbin \
+ LIBDATA=${D}/usr/$(get_libdir)/fax \
+ MAN=${D}/usr/share/man \
+ SPOOL=${D}/var/spool/fax \
+ HTMLDIR=${D}/usr/share/doc/${P}/html \
+ install || die "make install failed"
+
+ keepdir /var/spool/fax/{archive,client,etc,pollq,recvq,tmp}
+ keepdir /var/spool/fax/{status,sendq,log,info,doneq,docq,dev}
+
+ dosed "s:hostname:hostname -f:g" \
+ /var/spool/fax/bin/{faxrcvd,pollrcvd} || die "dosed failed"
+
+ einfo "Adding env.d entry for Hylafax"
+ newenvd "${FILESDIR}/99hylafax-4.2" 99hylafax
+
+ einfo "Adding init.d entry for Hylafax"
+ newinitd "${FILESDIR}/hylafax-4.2" hylafax
+
+ use pam && pamd_mimic_system hylafax auth account session
+
+ dodoc CHANGES CONTRIBUTORS COPYRIGHT README TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "The faxonly USE flag has been removed; since Hylafax does not"
+ elog "require mgetty, and certain fax files conflict, you must build"
+ elog "mgetty without fax support if you wish to use them both. You"
+ elog "may want to add both to package.use so any future updates are"
+ elog "correctly built:"
+ elog
+ elog " net-dialup/mgetty -fax"
+ elog " net-misc/hylafax [-mgetty|mgetty]"
+ elog
+ elog "There are additional files included in the hylafax/files dir."
+ elog
+ elog "Note 1: hylafax.cron is provided for vixie-cron users and"
+ elog "should be placed in /etc/cron.d. Use as-is or adapt it to"
+ elog "your system config."
+ elog
+ elog "Note 2: if you need to use hylafax with iptables, then you"
+ elog "need to specify the port and use ip_conntrack_ftp as shown"
+ elog "in the included example modules file."
+ elog
+ elog "See the docs and man pages for detailed configuration info."
+ elog
+ elog "Now run faxsetup and (if necessary) faxaddmodem."
+ elog
+}