summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-29 18:22:54 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-29 18:22:54 +0000
commitcde93a5d504be6dd13498c656d8252ba1ddb8ddc (patch)
tree56a26555c5ae19d7e7c4b6ee646fdcfb213e5c78 /net-misc/hylafax
parentold (diff)
downloadgentoo-2-cde93a5d504be6dd13498c656d8252ba1ddb8ddc.tar.gz
gentoo-2-cde93a5d504be6dd13498c656d8252ba1ddb8ddc.tar.bz2
gentoo-2-cde93a5d504be6dd13498c656d8252ba1ddb8ddc.zip
Migrate to EAPI 2 in order to get rid of built_with_use.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'net-misc/hylafax')
-rw-r--r--net-misc/hylafax/ChangeLog8
-rw-r--r--net-misc/hylafax/hylafax-4.4.4-r2.ebuild38
2 files changed, 16 insertions, 30 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index f8c72dfe3a10..4465ee814bf7 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/hylafax
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.95 2009/01/27 22:55:17 fmccor Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.96 2009/08/29 18:22:54 betelgeuse Exp $
+
+ 29 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ hylafax-4.4.4-r2.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
27 Jan 2009; Ferris McCormick <fmccor@gentoo.org> hylafax-4.4.4-r2.ebuild:
Sparc stable, Bug #245190.
diff --git a/net-misc/hylafax/hylafax-4.4.4-r2.ebuild b/net-misc/hylafax/hylafax-4.4.4-r2.ebuild
index b05ef69d893c..7f65ab946223 100644
--- a/net-misc/hylafax/hylafax-4.4.4-r2.ebuild
+++ b/net-misc/hylafax/hylafax-4.4.4-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.4.4-r2.ebuild,v 1.5 2009/01/27 22:55:17 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.4.4-r2.ebuild,v 1.6 2009/08/29 18:22:54 betelgeuse Exp $
+
+EAPI="2"
inherit eutils multilib pam toolchain-funcs
@@ -16,12 +18,12 @@ IUSE="jbig pam mgetty html"
DEPEND=">=sys-libs/zlib-1.1.4
virtual/ghostscript
- >=media-libs/tiff-3.8.2
+ >=media-libs/tiff-3.8.2[jbig?]
media-libs/jpeg
jbig? ( media-libs/jbigkit )
sys-apps/gawk
pam? ( virtual/pam )
- mgetty? ( net-dialup/mgetty )"
+ mgetty? ( net-dialup/mgetty[-fax] )"
RDEPEND="${DEPEND}
net-mail/metamail
@@ -29,29 +31,7 @@ RDEPEND="${DEPEND}
export CONFIG_PROTECT="${CONFIG_PROTECT} /var/spool/fax/etc /usr/lib/fax"
-pkg_setup() {
- if use mgetty; then
- if built_with_use net-dialup/mgetty fax; then
- eerror "net-dialup/mgetty must be installed without USE=fax"
- die "merge net-dialup/mgetty without USE=fax"
- fi
- fi
-
- if use jbig; then
- einfo "Checking for tiff compiled with jbig support..."
- if built_with_use media-libs/tiff jbig; then
- einfo "Found jbig support; continuing..."
- else
- ewarn "Tiff (media-libs/tiff) must be compiled with jbig support."
- einfo "Please re-emerge tiff with the jbig USE flag or disable it."
- die "Tiff not merged with jbig USE flag"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# force it not to strip binaries
for dir in etc util faxalter faxcover faxd faxmail faxrm faxstat \
hfaxd sendfax sendpage ; do
@@ -60,7 +40,7 @@ src_unpack() {
done
}
-src_compile() {
+src_configure() {
# gcc standard C++ header changes
if [ $(gcc-major-version) -eq 4 ] && [ $(gcc-minor-version) -ge 3 ] ; then
sed -i -e 's:"new.h":<new>:g' configure util/Types.h || die "sed failed"
@@ -119,7 +99,9 @@ src_compile() {
# eval required for quoting in ${my_conf} to work properly, better way?
eval ./configure --nointeractive ${my_conf} || die "./configure failed"
+}
+src_compile() {
emake -j1 || die "emake failed"
}
@@ -130,7 +112,7 @@ src_install() {
fperms 0600 /var/spool/fax
dodir /usr/share/doc/${P}/html
- make \
+ emake \
BIN=${D}/usr/bin \
SBIN=${D}/usr/sbin \
LIBDIR=${D}/usr/$(get_libdir) \