summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-26 19:51:40 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-26 19:51:40 +0000
commit67bc216ac2d67adcc9c559a6e661a81d9f07f415 (patch)
treec20a81e581631392fc4416dbff12980f61260366 /net-misc/icecast
parentDon't install the conversion script in /usr/bin to avoid file collisions with... (diff)
downloadgentoo-2-67bc216ac2d67adcc9c559a6e661a81d9f07f415.tar.gz
gentoo-2-67bc216ac2d67adcc9c559a6e661a81d9f07f415.tar.bz2
gentoo-2-67bc216ac2d67adcc9c559a6e661a81d9f07f415.zip
Implement missing reload function. Bug #324727
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/ChangeLog8
-rw-r--r--net-misc/icecast/files/init.d.icecast10
-rw-r--r--net-misc/icecast/icecast-2.3.3-r3.ebuild83
3 files changed, 100 insertions, 1 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index d962cc143c70..e5148b07ea9f 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/icecast
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.101 2013/09/25 17:28:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.102 2013/11/26 19:51:40 hwoarang Exp $
+
+*icecast-2.3.3-r3 (26 Nov 2013)
+
+ 26 Nov 2013; Markos Chandras <hwoarang@gentoo.org> +icecast-2.3.3-r3.ebuild,
+ files/init.d.icecast:
+ Implement missing reload function. Bug #324727
25 Sep 2013; Agostino Sarubbo <ago@gentoo.org> icecast-2.3.3-r2.ebuild:
Stable for ppc, wrt bug #485136
diff --git a/net-misc/icecast/files/init.d.icecast b/net-misc/icecast/files/init.d.icecast
index 202ce67ae5e1..1ead74c043ac 100644
--- a/net-misc/icecast/files/init.d.icecast
+++ b/net-misc/icecast/files/init.d.icecast
@@ -1,4 +1,8 @@
#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_started_commands="reload"
depend() {
need net
@@ -15,3 +19,9 @@ stop() {
start-stop-daemon --stop --pidfile /var/run/icecast.pid --name icecast
eend $?
}
+
+reload() {
+ ebegin "Reloading Icecast2 configuration"
+ start-stop-daemon --signal HUP --pidfile /var/run/icecast.pid
+ eend $?
+}
diff --git a/net-misc/icecast/icecast-2.3.3-r3.ebuild b/net-misc/icecast/icecast-2.3.3-r3.ebuild
new file mode 100644
index 000000000000..0f56ce0dc340
--- /dev/null
+++ b/net-misc/icecast/icecast-2.3.3-r3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.3-r3.ebuild,v 1.1 2013/11/26 19:51:40 hwoarang Exp $
+
+EAPI=4
+inherit eutils autotools systemd user
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="kate logrotate +speex +ssl +theora +yp"
+
+#Although there is a --with-ogg and --with-orbis configure option, they're
+#only useful for specifying paths, not for disabling.
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ media-libs/libogg
+ media-libs/libvorbis
+ kate? ( media-libs/libkate )
+ logrotate? ( app-admin/logrotate )
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ yp? ( net-misc/curl )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewuser icecast -1 -1 -1 nogroup
+}
+
+src_prepare() {
+ # bug #368539
+ epatch "${FILESDIR}"/${P}-libkate.patch
+ # bug #430434
+ epatch "${FILESDIR}"/${P}-fix-xiph_openssl.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --sysconfdir=/etc/icecast2 \
+ $(use_enable kate) \
+ $(use_with theora) \
+ $(use_with speex) \
+ $(use_with yp curl) \
+ $(use_with ssl openssl) \
+ $(use_enable yp)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
+ dohtml -A chm,hhc,hhp doc/*
+ doman debian/icecast2.1
+
+ newinitd "${FILESDIR}"/init.d.icecast icecast
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ insinto /etc/icecast2
+ doins "${FILESDIR}"/icecast.xml
+ fperms 600 /etc/icecast2/icecast.xml
+
+ if use logrotate; then
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+ fi
+ diropts -m0764 -o icecast -g nogroup
+ dodir /var/log/icecast
+ keepdir /var/log/icecast
+ rm -rf "${D}"/usr/share/doc/icecast
+}
+
+pkg_postinst() {
+ touch "${ROOT}"var/log/icecast/{access,error}.log
+ chown icecast:nogroup "${ROOT}"var/log/icecast/{access,error}.log
+}