summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-07-25 02:50:08 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-07-25 02:50:08 +0000
commit10f091bcb18b6a40f743bbf4dc68d38bc2c6a2f3 (patch)
treedc5827263e59c35fc07e0ce91ce306ee2eb89969 /net-misc/iodine
parentAdd ruby20, ruby21 targets. Use Rake tests. (diff)
downloadgentoo-2-10f091bcb18b6a40f743bbf4dc68d38bc2c6a2f3.tar.gz
gentoo-2-10f091bcb18b6a40f743bbf4dc68d38bc2c6a2f3.tar.bz2
gentoo-2-10f091bcb18b6a40f743bbf4dc68d38bc2c6a2f3.zip
Build on newer systemd by using pkg-config to grab right library.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'net-misc/iodine')
-rw-r--r--net-misc/iodine/ChangeLog6
-rw-r--r--net-misc/iodine/files/iodine-0.7.0-new-systemd.patch33
-rw-r--r--net-misc/iodine/iodine-0.7.0.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/net-misc/iodine/ChangeLog b/net-misc/iodine/ChangeLog
index f18a132cf3c1..8cb8353b179a 100644
--- a/net-misc/iodine/ChangeLog
+++ b/net-misc/iodine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/iodine
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/ChangeLog,v 1.10 2014/07/18 15:53:52 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/ChangeLog,v 1.11 2014/07/25 02:50:08 zx2c4 Exp $
+
+ 25 Jul 2014; Jason A. Donenfeld <zx2c4@gentoo.org>
+ +files/iodine-0.7.0-new-systemd.patch, iodine-0.7.0.ebuild:
+ Build on newer systemd by using pkg-config to grab right library.
*iodine-0.7.0 (18 Jul 2014)
diff --git a/net-misc/iodine/files/iodine-0.7.0-new-systemd.patch b/net-misc/iodine/files/iodine-0.7.0-new-systemd.patch
new file mode 100644
index 000000000000..1f54d38073d1
--- /dev/null
+++ b/net-misc/iodine/files/iodine-0.7.0-new-systemd.patch
@@ -0,0 +1,33 @@
+From cc4bc22447d15deacf44bc1d369621a63c934427 Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Fri, 25 Jul 2014 02:02:48 +0200
+Subject: [PATCH] osflags: use pkg-config for systemd support
+
+Recent versions of systemd don't ship with libsystemd-daemon.so anymore,
+but instead use libsystemd.so for everything. This is obviously
+problematic for using the same LDFLAGS on old systemd and new systemd.
+So, they also ship compatability pkgconfig files, which use the old
+names but return the new library. So, the most portable way to support
+both old and new systemd is to use pkgconfig. It's not a problem either,
+since systems that use systemd are bound to also have pkgconfig
+installed.
+---
+ src/osflags | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/osflags b/src/osflags
+index 9eda8f0..0f8a26c 100755
+--- a/src/osflags
++++ b/src/osflags
+@@ -19,7 +19,7 @@ link)
+ Linux)
+ FLAGS="";
+ [ -e /usr/include/selinux/selinux.h ] && FLAGS="$FLAGS -lselinux";
+- [ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS -lsystemd-daemon";
++ [ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS $(pkg-config --libs libsystemd-daemon)";
+ echo $FLAGS;
+ ;;
+ esac
+--
+1.9.3
+
diff --git a/net-misc/iodine/iodine-0.7.0.ebuild b/net-misc/iodine/iodine-0.7.0.ebuild
index 271657963c97..8ea18ece029d 100644
--- a/net-misc/iodine/iodine-0.7.0.ebuild
+++ b/net-misc/iodine/iodine-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/iodine-0.7.0.ebuild,v 1.1 2014/07/18 15:53:52 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/iodine-0.7.0.ebuild,v 1.2 2014/07/25 02:50:08 zx2c4 Exp $
EAPI=5
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
src_prepare(){
epatch "${FILESDIR}"/${P}-TestMessage.patch
+ epatch "${FILESDIR}"/${P}-new-systemd.patch
sed -e '/^\s@echo \(CC\|LD\)/d' \
-e 's:^\(\s\)@:\1:' \