summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 04:47:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 04:47:37 +0000
commit54370b1ee643cfc80589de11726853bdd0b88730 (patch)
treefbd61d1a77a2e72daa30328ed63a550b18a4b68d /net-misc/iputils
parents390 KEYWORDS (diff)
downloadgentoo-2-54370b1ee643cfc80589de11726853bdd0b88730.tar.gz
gentoo-2-54370b1ee643cfc80589de11726853bdd0b88730.tar.bz2
gentoo-2-54370b1ee643cfc80589de11726853bdd0b88730.zip
Restore USE=doc with an extra check in case we're in the middle of a bootstrap #23156.
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/ChangeLog6
-rw-r--r--net-misc/iputils/iputils-021109-r3.ebuild28
2 files changed, 21 insertions, 13 deletions
diff --git a/net-misc/iputils/ChangeLog b/net-misc/iputils/ChangeLog
index da741c09d7a2..83bb5eb11e1a 100644
--- a/net-misc/iputils/ChangeLog
+++ b/net-misc/iputils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/iputils
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.35 2005/01/04 04:28:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.36 2005/01/04 04:47:37 vapier Exp $
+
+ 03 Jan 2005; Mike Frysinger <vapier@gentoo.org> iputils-021109-r3.ebuild:
+ Restore USE=doc with an extra check in case we're in the middle of a
+ bootstrap #23156.
03 Jan 2005; Mike Frysinger <vapier@gentoo.org> iputils-021109-r3.ebuild:
Make sure linux/ipsec.h is usuable before building ipsec stuff #67569.
diff --git a/net-misc/iputils/iputils-021109-r3.ebuild b/net-misc/iputils/iputils-021109-r3.ebuild
index 20a21c23ce69..50d856ade246 100644
--- a/net-misc/iputils/iputils-021109-r3.ebuild
+++ b/net-misc/iputils/iputils-021109-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.16 2005/01/04 04:28:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.17 2005/01/04 04:47:37 vapier Exp $
inherit flag-o-matic gnuconfig eutils toolchain-funcs
@@ -12,19 +12,20 @@ SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${PN}-ss${PV}-try.tar.bz2
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="static ipv6 uclibc" #doc
+IUSE="static ipv6 uclibc doc"
DEPEND="virtual/libc
virtual/os-headers
sys-devel/bison
sys-devel/flex
dev-libs/openssl
- sys-devel/autoconf"
-# docs are broken #23156
-# doc? ( app-text/openjade
-# dev-perl/SGMLSpm
-# app-text/docbook-sgml-dtd
-# app-text/docbook-sgml-utils )
+ sys-devel/autoconf
+ doc? (
+ app-text/openjade
+ dev-perl/SGMLSpm
+ app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ )"
RDEPEND="virtual/libc"
S=${WORKDIR}/${PN}
@@ -78,9 +79,12 @@ src_compile() {
cd ${S}
emake || die "make main failed"
- #if use doc ; then
- # make html || die
- #fi
+ # We include the extra check for docbook2html
+ # because when we emerge from a stage1/stage2,
+ # it may not exist #23156
+ if use doc && type -p docbook2html ; then
+ make html || die
+ fi
make man || die "make man failed"
}
@@ -103,5 +107,5 @@ src_install() {
use ipv6 || rm doc/*6.8
doman doc/*.8
- #use doc && dohtml doc/*.html
+ use doc && dohtml doc/*.html
}