summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-07-12 02:36:33 +0000
committerDaniel Goller <morfic@gentoo.org>2004-07-12 02:36:33 +0000
commitfb4046bd526a4442c127194b80e6a2eb55ef9c25 (patch)
tree96abcf294ab5d023ac326ab173f211a56402b642 /net-misc/ksambaplugin
parentFix bug 56662: make filter-flags work properly with globs (diff)
downloadgentoo-2-fb4046bd526a4442c127194b80e6a2eb55ef9c25.tar.gz
gentoo-2-fb4046bd526a4442c127194b80e6a2eb55ef9c25.tar.bz2
gentoo-2-fb4046bd526a4442c127194b80e6a2eb55ef9c25.zip
Closing bug 54391, applied patch for gcc-3.4
Diffstat (limited to 'net-misc/ksambaplugin')
-rw-r--r--net-misc/ksambaplugin/ChangeLog7
-rw-r--r--net-misc/ksambaplugin/files/ksambaplugin-gcc3.4-fix.patch22
-rw-r--r--net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild16
3 files changed, 42 insertions, 3 deletions
diff --git a/net-misc/ksambaplugin/ChangeLog b/net-misc/ksambaplugin/ChangeLog
index f8293077bd30..d7cf1ba9545f 100644
--- a/net-misc/ksambaplugin/ChangeLog
+++ b/net-misc/ksambaplugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ksambaplugin
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ksambaplugin/ChangeLog,v 1.13 2004/07/03 21:21:25 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ksambaplugin/ChangeLog,v 1.14 2004/07/12 02:36:33 morfic Exp $
+
+ 11 Jul 2004; Daniel Goller <morfic@gentoo.org>
+ +files/ksambaplugin-gcc3.4-fix.patch, ksambaplugin-0.5f.ebuild:
+ Applied patch allowing compiling with gcc-3.4 thanks to Brian S. Stephan
+ closing bug #54391
03 Jul 2004; Carsten Lohrke <carlo@gentoo.org> ksambaplugin-0.5f.ebuild:
QA: need-kde after R/DEPEND
diff --git a/net-misc/ksambaplugin/files/ksambaplugin-gcc3.4-fix.patch b/net-misc/ksambaplugin/files/ksambaplugin-gcc3.4-fix.patch
new file mode 100644
index 000000000000..b71dadede789
--- /dev/null
+++ b/net-misc/ksambaplugin/files/ksambaplugin-gcc3.4-fix.patch
@@ -0,0 +1,22 @@
+--- kcmsambaconf.cpp.orig 2004-07-11 21:03:43.292001112 -0500
++++ kcmsambaconf.cpp 2004-07-11 21:04:37.727725624 -0500
+@@ -193,7 +193,7 @@
+
+ slotSpecifySmbConf(smbFile);
+
+-};
++}
+
+
+ KcmSambaConf::~KcmSambaConf() {
+--- ksambapropertiesdialogplugin.cpp.orig 2004-07-11 21:04:12.042630352 -0500
++++ ksambapropertiesdialogplugin.cpp 2004-07-11 21:10:57.705960152 -0500
+@@ -63,7 +63,7 @@
+ typedef KGenericFactory<KSambaPropertiesDialogPlugin, KPropertiesDialog> KSambaPropertiesDialogPluginFactory;
+
+ K_EXPORT_COMPONENT_FACTORY( ksambakonqiplugin,
+- KSambaPropertiesDialogPluginFactory("ksambakonqiplugin") );
++ KSambaPropertiesDialogPluginFactory("ksambakonqiplugin") )
+
+
+
diff --git a/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild b/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild
index ff28b2f833a4..d634a3ac3339 100644
--- a/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild
+++ b/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild,v 1.5 2004/07/03 21:21:25 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild,v 1.6 2004/07/12 02:36:33 morfic Exp $
-inherit kde
+inherit kde eutils gcc
S=${WORKDIR}/${P/f/}/${P/f/}
@@ -22,3 +22,15 @@ need-kde 3
use debug && myconf="$myconf --enable-debug --enable-profile"
myconf="$myconf --enable-sso"
+
+kde_src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}/ksambaplugin-0.5/ksambaplugin-0.5/src
+
+ #apply patch to compile with gcc-3.4.0 closing bug #54391
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/ksambaplugin-gcc3.4-fix.patch
+ fi
+}