summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-01-05 09:58:00 +0000
committerJoe McCann <joem@gentoo.org>2005-01-05 09:58:00 +0000
commit19aed59e2048043a29888ae196c2f3a5d4f0f456 (patch)
tree055cdc8b2851accdb5abc9f8510ac0cf4ca61b9f /net-misc/logjam/logjam-4.4.1.ebuild
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-19aed59e2048043a29888ae196c2f3a5d4f0f456.tar.gz
gentoo-2-19aed59e2048043a29888ae196c2f3a5d4f0f456.tar.bz2
gentoo-2-19aed59e2048043a29888ae196c2f3a5d4f0f456.zip
New version released, as reported in bug 76696. Ebuild now offers more use switches including a text only mode.
Diffstat (limited to 'net-misc/logjam/logjam-4.4.1.ebuild')
-rw-r--r--net-misc/logjam/logjam-4.4.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/logjam/logjam-4.4.1.ebuild b/net-misc/logjam/logjam-4.4.1.ebuild
new file mode 100644
index 000000000000..9f260cbfe865
--- /dev/null
+++ b/net-misc/logjam/logjam-4.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-4.4.1.ebuild,v 1.1 2005/01/05 09:58:00 joem Exp $
+
+IUSE="gtk gtkhtml spell svg xmms"
+
+inherit
+
+DESCRIPTION="GTK2-based LiveJournal client"
+HOMEPAGE="http://logjam.danga.com/"
+SRC_URI="http://logjam.danga.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+RDEPEND=">=dev-libs/libxml2-2.0
+ net-misc/curl
+ gtk? ( >=x11-libs/gtk+-2 )
+ gtkhtml? ( =gnome-extra/libgtkhtml-3.0.10* )
+ spell? ( app-text/gtkspell )
+ svg? ( >=gnome-base/librsvg-2.2.3 )
+ xmms? ( media-sound/xmms )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e s/logjam.png/logjam_pencil.png/ ${S}/data/logjam.desktop.in
+}
+
+src_compile() {
+
+ econf \
+ `use_with gtk` \
+ `use_with gtkhtml` \
+ `use_with spell gtkspell` \
+ `use_with svg librsvg` \
+ `use_with xmms` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc Changelog doc/README doc/TODO
+}