summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2005-02-06 18:22:01 +0000
committerSimone Gotti <motaboy@gentoo.org>2005-02-06 18:22:01 +0000
commit0a5d98e7852f738c41976f296fc57534d951f799 (patch)
tree175454d8aefb1151ee1c9ae40efb8bdf1eda98a8 /net-misc/mDNSResponder/mDNSResponder-98.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-0a5d98e7852f738c41976f296fc57534d951f799.tar.gz
gentoo-2-0a5d98e7852f738c41976f296fc57534d951f799.tar.bz2
gentoo-2-0a5d98e7852f738c41976f296fc57534d951f799.zip
Initial ebuild. mDNSResponder from Apple, needed by various programs like kdelibs-3.4. Closes bug #75046.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-misc/mDNSResponder/mDNSResponder-98.ebuild')
-rw-r--r--net-misc/mDNSResponder/mDNSResponder-98.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/mDNSResponder/mDNSResponder-98.ebuild b/net-misc/mDNSResponder/mDNSResponder-98.ebuild
new file mode 100644
index 000000000000..5bb91caf9472
--- /dev/null
+++ b/net-misc/mDNSResponder/mDNSResponder-98.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mDNSResponder/mDNSResponder-98.ebuild,v 1.1 2005/02/06 18:22:01 motaboy Exp $
+
+inherit eutils
+
+DESCRIPTION="The mDNSResponder project is a component of Rendezvous, Apple's ease-of-use IP networking initiative."
+HOMEPAGE="http://developer.apple.com/macosx/rendezvous/"
+SRC_URI="http://helios.et.put.poznan.pl/~jstachow/pub/${P}.tar.gz"
+
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-Makefiles.patch
+}
+
+src_compile() {
+ cd ${S}/mDNSPosix
+ make os=linux
+}
+
+src_install() {
+ cd ${S}/mDNSPosix
+ dodir /usr/sbin
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/include
+ dodir /lib/
+ dodir /etc/
+ dodir /usr/share/man/man5/
+ dodir /usr/share/man/man8/
+
+ make DESTDIR=${D} os=linux install
+
+ # Install init scripts
+ insinto /etc/init.d
+ newins ${FILESDIR}/mdnsd.init.d mdnsd
+
+ # Fix the perms on the init scripts
+ fperms a+x /etc/init.d/mdnsd
+}