summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2006-09-24 11:42:10 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2006-09-24 11:42:10 +0000
commit311d79e1f473ae40d5f45b445513ec9144eceaa6 (patch)
treef90b124cf852b44e3276987653d1c245b5bab75f /net-misc/neon
parentstable on amd64 (diff)
downloadgentoo-2-311d79e1f473ae40d5f45b445513ec9144eceaa6.tar.gz
gentoo-2-311d79e1f473ae40d5f45b445513ec9144eceaa6.tar.bz2
gentoo-2-311d79e1f473ae40d5f45b445513ec9144eceaa6.zip
Remove the optional gnutls support as it breaks subversion over https
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/ChangeLog8
-rw-r--r--net-misc/neon/files/digest-neon-0.26.1-r13
-rw-r--r--net-misc/neon/neon-0.26.1-r1.ebuild97
3 files changed, 107 insertions, 1 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index c5b2df727994..388ccb1778a7 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/neon
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.75 2006/09/03 23:10:32 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.76 2006/09/24 11:42:10 pauldv Exp $
+
+*neon-0.26.1-r1 (24 Sep 2006)
+
+ 24 Sep 2006; Paul de Vrieze <pauldv@gentoo.org> +neon-0.26.1-r1.ebuild:
+ Gnutls support is broken in connection with subversion. This should fix
+ #148306 and others once and for all.
03 Sep 2006; Joshua Kinard <kumba@gentoo.org> neon-0.26.1.ebuild:
Marked stable on mips.
diff --git a/net-misc/neon/files/digest-neon-0.26.1-r1 b/net-misc/neon/files/digest-neon-0.26.1-r1
new file mode 100644
index 000000000000..da39b252b488
--- /dev/null
+++ b/net-misc/neon/files/digest-neon-0.26.1-r1
@@ -0,0 +1,3 @@
+MD5 3bb7a82bddfc1c56d2f9dba849aecd1f neon-0.26.1.tar.gz 781639
+RMD160 240e7e34e9b7796ea88c876cf880d3bf38bd94dc neon-0.26.1.tar.gz 781639
+SHA256 c72dc47a9918ed2dc026dff71e4b4fae87174b2bc7a008b0425b7bc9ec0b7160 neon-0.26.1.tar.gz 781639
diff --git a/net-misc/neon/neon-0.26.1-r1.ebuild b/net-misc/neon/neon-0.26.1-r1.ebuild
new file mode 100644
index 000000000000..391b5394737e
--- /dev/null
+++ b/net-misc/neon/neon-0.26.1-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.1-r1.ebuild,v 1.1 2006/09/24 11:42:10 pauldv Exp $
+
+inherit eutils libtool versionator
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 mips ppc ~ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="expat nls socks5 ssl static zlib"
+
+DEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ socks5? ( net-proxy/dante )
+ zlib? ( sys-libs/zlib )
+ ssl? ( >=dev-libs/openssl-0.9.6f )"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ if use userland_Darwin ; then
+ sed -i -e "s:GXX:GCC:g" ${S}/configure || die "sed failed"
+ fi
+
+ elibtoolize
+}
+
+src_compile() {
+ local myconf=""
+ if has_version sys-libs/glibc; then
+ if built_with_use sys-libs/glibc nptlonly \
+ || built_with_use sys-libs/glibc nptl; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf="${myconf} --enable-threadsafe-ssl=posix"
+ fi
+ fi
+ if use expat; then
+ myconf="${myconf} --with-expat"
+ else
+ myconf="${myconf} --with-xml2"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if use static; then
+ myconf="${myconf} --enable-static"
+ else
+ myconf="${myconf} --disable-static --with-pic"
+ fi
+
+ econf \
+ --enable-shared \
+ --without-gssapi \
+ $(use_with zlib) \
+ $(use_enable socks5 socks) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ cd ${S}
+ make check || die "Trying make check without success."
+}
+
+src_install() {
+ make DESTDIR=${D} install || die 'install failed'
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
+}
+
+pkg_postinst() {
+ ewarn "There are new features in this version; please beware that"
+ ewarn "upstream considers the socks support experimental. If you"
+ ewarn "experience test failures (eg, bug 135863) then try rebuilding"
+ ewarn "glibc."
+ ewarn
+ ewarn "Neon has a policy of breaking API across versions, this means"
+ ewarn "that any packages that link against neon will be broken after"
+ ewarn "updating. They will remain broken until they are ported to the"
+ ewarn "new API. You can downgrade neon to the previous version by doing:"
+ ewarn
+ ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
+ ewarn
+ ewarn "You may also have to downgrade any packages that have already been"
+ ewarn "ported to the new API."
+}