summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-06-18 15:17:36 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-06-18 15:17:36 +0000
commit027e468edb94d732b0e94504525a7fba57fe5926 (patch)
tree0b49730a0e333f58695c55f72b521624182e6bb1 /net-misc/nxcl
parentKeyword ~amd64 (diff)
downloadgentoo-2-027e468edb94d732b0e94504525a7fba57fe5926.tar.gz
gentoo-2-027e468edb94d732b0e94504525a7fba57fe5926.tar.bz2
gentoo-2-027e468edb94d732b0e94504525a7fba57fe5926.zip
Fix compilation with GCC 4.7, bug #421731
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/nxcl')
-rw-r--r--net-misc/nxcl/ChangeLog6
-rw-r--r--net-misc/nxcl/files/nxcl-0.9-gcc47.patch10
-rw-r--r--net-misc/nxcl/nxcl-0.9-r2.ebuild9
3 files changed, 20 insertions, 5 deletions
diff --git a/net-misc/nxcl/ChangeLog b/net-misc/nxcl/ChangeLog
index 1b04a3e3095d..fc6203a97e8f 100644
--- a/net-misc/nxcl/ChangeLog
+++ b/net-misc/nxcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/nxcl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/ChangeLog,v 1.11 2012/05/21 19:14:40 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/ChangeLog,v 1.12 2012/06/18 15:17:36 voyageur Exp $
+
+ 18 Jun 2012; Bernard Cafarelli <voyageur@gentoo.org> nxcl-0.9-r2.ebuild,
+ +files/nxcl-0.9-gcc47.patch:
+ Fix compilation with GCC 4.7, bug #421731
21 May 2012; Kacper Kowalik <xarthisius@gentoo.org> nxcl-0.9-r1.ebuild,
nxcl-0.9-r2.ebuild:
diff --git a/net-misc/nxcl/files/nxcl-0.9-gcc47.patch b/net-misc/nxcl/files/nxcl-0.9-gcc47.patch
new file mode 100644
index 000000000000..d14c25e9b583
--- /dev/null
+++ b/net-misc/nxcl/files/nxcl-0.9-gcc47.patch
@@ -0,0 +1,10 @@
+--- lib/notQt.h.orig 2012-06-18 17:15:02.139055813 +0200
++++ lib/notQt.h 2012-06-18 17:15:23.424070974 +0200
+@@ -34,6 +34,7 @@
+ #include <fstream>
+ extern "C" {
+ #include <sys/poll.h>
++#include <unistd.h>
+ }
+ #define NOTQTPROCESS_MAIN_APP 0
+ #define NOTQTPROCESS_FAILURE -1
diff --git a/net-misc/nxcl/nxcl-0.9-r2.ebuild b/net-misc/nxcl/nxcl-0.9-r2.ebuild
index 133a303fbed6..e8bca865eec9 100644
--- a/net-misc/nxcl/nxcl-0.9-r2.ebuild
+++ b/net-misc/nxcl/nxcl-0.9-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/nxcl-0.9-r2.ebuild,v 1.2 2012/05/21 19:14:40 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/nxcl-0.9-r2.ebuild,v 1.3 2012/06/18 15:17:36 voyageur Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils
@@ -34,13 +34,14 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-no_nxssh.patch
fi
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
eautoreconf
}
src_configure() {
- econf $(use_with doc doxygen) || die "configure failed"
+ econf $(use_with doc doxygen)
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install
}