summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-09-10 09:12:15 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-09-10 09:12:15 +0000
commitce58ca5f89499065edab3171b1617cea64ed092f (patch)
treec04205dab28256cf5ea75f187a897837b032e067 /net-misc/nxcl
parentAdded htp-1.16 (#233678). (diff)
downloadgentoo-2-ce58ca5f89499065edab3171b1617cea64ed092f.tar.gz
gentoo-2-ce58ca5f89499065edab3171b1617cea64ed092f.tar.bz2
gentoo-2-ce58ca5f89499065edab3171b1617cea64ed092f.zip
Fix compilation with gcc-4.3, closes bug #235018
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-misc/nxcl')
-rw-r--r--net-misc/nxcl/ChangeLog6
-rw-r--r--net-misc/nxcl/files/nxcl-0.9-gcc43.patch37
-rw-r--r--net-misc/nxcl/nxcl-0.9.ebuild4
3 files changed, 45 insertions, 2 deletions
diff --git a/net-misc/nxcl/ChangeLog b/net-misc/nxcl/ChangeLog
index 9a83f1b5274f..ad3292bf7dd2 100644
--- a/net-misc/nxcl/ChangeLog
+++ b/net-misc/nxcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/nxcl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/ChangeLog,v 1.5 2008/06/05 15:20:04 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/ChangeLog,v 1.6 2008/09/10 09:12:14 voyageur Exp $
+
+ 10 Sep 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +files/nxcl-0.9-gcc43.patch, nxcl-0.9.ebuild:
+ Fix compilation with gcc-4.3, closes bug #235018
05 Jun 2008; Peter Volkov <pva@gentoo.org> nxcl-0.9.ebuild:
amd64 stable, bug #222967.
diff --git a/net-misc/nxcl/files/nxcl-0.9-gcc43.patch b/net-misc/nxcl/files/nxcl-0.9-gcc43.patch
new file mode 100644
index 000000000000..1961e268d0c0
--- /dev/null
+++ b/net-misc/nxcl/files/nxcl-0.9-gcc43.patch
@@ -0,0 +1,37 @@
+Index: nxcl/nxcl.cpp
+===================================================================
+--- nxcl/nxcl.cpp (révision 520)
++++ nxcl/nxcl.cpp (révision 545)
+@@ -30,6 +30,7 @@
+ #include <dbus/dbus.h>
+ #include <X11/Xlib.h>
+ }
++#include <stdlib.h>
+
+ using namespace nxcl;
+ using namespace std;
+Index: lib/notQt.cpp
+===================================================================
+--- lib/notQt.cpp (révision 520)
++++ lib/notQt.cpp (révision 545)
+@@ -29,6 +29,7 @@
+ #include <sys/socket.h>
+ #include <signal.h>
+ }
++#include <stdlib.h>
+
+ #include "../config.h"
+ #include "notQt.h"
+Index: lib/nxclientlib.cpp
+===================================================================
+--- lib/nxclientlib.cpp (révision 520)
++++ lib/nxclientlib.cpp (révision 545)
+@@ -43,6 +43,8 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ }
++#include <stdlib.h>
++#include <string.h>
+
+ /*
+ * On the location of nxproxy and nxssh binaries
diff --git a/net-misc/nxcl/nxcl-0.9.ebuild b/net-misc/nxcl/nxcl-0.9.ebuild
index a59690e053a6..228793629ec0 100644
--- a/net-misc/nxcl/nxcl-0.9.ebuild
+++ b/net-misc/nxcl/nxcl-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/nxcl-0.9.ebuild,v 1.5 2008/06/05 15:20:04 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/nxcl-0.9.ebuild,v 1.6 2008/09/10 09:12:14 voyageur Exp $
inherit autotools
@@ -24,6 +24,8 @@ S="${WORKDIR}/${MY_P}/${PN}"
src_unpack() {
unpack ${A}
cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}