summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-04-02 21:20:14 +0000
committerVlastimil Babka <caster@gentoo.org>2008-04-02 21:20:14 +0000
commit66e48822a5b155516b3af004f3a216adf6f27b5b (patch)
tree29c5dae0440f7255055dec63666889ffcbf3ccb7 /net-misc/omniORB
parentMask networkmanager USE flag - no version of it keyworded (diff)
downloadgentoo-2-66e48822a5b155516b3af004f3a216adf6f27b5b.tar.gz
gentoo-2-66e48822a5b155516b3af004f3a216adf6f27b5b.tar.bz2
gentoo-2-66e48822a5b155516b3af004f3a216adf6f27b5b.zip
Version bump, bug #214308. Fix multilib-strict and quoting, thanks to gentoofan23, bug #214306. Rename omniORB init script to omniNames for clarity and rewrite it with s-s-d. Point the naming service to localhost in omniORB.cfg to work out of the box. Add myself as maintainer.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/omniORB')
-rw-r--r--net-misc/omniORB/ChangeLog13
-rw-r--r--net-misc/omniORB/files/omniNames22
-rw-r--r--net-misc/omniORB/metadata.xml2
-rw-r--r--net-misc/omniORB/omniORB-4.1.2.ebuild78
4 files changed, 112 insertions, 3 deletions
diff --git a/net-misc/omniORB/ChangeLog b/net-misc/omniORB/ChangeLog
index ba6a6a39a0ec..a4e111c7a742 100644
--- a/net-misc/omniORB/ChangeLog
+++ b/net-misc/omniORB/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/omniORB
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.48 2007/11/03 17:05:46 caleb Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.49 2008/04/02 21:20:13 caster Exp $
+
+*omniORB-4.1.2 (02 Apr 2008)
+
+ 02 Apr 2008; Vlastimil Babka <caster@gentoo.org> +files/omniNames,
+ metadata.xml, +omniORB-4.1.2.ebuild:
+ Version bump, bug #214308. Fix multilib-strict and quoting, thanks to
+ gentoofan23, bug #214306. Rename omniORB init script to omniNames for
+ clarity and rewrite it with s-s-d. Point the naming service to localhost
+ in omniORB.cfg to work out of the box. Add myself as maintainer.
03 Nov 2007; Caleb Tennis <caleb@gentoo.org> -omniORB-4.0.6.ebuild,
-omniORB-4.0.7.ebuild:
diff --git a/net-misc/omniORB/files/omniNames b/net-misc/omniORB/files/omniNames
new file mode 100644
index 000000000000..aa49fd9dcc40
--- /dev/null
+++ b/net-misc/omniORB/files/omniNames
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/files/omniNames,v 1.1 2008/04/02 21:20:14 caster Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting omniNames"
+ start-stop-daemon --start --background --make-pidfile --pidfile /var/run/omniNames.pid \
+ --exec /usr/bin/omniNames -- -start -always -logdir /var/log/omniORB \
+ -errlog /var/log/omniORB/omniORB.errors
+ eend $? "Error starting omniNames."
+}
+
+stop() {
+ ebegin "Stopping omniNames"
+ start-stop-daemon --stop --pidfile /var/run/omniNames.pid
+ eend $? "Error stopping omniNames."
+}
diff --git a/net-misc/omniORB/metadata.xml b/net-misc/omniORB/metadata.xml
index 9f3fdee2246b..d57d8cff9f6e 100644
--- a/net-misc/omniORB/metadata.xml
+++ b/net-misc/omniORB/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>caster@gentoo.org</email>
</maintainer>
</pkgmetadata>
diff --git a/net-misc/omniORB/omniORB-4.1.2.ebuild b/net-misc/omniORB/omniORB-4.1.2.ebuild
new file mode 100644
index 000000000000..13122fc5f21a
--- /dev/null
+++ b/net-misc/omniORB/omniORB-4.1.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-4.1.2.ebuild,v 1.1 2008/04/02 21:20:13 caster Exp $
+
+inherit python eutils
+
+DESCRIPTION="A robust, high-performance CORBA 2 ORB"
+SRC_URI="mirror://sourceforge/omniorb/${PF}.tar.gz"
+HOMEPAGE="http://omniorb.sourceforge.net/"
+
+IUSE="ssl"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/python
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = ${CXXFLAGS}/" \
+ -e "s/^CDEBUGFLAGS.*/CDEBUGFLAGS = ${CFLAGS}/" \
+ mk/beforeauto.mk.in \
+ mk/platforms/i586_linux_2.0_*.mk || die "sed failed"
+}
+
+src_compile() {
+ mkdir build || die
+ cd build
+
+ MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg \
+ --with-omniNames-logdir=/var/log/omniORB --libdir=/usr/$(get_libdir)"
+
+ use ssl && MY_CONF="${MY_CONF} --with-openssl=/usr"
+
+ python_version
+ PYTHON=/usr/bin/python${PYVER} ../configure ${MY_CONF} \
+ || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ cd "${S}/build"
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd "${S}"
+ dodoc COPYING* CREDITS README* ReleaseNotes* || die
+
+ docinto print
+ dodoc doc/*.ps doc/*.pdf || die
+
+ dodir /etc/env.d/
+ cat <<- EOF > "${T}/90omniORB"
+ PATH="/usr/share/omniORB/bin/scripts"
+ OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
+ EOF
+ doenvd "${T}/90omniORB" || die
+ doinitd "${FILESDIR}"/omniNames || die
+
+ cp "sample.cfg" "${T}/omniORB.cfg" || die
+ cat <<- EOF >> "${T}/omniORB.cfg"
+ # resolve the omniNames running on localhost
+ InitRef = NameService=corbaname::localhost
+ EOF
+ dodir /etc/omniorb
+ insinto /etc/omniorb
+ doins "${T}/omniORB.cfg" || die
+
+ keepdir /var/log/omniORB
+}
+
+src_postinst() {
+ elog "Since 4.1.2, the omniORB init script has been renamed to omniNames for clarity."
+}