summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-25 12:31:13 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-25 12:31:13 +0000
commitac6cd3cefbc1ea4be93e8f58a963daa8bb54a803 (patch)
tree369e0e83e42f280e557aeda2fa674f11a5a8f952 /net-misc/pavuk
parentRestricting pypy and jython (diff)
downloadgentoo-2-ac6cd3cefbc1ea4be93e8f58a963daa8bb54a803.tar.gz
gentoo-2-ac6cd3cefbc1ea4be93e8f58a963daa8bb54a803.tar.bz2
gentoo-2-ac6cd3cefbc1ea4be93e8f58a963daa8bb54a803.zip
Fixes underlinking, bug #405337 by Attila Tóth; fixes a segfault in the GTK+2 interface on amd64, bug #262504#c40. Thanks to Richard Grenville for the fixes.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/pavuk')
-rw-r--r--net-misc/pavuk/ChangeLog12
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch26
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch10
-rw-r--r--net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild111
4 files changed, 158 insertions, 1 deletions
diff --git a/net-misc/pavuk/ChangeLog b/net-misc/pavuk/ChangeLog
index ce9b317625e5..e3dae5f15ed8 100644
--- a/net-misc/pavuk/ChangeLog
+++ b/net-misc/pavuk/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-misc/pavuk
# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.37 2012/02/19 13:20:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.38 2012/02/25 12:31:13 pacho Exp $
+
+*pavuk-0.9.36_pre20120215-r1 (25 Feb 2012)
+
+ 25 Feb 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch,
+ +files/pavuk-0.9.36_pre20120215-fix-underlinking.patch,
+ +pavuk-0.9.36_pre20120215-r1.ebuild:
+ Fixes underlinking, bug #405337 by Attila Tóth; fixes a segfault in the GTK+2
+ interface on amd64, bug #262504#c40. Thanks to Richard Grenville for the
+ fixes.
19 Feb 2012; Pacho Ramos <pacho@gentoo.org>
+files/pavuk-0.9.36_pre20120215-pcre-fix.patch,
diff --git a/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch
new file mode 100644
index 000000000000..6ce18c1ed3e2
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-gtkmulticol-segfault.patch
@@ -0,0 +1,26 @@
+--- src/gtkmulticol.c 2009-01-21 16:37:39.000000000 +0800
++++ src/gtkmulticol.c 2012-02-21 09:47:21.680512626 +0800
+@@ -45,9 +45,9 @@
+ static void gtk_multicol_size_request(GtkWidget *widget, GtkRequisition *requisition);
+ static void gtk_multicol_size_allocate(GtkWidget *widget, GtkAllocation *allocation);
+
+-guint gtk_multicol_get_type(void)
++GType gtk_multicol_get_type(void)
+ {
+- static guint multicol_type = 0;
++ static GType multicol_type = 0;
+
+ if (!multicol_type)
+ {
+
+--- src/gtkmulticol.h 2009-01-21 16:37:40.000000000 +0800
++++ src/gtkmulticol.h 2012-02-21 09:47:42.880514545 +0800
+@@ -41,7 +41,7 @@
+ GtkBoxClass parent_class;
+ };
+
+-guint gtk_multicol_get_type(void);
++GType gtk_multicol_get_type(void);
+ GtkWidget *gtk_multicol_new(gint nrows);
+ void gtk_multicol_set_number_of_rows(GtkMultiCol *multicol, gint nrows);
+ void gtk_multicol_set_spacing(GtkMultiCol *multicol, gint hspacing, gint vspacing);
diff --git a/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch
new file mode 100644
index 000000000000..25338460bd4c
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-fix-underlinking.patch
@@ -0,0 +1,10 @@
+--- configure.in~ 2011-03-02 10:44:45.000000000 +0800
++++ configure.in 2012-02-23 09:55:28.073709216 +0800
+@@ -1749,6 +1749,7 @@
+
+ if test -n "$GTK_LIBS" ; then
+ if test -n "$GTK_LIBS"; then
++ AX_ADD_OPTION([LIBS], [$X_LIBS])
+ AX_ADD_OPTION([LIBS], [$GTK_LIBS])
+ AX_ADD_OPTION([CPPFLAGS], [$GTK_CFLAGS])
+ AC_DEFINE_UNQUOTED(GTK_FACE, [$GTK_VERSION], [with GTK+ GUI])
diff --git a/net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild b/net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild
new file mode 100644
index 000000000000..e5b5f05b6172
--- /dev/null
+++ b/net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild,v 1.1 2012/02/25 12:31:13 pacho Exp $
+
+EAPI=4
+
+S="${WORKDIR}/${PN}"
+
+inherit eutils autotools-utils
+
+DESCRIPTION="Web spider and website mirroring tool"
+HOMEPAGE="http://www.pavuk.org/"
+SRC_URI="http://dev.gentoo.org/~pacho/maintainer-needed/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug gtk hammer ipv6 nls pcre profile ssl"
+
+RDEPEND="virtual/libintl
+ gtk? ( x11-libs/gtk+:2 )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/gettext"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ # Fixes a bug in re.c for PCRE support
+ "${FILESDIR}/${P}-pcre-fix.patch"
+
+ # Fixes underlinking, bug #405337
+ "${FILESDIR}/${P}-fix-underlinking.patch"
+
+ # Fixes a segfault in the GTK+2 interface on amd64, bug #262504#c40
+ "${FILESDIR}/${P}-fix-gtkmulticol-segfault.patch"
+)
+
+DOCS=( README CREDITS NEWS AUTHORS BUGS TODO MAILINGLIST wget-pavuk.HOWTO
+ ChangeLog wget-pavuk.HOWTO pavuk_authinfo.sample pavukrc.sample
+ )
+
+src_prepare() {
+ # Fixes a bug in Makefile.am that causes aclocal to fail
+ sed -i 's/^\(ACLOCAL_AMFLAGS[[:space:]]*=[[:space:]]*-I[[:space:]]*\)\$(top_srcdir)\//\1/' "${S}/Makefile.am" || die
+
+ # Fixes a bug in configure.in that breaks non-debug builds
+ sed -i 's/\([[:space:]]C\(PP\)*FLAGS=`\)/true; # \1/' "${S}/configure.in" || die
+
+ # Fix for building with ~dev-lang/spidermonkey-1.8.5
+ # sed -i 's/mozjs/mozjs185/g' "${S}/configure.in" || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local regex="auto"
+ use pcre && regex="pcre"
+
+ local myeconfargs=(
+ --enable-threads
+ --enable-socks
+ --enable-utf-8
+ --disable-js
+ "--with-regex=${regex}"
+ $(use_enable gtk)
+ $(use_enable gtk gtk2)
+ $(use_enable gtk gnome)
+ $(use_with gtk x)
+ $(use_enable debug debugging)
+ $(use_enable debug debug-build)
+ # $(use_enable debug debug-features)
+ $(use_enable ssl)
+ $(use_enable nls)
+ $(use_enable ipv6)
+ # $(use_enable javascript js)
+ $(use_enable profile profiling)
+ )
+
+ # JavaScript bindings: Broken!
+ # ============================
+ # Currently could pass configure phase with ~dev-lang/spidermonkey-1.8.5
+ # yet apparently incompatible with recent versions of spidermonkey
+
+ # if use javascript; then
+ # local jspkg='mozjs185'
+ # local jsinclude=$(pkg-config --cflags "$jspkg")
+ # local jslibs='/dev/null '$(pkg-config --libs-only-l "$jspkg")
+ # myeconfargs+=(
+ # "--with-js-include=${jsinclude}"
+ # "--with-js-libraries=${jslibs}"
+ # )
+ # fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ if use gtk; then
+ newicon src/pavuk_logo.xpm pavuk.xpm
+ domenu pavuk.desktop
+ fi
+
+ doman "${S}/doc/pavuk.1"
+
+ autotools-utils_src_install
+}