summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-02 14:47:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-02 14:47:31 +0000
commit172c3f9ce8d54142bee3b9e2b3b970108e0fd548 (patch)
treecfc38f3358ba89ca1be7a3d8d83001b71580cd90 /net-misc/pino
parentClean up old revision. (diff)
downloadgentoo-2-172c3f9ce8d54142bee3b9e2b3b970108e0fd548.tar.gz
gentoo-2-172c3f9ce8d54142bee3b9e2b3b970108e0fd548.tar.bz2
gentoo-2-172c3f9ce8d54142bee3b9e2b3b970108e0fd548.zip
Clean up old revisions. Fix vala dependency to slot 0, bug #339084. Fix some nitpicks wrt eclass usage.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/pino')
-rw-r--r--net-misc/pino/ChangeLog7
-rw-r--r--net-misc/pino/pino-0.2.10.ebuild65
-rw-r--r--net-misc/pino/pino-0.2.11.ebuild11
-rw-r--r--net-misc/pino/pino-0.2.9.ebuild68
4 files changed, 10 insertions, 141 deletions
diff --git a/net-misc/pino/ChangeLog b/net-misc/pino/ChangeLog
index 2dfbbb745f56..dfe6c9474d5c 100644
--- a/net-misc/pino/ChangeLog
+++ b/net-misc/pino/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/pino
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/ChangeLog,v 1.6 2010/07/26 20:43:25 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/ChangeLog,v 1.7 2010/10/02 14:47:30 eva Exp $
+
+ 02 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> -pino-0.2.9.ebuild,
+ -pino-0.2.10.ebuild, pino-0.2.11.ebuild:
+ Clean up old revisions. Fix vala dependency to slot 0, bug #339084. Fix
+ some nitpicks wrt eclass usage.
26 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> pino-0.2.11.ebuild:
Fix compile failure due to vala-0.8, bug 328703
diff --git a/net-misc/pino/pino-0.2.10.ebuild b/net-misc/pino/pino-0.2.10.ebuild
deleted file mode 100644
index 57775c2323bb..000000000000
--- a/net-misc/pino/pino-0.2.10.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/pino-0.2.10.ebuild,v 1.1 2010/05/27 05:47:45 dev-zero Exp $
-
-EAPI="3"
-
-DESCRIPTION="Twitter and Identi.ca desktop client written in Vala"
-HOMEPAGE="http://pino-app.appspot.com/ http://code.google.com/p/pino-twitter/"
-SRC_URI="http://pino-twitter.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug indicate"
-
-RDEPEND=">=dev-libs/glib-2.14:2
- >=x11-libs/gtk+-2.10:2
- >=dev-libs/libgee-0.5.0
- x11-libs/libnotify
- net-libs/libsoup:2.4
- dev-libs/libxml2:2
- >=net-libs/webkit-gtk-1.1
- dev-libs/libunique
- app-text/gtkspell
- indicate? ( dev-libs/libindicate )"
-DEPEND="${RDEPEND}
- >=dev-lang/vala-0.7.9
- dev-util/pkgconfig
- sys-devel/gettext
- dev-util/intltool"
-
-# TODO:
-# write a patch (for CMakeLists.txt) to not ignore LINGUAS
-
-DOCS="AUTHORS README"
-
-src_configure() {
- local myconf=""
- use debug && myconf="--debug"
-
- if ! use indicate ; then
- # sabotage the detection since no configure option
- sed -i \
- -e 's|indicate|indicate-false|' \
- wscript || die "sed failed"
- fi
-
- CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" \
- ./waf --prefix=/usr \
- configure ${myconf} || die "./waf configure failed"
-}
-
-src_compile() {
- local myjobs=$(sed -n -e 's,.*\(-j[[:digit:]]\+\).*,\1,p' <<< ${MAKEOPTS})
- ./waf ${myjobs} build || die "./waf configure failed"
-}
-
-src_install() {
- ./waf \
- --destdir="${D}" \
- install || die "./waf install failed"
-
- rm -rf "${D}/usr/share/doc"
- dodoc ${DOCS}
-}
diff --git a/net-misc/pino/pino-0.2.11.ebuild b/net-misc/pino/pino-0.2.11.ebuild
index 5ce283fe5e40..8c68800b32c8 100644
--- a/net-misc/pino/pino-0.2.11.ebuild
+++ b/net-misc/pino/pino-0.2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/pino-0.2.11.ebuild,v 1.3 2010/07/26 20:43:25 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/pino-0.2.11.ebuild,v 1.4 2010/10/02 14:47:30 eva Exp $
EAPI="3"
@@ -27,7 +27,7 @@ RDEPEND=">=dev-libs/glib-2.14:2
indicate? ( dev-libs/libindicate )"
# vala-0.9 required due to bug 328703
DEPEND="${RDEPEND}
- >=dev-lang/vala-0.9
+ >=dev-lang/vala-0.9:0
dev-util/pkgconfig
sys-devel/gettext
dev-util/intltool"
@@ -41,9 +41,6 @@ DOCS="AUTHORS README"
S="${WORKDIR}/${PN}-0.2.10"
src_configure() {
- local myconf=""
- use debug && myconf="--debug"
-
if ! use indicate ; then
# sabotage the detection since no configure option
sed -i \
@@ -60,6 +57,6 @@ src_configure() {
src_install() {
cmake-utils_src_install
- rm -rf "${D}/usr/share/doc"
- dodoc ${DOCS}
+ rm -rf "${D}/usr/share/doc" || die
+ dodoc ${DOCS} || die
}
diff --git a/net-misc/pino/pino-0.2.9.ebuild b/net-misc/pino/pino-0.2.9.ebuild
deleted file mode 100644
index 9d75b7215e3d..000000000000
--- a/net-misc/pino/pino-0.2.9.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/pino-0.2.9.ebuild,v 1.1 2010/05/16 14:39:17 dev-zero Exp $
-
-EAPI="3"
-
-DESCRIPTION="Twitter and Identi.ca desktop client written in Vala"
-HOMEPAGE="http://pino-app.appspot.com/ http://code.google.com/p/pino-twitter/"
-SRC_URI="http://pino-twitter.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug indicate"
-
-RDEPEND=">=dev-libs/glib-2.14:2
- >=x11-libs/gtk+-2.10:2
- >=dev-libs/libgee-0.5.0
- x11-libs/libnotify
- net-libs/libsoup:2.4
- dev-libs/libxml2:2
- >=net-libs/webkit-gtk-1.1
- dev-libs/libunique
- app-text/gtkspell
- indicate? ( dev-libs/libindicate )"
-DEPEND="${RDEPEND}
- >=dev-lang/vala-0.7.9
- dev-util/pkgconfig
- sys-devel/gettext
- dev-util/intltool"
-
-# upstream got something wrong
-S="${WORKDIR}/test"
-
-# TODO:
-# write a patch (for CMakeLists.txt) to not ignore LINGUAS
-
-DOCS="AUTHORS README"
-
-src_configure() {
- local myconf=""
- use debug && myconf="--debug"
-
- if ! use indicate ; then
- # sabotage the detection since no configure option
- sed -i \
- -e 's|indicate|indicate-false|' \
- wscript || die "sed failed"
- fi
-
- CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" \
- ./waf --prefix=/usr \
- configure ${myconf} || die "./waf configure failed"
-}
-
-src_compile() {
- local myjobs=$(sed -n -e 's,.*\(-j[[:digit:]]\+\).*,\1,p' <<< ${MAKEOPTS})
- ./waf ${myjobs} build || die "./waf configure failed"
-}
-
-src_install() {
- ./waf \
- --destdir="${D}" \
- install || die "./waf install failed"
-
- rm -rf "${D}/usr/share/doc"
- dodoc ${DOCS}
-}