summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-03-10 13:30:38 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-03-10 13:30:38 +0000
commit9ac20ff4004f17a2f7a5029d30fc7f2c54d8e7af (patch)
tree8b6e5839b2313bd688dedd0b4ce4097e017f75eb /net-misc/plowshare
parentadd dep to DEPEND (diff)
downloadgentoo-2-9ac20ff4004f17a2f7a5029d30fc7f2c54d8e7af.tar.gz
gentoo-2-9ac20ff4004f17a2f7a5029d30fc7f2c54d8e7af.tar.bz2
gentoo-2-9ac20ff4004f17a2f7a5029d30fc7f2c54d8e7af.zip
Version bump, optionally install a set of modules as plowhsare only provides core functionalities now. Thanks Matthieu Crapet for the notification on this new system
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/plowshare')
-rw-r--r--net-misc/plowshare/ChangeLog10
-rw-r--r--net-misc/plowshare/metadata.xml1
-rw-r--r--net-misc/plowshare/plowshare-2.0.1.ebuild92
3 files changed, 102 insertions, 1 deletions
diff --git a/net-misc/plowshare/ChangeLog b/net-misc/plowshare/ChangeLog
index ff0e36708626..81b91cb4e6c1 100644
--- a/net-misc/plowshare/ChangeLog
+++ b/net-misc/plowshare/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/plowshare
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/plowshare/ChangeLog,v 1.31 2015/02/03 14:39:22 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/plowshare/ChangeLog,v 1.32 2015/03/10 13:30:38 voyageur Exp $
+
+*plowshare-2.0.1 (10 Mar 2015)
+
+ 10 Mar 2015; Bernard Cafarelli <voyageur@gentoo.org> +plowshare-2.0.1.ebuild,
+ metadata.xml:
+ Version bump, optionally install a set of modules as plowhsare only provides
+ core functionalities now. Thanks Matthieu Crapet for the notification on this
+ new system
*plowshare-1.2.0 (03 Feb 2015)
diff --git a/net-misc/plowshare/metadata.xml b/net-misc/plowshare/metadata.xml
index 703e09e31828..09c9740cdc18 100644
--- a/net-misc/plowshare/metadata.xml
+++ b/net-misc/plowshare/metadata.xml
@@ -6,6 +6,7 @@
<name>Bernard Cafarelli</name>
</maintainer>
<use>
+ <flag name="modules">Install a system-wide set of modules</flag>
<flag name="view-captcha">View captcha with aview</flag>
</use>
<upstream>
diff --git a/net-misc/plowshare/plowshare-2.0.1.ebuild b/net-misc/plowshare/plowshare-2.0.1.ebuild
new file mode 100644
index 000000000000..51757596d34a
--- /dev/null
+++ b/net-misc/plowshare/plowshare-2.0.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/plowshare/plowshare-2.0.1.ebuild,v 1.1 2015/03/10 13:30:38 voyageur Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
+HOMEPAGE="http://code.google.com/p/plowshare/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="bash-completion +javascript +modules view-captcha"
+
+MOD_PV="2ededde1f34e78dcbacf02e900a2ce8cad2e148d"
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz
+ modules? ( http://dev.gentoo.org/~voyageur/distfiles/${PN}-modules-${MOD_PV}.tar.gz )"
+
+RDEPEND="
+ >=app-shells/bash-4
+ || ( app-text/recode ( dev-lang/perl dev-perl/HTML-Parser ) )
+ || ( media-gfx/imagemagick[tiff] media-gfx/graphicsmagick[imagemagick,tiff] )
+ net-misc/curl
+ sys-apps/util-linux
+ javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
+ view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
+DEPEND=""
+
+# NOTES:
+# javascript dep should be any javascript interpreter using /usr/bin/js
+
+# Modules using detect_javascript
+JS_MODULES="flashx letitbit nowdownload_co oboom rapidgator yourvideohost zalaa zippyshare"
+
+src_unpack() {
+ default
+ if use modules; then
+ rm -r "${S}"/src/modules
+ mv ${PN}-modules-${MOD_PV} "${S}"/src/modules
+ fi
+}
+
+src_prepare() {
+ if use modules && ! use javascript; then
+ for module in ${JS_MODULES}; do
+ sed -i -e "s:^${module}.*::" src/modules/config || die "${module} sed failed"
+ rm src/modules/${module}.sh || die "${module} rm failed"
+ done
+ fi
+
+ # Fix doc install path
+ sed -i -e "/^DOCDIR/s|plowshare4|${P}|" Makefile || die "sed failed"
+
+ if ! use bash-completion
+ then
+ sed -i -e \ "/^install:/s/install_bash_completion//" \
+ Makefile || die "sed failed"
+ fi
+}
+
+src_compile() {
+ # There is a Makefile but it's not compiling anything, let's not try.
+ :
+}
+
+src_test() {
+ # Disable tests because all of them need a working Internet connection.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" \
+ PLOWSHARE_FORCE_VERSION="${PV}" install
+}
+
+pkg_postinst() {
+ if use modules; then
+ elog "System-wide modules can break between releases, install per-user versions"
+ elog "in ~/.config/plowshare/modules if needed"
+ if ! use javascript; then
+ ewarn "Without javascript you will not be able to use:"
+ ewarn " ${JS_MODULES}"
+ fi
+ else
+ elog "plowshare is not delivered with modules by default anymore"
+ elog "Per-user modules should be installed as described at:"
+ elog "https://code.google.com/p/plowshare/wiki/Readme#Installation_of_modules"
+ elog "USE=modules will install a system-wide set occasionally updated"
+ fi
+}