summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-03-20 18:09:43 +0000
committerAlin Năstac <mrness@gentoo.org>2005-03-20 18:09:43 +0000
commitb82126be0861a528d923a449d085f93edaa49d18 (patch)
treeadd789b218b49c70689e9ab48766b46a47401a28 /net-misc/quagga/quagga-0.96.5.ebuild
parentadd amd64 keyword (diff)
downloadgentoo-2-b82126be0861a528d923a449d085f93edaa49d18.tar.gz
gentoo-2-b82126be0861a528d923a449d085f93edaa49d18.tar.bz2
gentoo-2-b82126be0861a528d923a449d085f93edaa49d18.zip
fixed bugs #69900, #70457, #80633, #80636, #80697, #81095 and #83009
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/quagga/quagga-0.96.5.ebuild')
-rw-r--r--net-misc/quagga/quagga-0.96.5.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-misc/quagga/quagga-0.96.5.ebuild b/net-misc/quagga/quagga-0.96.5.ebuild
index 6ed6f606cd37..66dbad3222dc 100644
--- a/net-misc/quagga/quagga-0.96.5.ebuild
+++ b/net-misc/quagga/quagga-0.96.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.96.5.ebuild,v 1.2 2004/10/22 08:16:24 amir Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.96.5.ebuild,v 1.3 2005/03/20 18:09:43 mrness Exp $
inherit eutils
@@ -66,7 +66,7 @@ src_compile() {
# configure the stuff
- ./configure --host=${HOST} --prefix=/usr --enable-tcp-zebra \
+ ./configure --host=${CHOST} --prefix=/usr --enable-tcp-zebra \
--enable-nssa --enable-opaque-lsa --enable-ospf-te \
--enable-ospf-secondary \
--enable-user=${QUAGGA_USER} \
@@ -102,7 +102,9 @@ src_install() {
pkg_postinst() {
# empty dir for pid files for the new priv separation auth
- install -d -m0755 -o quagga -g quagga ${ROOT}/var/run/quagga
+ #set proper owner/group/perms even if dir already existed
+ install -d -m0700 -o ${QUAGGA_USER_NAME} -g ${QUAGGA_GROUP_NAME} ${ROOT}/etc/quagga
+ install -d -m0755 -o ${QUAGGA_USER_NAME} -g ${QUAGGA_GROUP_NAME} ${ROOT}/var/run/quagga
einfo "Sample configuration files can be found in /etc/quagga/sample."
einfo "You have to create config files in /etc/quagga before"