summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2012-04-04 16:53:04 +0000
committerChristian Birchinger <joker@gentoo.org>2012-04-04 16:53:04 +0000
commit8764f71d1267faea4563e061170abe4773b2c250 (patch)
tree0ac02e896cccbf430068dae0db6e169c74b2b576 /net-misc/r8168
parentStable for amd64, wrt bug #409403 (diff)
downloadgentoo-2-8764f71d1267faea4563e061170abe4773b2c250.tar.gz
gentoo-2-8764f71d1267faea4563e061170abe4773b2c250.tar.bz2
gentoo-2-8764f71d1267faea4563e061170abe4773b2c250.zip
Adding a patch to support Linux 3.3 kernels
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/ChangeLog6
-rw-r--r--net-misc/r8168/files/r8168-8.028.00-linux-3.3-compat.patch29
-rw-r--r--net-misc/r8168/r8168-8.028.00.ebuild6
3 files changed, 39 insertions, 2 deletions
diff --git a/net-misc/r8168/ChangeLog b/net-misc/r8168/ChangeLog
index a4fa168144c2..4ca5f59d3cf3 100644
--- a/net-misc/r8168/ChangeLog
+++ b/net-misc/r8168/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/r8168
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.6 2012/03/31 17:32:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.7 2012/04/04 16:53:04 joker Exp $
+
+ 04 Apr 2012; Christian Birchinger <joker@gentoo.org> r8168-8.028.00.ebuild:
+ Adding a patch to support Linux 3.3 kernels. This wont affect current users
+ with 3.2 kernels, so it's not required to bump the revision
31 Mar 2012; Markos Chandras <hwoarang@gentoo.org> r8168-8.028.00.ebuild:
Stable on amd64 wrt bug #404311
diff --git a/net-misc/r8168/files/r8168-8.028.00-linux-3.3-compat.patch b/net-misc/r8168/files/r8168-8.028.00-linux-3.3-compat.patch
new file mode 100644
index 000000000000..a599dba40d71
--- /dev/null
+++ b/net-misc/r8168/files/r8168-8.028.00-linux-3.3-compat.patch
@@ -0,0 +1,29 @@
+diff --git a/src/r8168_n.c b/src/r8168_n.c
+index 80cdf1a..4df0e48 100755
+--- a/src/r8168_n.c
++++ b/src/r8168_n.c
+@@ -4,7 +4,7 @@
+ # r8168 is the Linux device driver released for RealTek RTL8168B/8111B,
+ # RTL8168C/8111C, RTL8168CP/8111CP, RTL8168D/8111D, RTL8168DP/8111DP, and
+ # RTL8168E/8111E Gigabit Ethernet controllers with PCI-Express interface.
+-#
++
+ # Copyright(c) 2011 Realtek Semiconductor Corp. All rights reserved.
+ #
+ # This program is free software; you can redistribute it and/or modify it
+@@ -2232,6 +2232,7 @@ static struct ethtool_ops rtl8168_ethtool_ops = {
+ .set_settings = rtl8168_set_settings,
+ .get_msglevel = rtl8168_get_msglevel,
+ .set_msglevel = rtl8168_set_msglevel,
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3,3,0)
+ .get_rx_csum = rtl8168_get_rx_csum,
+ .set_rx_csum = rtl8168_set_rx_csum,
+ .get_tx_csum = rtl8168_get_tx_csum,
+@@ -2242,6 +2243,7 @@ static struct ethtool_ops rtl8168_ethtool_ops = {
+ .get_tso = ethtool_op_get_tso,
+ .set_tso = ethtool_op_set_tso,
+ #endif
++#endif
+ .get_regs = rtl8168_get_regs,
+ .get_wol = rtl8168_get_wol,
+ .set_wol = rtl8168_set_wol,
diff --git a/net-misc/r8168/r8168-8.028.00.ebuild b/net-misc/r8168/r8168-8.028.00.ebuild
index 3ec954ea21b6..6de7a4e1fb05 100644
--- a/net-misc/r8168/r8168-8.028.00.ebuild
+++ b/net-misc/r8168/r8168-8.028.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/r8168-8.028.00.ebuild,v 1.2 2012/03/31 17:32:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/r8168-8.028.00.ebuild,v 1.3 2012/04/04 16:53:04 joker Exp $
EAPI=4
@@ -21,6 +21,10 @@ CONFIG_CHECK="!R8169"
ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-linux-3.3-compat.patch"
+}
+
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERNELDIR=${KV_DIR}"