summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-18 02:00:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-18 02:00:21 +0000
commitf736299671eb1d12c52b17f23b7fc373d83ea511 (patch)
tree2006d9817d11f26ed9c828a2709d166a2a42db15 /net-misc/rsync
parentfix bad directory reading for bug #85699; tidy (diff)
downloadgentoo-2-f736299671eb1d12c52b17f23b7fc373d83ea511.tar.gz
gentoo-2-f736299671eb1d12c52b17f23b7fc373d83ea511.tar.bz2
gentoo-2-f736299671eb1d12c52b17f23b7fc373d83ea511.zip
old
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/files/digest-rsync-2.6.0-r33
-rw-r--r--net-misc/rsync/rsync-2.6.0-r3.ebuild82
2 files changed, 0 insertions, 85 deletions
diff --git a/net-misc/rsync/files/digest-rsync-2.6.0-r3 b/net-misc/rsync/files/digest-rsync-2.6.0-r3
deleted file mode 100644
index 42e8d077802b..000000000000
--- a/net-misc/rsync/files/digest-rsync-2.6.0-r3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3f24bf31aec0a657eb3b6844c3f09f21 rsync-2.6.0.tar.gz 464920
-MD5 a399e227a18ea3f2eb5aa2b401006d2d rsync-2.5.6-proxy-auth-1.patch 4353
-MD5 16cbffdcd9c6c318761c6c0d86400197 rsync-2.6.0-acl.diff.bz2 60721
diff --git a/net-misc/rsync/rsync-2.6.0-r3.ebuild b/net-misc/rsync/rsync-2.6.0-r3.ebuild
deleted file mode 100644
index 462c99fc2745..000000000000
--- a/net-misc/rsync/rsync-2.6.0-r3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.0-r3.ebuild,v 1.11 2005/02/11 05:20:27 vapier Exp $
-
-inherit eutils flag-o-matic gcc gnuconfig
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="http://rsync.samba.org/"
-SRC_URI="http://rsync.samba.org/ftp/rsync/old-versions/${P}.tar.gz
- http://www.imada.sdu.dk/~bardur/personal/40-patches/rsync-proxy-auth/rsync-2.5.6-proxy-auth-1.patch
- acl? ( http://www.saout.de/misc/${P}-acl.diff.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="build static acl"
-
-RDEPEND="virtual/libc
- !build? ( >=dev-libs/popt-1.5 )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- acl? ( sys-apps/acl )"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- cd ${S}
- epatch ${FILESDIR}/${PV}-sanitize.patch
- epatch "${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch"
- use acl && epatch ${DISTDIR}/${P}-acl.diff.bz2
-
- # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
- # configure option doesn't work
- sed -i \
- -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h \
- || die "sed rsync.h failed"
- # yes, updating the man page is very important.
- sed -i \
- -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' \
- rsync.1 rsyncd.conf.5 \
- || die "sed rsyncd.conf.5 failed"
-
- # apply security patch from bug #60309
- epatch ${FILESDIR}/${PN}-pathsanitize.patch
-
- gnuconfig_update
-}
-
-src_compile() {
- [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
- use static && append-ldflags -static
- export LDFLAGS
- econf $(use_with build included-popt) \
- $(use_with acl acl-support) || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- insinto /etc/conf.d && newins "${FILESDIR}/rsyncd.conf.d" rsyncd
- exeinto /etc/init.d && newexe "${FILESDIR}/rsyncd.init.d" rsyncd
- if ! use build ; then
- dodir /etc/rsync
- dodoc NEWS OLDNEWS README TODO tech_report.tex
- if [ ! -e /etc/rsync/rsyncd.conf ] ; then
- insinto /etc/rsync
- doins "${FILESDIR}/rsyncd.conf"
- fi
- else
- rm -rf "${D}/usr/share"
- fi
-}
-
-pkg_postinst() {
- ewarn "Please make sure you do NOT disable the rsync server running"
- ewarn "in a chroot. Please check /etc/rsync/rsyncd.conf and make sure"
- ewarn "it says: use chroot = yes"
-
- einfo 'This patch enables usage of user:pass@proxy.foo:port'
- einfo 'in the RSYNC_PROXY environment variable to support'
- einfo 'the "Basic" proxy authentication scheme if you are'
- einfo 'behind a password protected HTTP proxy.'
-}