summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-24 00:19:59 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-24 00:19:59 +0000
commitf17a236ed43dff887bee6b60ff496694e5584676 (patch)
tree999b1875340eee01fa976fe5b3e37f39ac9ddda6 /net-misc/shout
parentFixed ebuild so that it installs files in an FHS compliant manner. (diff)
downloadgentoo-2-f17a236ed43dff887bee6b60ff496694e5584676.tar.gz
gentoo-2-f17a236ed43dff887bee6b60ff496694e5584676.tar.bz2
gentoo-2-f17a236ed43dff887bee6b60ff496694e5584676.zip
Made shout FHS compliant.
Diffstat (limited to 'net-misc/shout')
-rw-r--r--net-misc/shout/ChangeLog9
-rw-r--r--net-misc/shout/files/digest-shout-0.8.0-r11
-rw-r--r--net-misc/shout/files/variables.diff20
-rw-r--r--net-misc/shout/shout-0.8.0-r1.ebuild40
4 files changed, 69 insertions, 1 deletions
diff --git a/net-misc/shout/ChangeLog b/net-misc/shout/ChangeLog
index 85e214157679..2c744ea841ae 100644
--- a/net-misc/shout/ChangeLog
+++ b/net-misc/shout/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/shout
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/shout/ChangeLog,v 1.2 2002/07/09 10:53:59 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/shout/ChangeLog,v 1.3 2002/07/24 00:19:59 raker Exp $
+
+*shout-0.8.0-r1 (23 Jul 2002)
+
+ 23 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ shout-0.8.0-r1.ebuild, files/digest-shout-0.8.0-r1, files/variables.diff :
+
+ Made shout FHS compliant.
*shout-0.8.0 (1 Feb 2002)
diff --git a/net-misc/shout/files/digest-shout-0.8.0-r1 b/net-misc/shout/files/digest-shout-0.8.0-r1
new file mode 100644
index 000000000000..96ea0563730a
--- /dev/null
+++ b/net-misc/shout/files/digest-shout-0.8.0-r1
@@ -0,0 +1 @@
+MD5 d44604a2235532e31e10d2d0e4740f20 shout-0.8.0.tar.gz 66394
diff --git a/net-misc/shout/files/variables.diff b/net-misc/shout/files/variables.diff
new file mode 100644
index 000000000000..f0c71c4c661b
--- /dev/null
+++ b/net-misc/shout/files/variables.diff
@@ -0,0 +1,20 @@
+diff -urN shout-0.8.0/Makefile.in shout-0.8.0-modified/Makefile.in
+--- shout-0.8.0/Makefile.in Thu Apr 20 02:31:50 2000
++++ shout-0.8.0-modified/Makefile.in Tue Jul 23 19:14:36 2002
+@@ -9,11 +9,11 @@
+ srcdir = @srcdir@
+ VPATH = @srcdir@
+
+-prefix = @prefix@/icecast
+-exec_prefix = @prefix@
+-bindir = @BINDIR@
+-etcdir = @ETCDIR@
+-logdir = @LOGDIR@
++prefix = /usr
++exec_prefix = /usr
++bindir = /usr/bin
++etcdir = /etc/shout
++logdir = /var/log/shout
+
+ DEFS = -I. @DEFS@
+
diff --git a/net-misc/shout/shout-0.8.0-r1.ebuild b/net-misc/shout/shout-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..8caefbc900f8
--- /dev/null
+++ b/net-misc/shout/shout-0.8.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/shout/shout-0.8.0-r1.ebuild,v 1.1 2002/07/24 00:19:59 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Shout is a prgram for creatinga mp3 stream for use with icecast or shoutcast."
+SRC_URI="http://www.icecast.org/releases/${P}.tar.gz"
+HOMEPAGE="http://www.icecast.org"
+KEYWORDS="x86"
+LICENSE="GPL"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/variables.diff
+
+}
+
+src_compile() {
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --sysconfdir=/etc/shout \
+ --localstatedir=/var \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc BUGS CREDITS README.shout TODO
+
+}