summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2008-11-07 19:04:14 +0000
committerGustavo Felisberto <humpback@gentoo.org>2008-11-07 19:04:14 +0000
commit9844c82bfc840a029a0a25c229daa62065ae82be (patch)
treee4427ed8de45617bc62b1b41a78628f1ddb9516a /net-misc/sobby
parentbump (diff)
downloadgentoo-2-9844c82bfc840a029a0a25c229daa62065ae82be.tar.gz
gentoo-2-9844c82bfc840a029a0a25c229daa62065ae82be.tar.bz2
gentoo-2-9844c82bfc840a029a0a25c229daa62065ae82be.zip
bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'net-misc/sobby')
-rw-r--r--net-misc/sobby/ChangeLog7
-rw-r--r--net-misc/sobby/sobby-0.4.5.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-misc/sobby/ChangeLog b/net-misc/sobby/ChangeLog
index de62a8e389dc..92edd1070d15 100644
--- a/net-misc/sobby/ChangeLog
+++ b/net-misc/sobby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/sobby
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/ChangeLog,v 1.14 2008/10/10 10:35:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/ChangeLog,v 1.15 2008/11/07 19:04:14 humpback Exp $
+
+*sobby-0.4.5 (07 Nov 2008)
+
+ 07 Nov 2008; Gustavo Felisberto <humpback@gentoo.org> +sobby-0.4.5.ebuild:
+ Bump.
10 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> sobby-0.4.4.ebuild:
Fix build dependencies.
diff --git a/net-misc/sobby/sobby-0.4.5.ebuild b/net-misc/sobby/sobby-0.4.5.ebuild
new file mode 100644
index 000000000000..401ffe7f6d69
--- /dev/null
+++ b/net-misc/sobby/sobby-0.4.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/sobby-0.4.5.ebuild,v 1.1 2008/11/07 19:04:14 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Standalone Obby server"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi"
+
+RDEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ >=dev-cpp/libxmlpp-2.6
+ >=net-libs/obby-0.4.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-libs/obby avahi ; then
+ eerror "Please reinstall net-libs/obby with the avahi USE-flag enabled"
+ eerror "for zeroconf/DNS-SD support or disable it for this package."
+ die "Missing 'avahi' USE-flag for net-libs/obby"
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable avahi zeroconf) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ newconfd "${FILESDIR}/sobby-conf-0.4.3" sobby
+ newinitd "${FILESDIR}/sobby-init-0.4.3" sobby
+}
+
+pkg_postinst() {
+ elog "To start sobby, you can use the init script:"
+ elog " /etc/init.d/sobby start"
+ elog ""
+ elog "Please check the configuration in /etc/conf.d/sobby"
+ elog "before you start sobby"
+}