summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-29 19:47:26 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-29 19:47:26 +0000
commit5fe3a0885fae90f32f92300f0f1676ee7c53c376 (patch)
treea47a878db8273918f1e997c7302b1b96862a7166 /net-misc/socat
parentVersion bumped (diff)
downloadgentoo-2-5fe3a0885fae90f32f92300f0f1676ee7c53c376.tar.gz
gentoo-2-5fe3a0885fae90f32f92300f0f1676ee7c53c376.tar.bz2
gentoo-2-5fe3a0885fae90f32f92300f0f1676ee7c53c376.zip
Version bumped
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/ChangeLog7
-rw-r--r--net-misc/socat/Manifest4
-rw-r--r--net-misc/socat/files/digest-socat-1.3.2.01
-rw-r--r--net-misc/socat/socat-1.3.2.0.ebuild66
4 files changed, 75 insertions, 3 deletions
diff --git a/net-misc/socat/ChangeLog b/net-misc/socat/ChangeLog
index 7252b64ebdf3..fcc4eb6b446a 100644
--- a/net-misc/socat/ChangeLog
+++ b/net-misc/socat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/socat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.4 2003/06/25 20:25:55 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.5 2003/07/29 19:47:10 mholzer Exp $
+
+*socat-1.3.2.0 (30 Jul 2003)
+
+ 30 Jul 2003; Martin Holzer <mholzer@gentoo.org> socat-1.3.2.0.ebuild:
+ Version bumped
*socat-1.3.1.0 (25 Jun 2003)
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index 12c4a495817c..a39f14732ede 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,7 +1,7 @@
-MD5 68d76d46de3700eb885a847a3a4e9ae1 ChangeLog 546
+MD5 8fe34c65c1a0f2f37ba9fc2316d45a38 ChangeLog 666
MD5 0ebf52a7604fcd03077a74b95ddcb1ce socat-1.3.0.1.ebuild 1619
MD5 40dab67cd288c5ece83f08940ca3df22 socat-1.3.1.0.ebuild 1623
-MD5 40dab67cd288c5ece83f08940ca3df22 socat-1.3.2.0.ebuild 1623
+MD5 b25035e2fc6b792dd74b4bb355d6fc17 socat-1.3.2.0.ebuild 1539
MD5 506ab9d342949b2589479d2c61ff4038 files/digest-socat-1.3.0.1 66
MD5 3716109facbed0db26250a872dd6eda1 files/digest-socat-1.3.1.0 66
MD5 a7603fa9eae81b2f857ba740fedb09d7 files/digest-socat-1.3.2.0 66
diff --git a/net-misc/socat/files/digest-socat-1.3.2.0 b/net-misc/socat/files/digest-socat-1.3.2.0
new file mode 100644
index 000000000000..7cd1b2c17692
--- /dev/null
+++ b/net-misc/socat/files/digest-socat-1.3.2.0
@@ -0,0 +1 @@
+MD5 5b845a84d2c53dbf9ec412ea558d86ec socat-1.3.2.0.tar.bz2 226132
diff --git a/net-misc/socat/socat-1.3.2.0.ebuild b/net-misc/socat/socat-1.3.2.0.ebuild
new file mode 100644
index 000000000000..9c1e2e297346
--- /dev/null
+++ b/net-misc/socat/socat-1.3.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.3.2.0.ebuild,v 1.1 2003/07/29 19:47:10 mholzer Exp $
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+SRC_URI="http://www.dest-unreach.org/${PN}/download/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="ssl readline ipv6"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ virtual/glibc"
+RDEPEND="virtual/glibc"
+
+S="${WORKDIR}/socat-1.3"
+
+src_compile() {
+
+ # Construct the config options for the optional features.
+ local myconf
+ use ssl || myconf="--disable-openssl"
+ use readline || myconf="${myconf} --disable-readline"
+ use ipv6 || myconf="${myconf} --disable-ip6"
+
+ sed -i "s:-Wall:${CFLAGS} -Wall:" Makefile.in
+ econf ${myconf}
+
+ # Calculating dependencies
+ # (this seems to error out (due to gcc3?) but compiles work
+ # nonetheless)
+ make depend
+
+ # Starting the compile
+ emake || die
+}
+
+src_install() {
+ # The original install target is a bit broken when installing
+ # into temporary roots.
+
+ # The docs.
+ dodoc BUGREPORTS CHANGES COPYING* DEVELOPMENT
+ dodoc EXAMPLES FAQ FILES PORTING README
+ dodoc SECURITY VERSION
+ dodoc xio.help
+
+ # The example scripts
+ dodoc daemon.sh ftp.sh mail.sh
+
+ # The html docs
+ dohtml socat.html
+
+ # The manpage
+ doman socat.1
+
+ # And the executables
+ exeinto /usr/bin
+ doexe socat
+ doexe procan
+ doexe filan
+}