summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-09-20 02:45:27 +0000
committerDaniel Goller <morfic@gentoo.org>2004-09-20 02:45:27 +0000
commit5407c866d45a9c173ff2cb6f9cd4d9ea191c840e (patch)
tree2e7c5c3879c6a2d3ecf1cff332fd3e422f95c390 /net-misc/tightvnc
parentstable on ppc64, bug #63661 (Manifest recommit) (diff)
downloadgentoo-2-5407c866d45a9c173ff2cb6f9cd4d9ea191c840e.tar.gz
gentoo-2-5407c866d45a9c173ff2cb6f9cd4d9ea191c840e.tar.bz2
gentoo-2-5407c866d45a9c173ff2cb6f9cd4d9ea191c840e.zip
readding 1.3 all nice and sane now
Diffstat (limited to 'net-misc/tightvnc')
-rw-r--r--net-misc/tightvnc/Manifest2
-rw-r--r--net-misc/tightvnc/files/digest-tightvnc-1.3_alpha51
-rw-r--r--net-misc/tightvnc/tightvnc-1.3_alpha5.ebuild70
3 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/tightvnc/Manifest b/net-misc/tightvnc/Manifest
index 246a7c9179fb..bb795d831c32 100644
--- a/net-misc/tightvnc/Manifest
+++ b/net-misc/tightvnc/Manifest
@@ -1,6 +1,7 @@
MD5 4da94dff5ba93bb47826ce3f578f1cca tightvnc-1.2.8.ebuild 1605
MD5 fdc7480acff3391ab1a511dda2774d78 tightvnc-1.2.9-r1.ebuild 1716
MD5 778524cf028a58d7a58572b693d953df tightvnc-4.0_beta20031113.ebuild 2656
+MD5 7a7c3833a10e8394c92f316b6b03d2f7 tightvnc-1.3_alpha5.ebuild 2034
MD5 3b72b5d529cf5558e7915c9bafa9aed8 ChangeLog 5106
MD5 37236013e0d26d43c6bff35a8a48e8ec metadata.xml 220
MD5 8a5968ab6bd3fdd835fe13c589e1cc4d files/digest-tightvnc-4.0_beta20031113 367
@@ -10,6 +11,7 @@ MD5 1ddf3e5ec0121aaca487686a7bb6dd55 files/x86.patch 1613
MD5 b801cfcb63f9c7c9299dd4919ba332b9 files/tightvnc-1.2.9-imake-tmpdir.patch 956
MD5 fba34335858b6b6b681a660c7c74273f files/tightvnc-gentoo.diff 636
MD5 57e1cd8ec91d0e8abbea5b267a6f1fb6 files/tightvnc-1.2.8-gentoo.security.patch 771
+MD5 4e84efe3429797daa190b7d29e9b5857 files/digest-tightvnc-1.3_alpha5 78
MD5 70b94ceb3134edc412d70768b55661aa files/tightvnc-1.3_alpha5-gcc34.patch 1540
MD5 eb14fedcc3608a1384ef1cba6dbbf103 files/tightvnc-1.2.7-gentoo.diff 657
MD5 57e1cd8ec91d0e8abbea5b267a6f1fb6 files/tightvnc-1.2.9-gentoo.security.patch 771
diff --git a/net-misc/tightvnc/files/digest-tightvnc-1.3_alpha5 b/net-misc/tightvnc/files/digest-tightvnc-1.3_alpha5
new file mode 100644
index 000000000000..cacf52526b8e
--- /dev/null
+++ b/net-misc/tightvnc/files/digest-tightvnc-1.3_alpha5
@@ -0,0 +1 @@
+MD5 bdcae6956ae382e5aca6cb708d085766 tightvnc-1.3dev5_unixsrc.tar.bz2 1762386
diff --git a/net-misc/tightvnc/tightvnc-1.3_alpha5.ebuild b/net-misc/tightvnc/tightvnc-1.3_alpha5.ebuild
new file mode 100644
index 000000000000..5558975ae65e
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.3_alpha5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Foundation, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.3_alpha5.ebuild,v 1.6 2004/09/20 02:45:27 morfic Exp $
+
+inherit eutils
+
+IUSE="java tcpd"
+
+DLFILE="`echo ${P} | sed s:_alpha:dev:`"
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${DLFILE}_unixsrc.tar.bz2"
+HOMEPAGE="http://www.tightvnc.com/"
+
+#can't test on anything but x86
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/x11
+ ~media-libs/jpeg-6b
+ sys-libs/zlib
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+ !net-misc/vnc"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ java? ( || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 ) )"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gentoo.security.patch
+ epatch ${FILESDIR}/${P}-imake-tmpdir.patch
+ epatch ${FILESDIR}/x86.patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
+src_compile() {
+ local CDEBUGFLAGS="${CFLAGS}"
+
+ use amd64 && CDEBUGFLAGS="${CDEBUGFLAGS} -m32 \
+ -L/emul/linux/x86/lib \
+ -L/emul/linux/x86/usr/lib/gcc-lib/i386-pc-linux-gnu/3.2.3 \
+ -L/emul/linux/x86/usr/lib -L/emul/linux/x86/usr/X11R6/lib"
+
+ xmkmf -a || die "xmkmf failed"
+
+ make CDEBUGFLAGS="${CDEBUGFLAGS}" World || die "make World failed"
+ cd Xvnc && ./configure || die "Configure failed."
+
+ if use tcpd; then
+ make EXTRA_LIBRARIES="-lwrap -lnss_nis" CDEBUGFLAGS="${CDEBUGFLAGS}" EXTRA_DEFINES="-DUSE_LIBWRAP=1" || die
+ else
+ make CDEBUGFLAGS="${CDEBUGFLAGS}" || die
+ fi
+}
+
+src_install() {
+ # the web based interface and the java viewer need the java class files
+ insinto /usr/share/tightvnc/classes ; doins classes/*
+
+ dodir /usr/share/man/man1 /usr/bin
+ ./vncinstall ${D}/usr/bin ${D}/usr/share/man || die "vncinstall failed"
+
+ dodoc ChangeLog README WhatsNew
+ use java && dodoc ${FILESDIR}/README.JavaViewer
+ newdoc vncviewer/README README.vncviewer
+}