summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2006-08-06 23:19:28 +0000
committerJason Wever <weeve@gentoo.org>2006-08-06 23:19:28 +0000
commitb47798a62455784b1438d54633fe43309da738eb (patch)
treebead7fadbcd6e112f31e3f6a1756d84029245c3b /net-misc/tightvnc
parentRemove PDO-Firebird driver, broken and unmaintained upstream. (diff)
downloadgentoo-2-b47798a62455784b1438d54633fe43309da738eb.tar.gz
gentoo-2-b47798a62455784b1438d54633fe43309da738eb.tar.bz2
gentoo-2-b47798a62455784b1438d54633fe43309da738eb.zip
Stable on SPARC wrt bug #138779. Also add a patch to fix display corruption in vncserver for SPARC and PPC.
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'net-misc/tightvnc')
-rw-r--r--net-misc/tightvnc/ChangeLog7
-rw-r--r--net-misc/tightvnc/files/tightvnc-ppcsparc-server.patch30
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.9-r2.ebuild5
3 files changed, 39 insertions, 3 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index 9bcb4d203b61..360e934a1080 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.70 2006/08/05 08:12:26 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.71 2006/08/06 23:19:28 weeve Exp $
+
+ 06 Aug 2006; Jason Wever <weeve@gentoo.org>
+ +files/tightvnc-ppcsparc-server.patch, tightvnc-1.2.9-r2.ebuild:
+ Stable on SPARC wrt bug #138779. Also add a patch to fix display corruption
+ in vncserver for SPARC and PPC.
05 Aug 2006; Michael Hanselmann <hansmi@gentoo.org>
tightvnc-1.2.9-r2.ebuild:
diff --git a/net-misc/tightvnc/files/tightvnc-ppcsparc-server.patch b/net-misc/tightvnc/files/tightvnc-ppcsparc-server.patch
new file mode 100644
index 000000000000..b2124b07e0ff
--- /dev/null
+++ b/net-misc/tightvnc/files/tightvnc-ppcsparc-server.patch
@@ -0,0 +1,30 @@
+--- vnc-3.3.3r2.orig/Xvnc/programs/Xserver/include/servermd.h Mon Jul 28 10:17:34 1997
++++ vnc-3.3.3r2/Xvnc/programs/Xserver/include/servermd.h Tue Dec 12 13:40:57 2000
+@@ -380,6 +380,27 @@
+ #define GETLEFTBITS_ALIGNMENT 1
+
+ #endif /* linux/m68k */
++
++#if defined (linux) && defined (PPC)
++
++#define IMAGE_BYTE_ORDER MSBFirst
++#define BITMAP_BIT_ORDER MSBFirst
++#define GLYPHPADBYTES 4
++#define GETLEFTBITS_ALIGNMENT 1
++
++#define LARGE_INSTRUCTION_CACHE
++#define FAST_CONSTANT_OFFSET_MODE
++
++#endif /* linux/PPC */
++
++#if defined (linux) && defined (__sparc__)
++
++#define IMAGE_BYTE_ORDER MSBFirst
++#define BITMAP_BIT_ORDER MSBFirst
++#define GLYPHPADBYTES 4
++#define GETLEFTBITS_ALIGNMENT 1
++
++#endif /* linux/__sparc__ */
+
+ #ifdef sgi
+
diff --git a/net-misc/tightvnc/tightvnc-1.2.9-r2.ebuild b/net-misc/tightvnc/tightvnc-1.2.9-r2.ebuild
index f12ee85f27d9..19883266673d 100644
--- a/net-misc/tightvnc/tightvnc-1.2.9-r2.ebuild
+++ b/net-misc/tightvnc/tightvnc-1.2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.2.9-r2.ebuild,v 1.3 2006/08/05 08:12:26 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.2.9-r2.ebuild,v 1.4 2006/08/06 23:19:28 weeve Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ DESCRIPTION="A great client/server software package allowing remote network acce
SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
HOMEPAGE="http://www.tightvnc.com/"
-KEYWORDS="~alpha ~amd64 ppc ~sparc x86"
+KEYWORDS="~alpha ~amd64 ppc sparc x86"
LICENSE="GPL-2"
SLOT="0"
@@ -46,6 +46,7 @@ src_unpack() {
epatch ${FILESDIR}/x86.patch
epatch ${FILESDIR}/${P}-amd64.patch
epatch ${FILESDIR}/${P}-gentoo-2.diff
+ epatch ${FILESDIR}/${PN}-ppcsparc-server.patch
}
src_compile() {