summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2008-04-20 14:36:03 +0000
committerPeter Weller <welp@gentoo.org>2008-04-20 14:36:03 +0000
commit269a4dbaa63f198a420238cc5a748693d0164c87 (patch)
tree6ea3ddf34bc93d72a7b428aaa9e38d4b3210c8ef /net-misc/twitux/twitux-0.61.ebuild
parentInitial addition. Thanks to serkan for the original ebuild which was then imp... (diff)
downloadgentoo-2-269a4dbaa63f198a420238cc5a748693d0164c87.tar.gz
gentoo-2-269a4dbaa63f198a420238cc5a748693d0164c87.tar.bz2
gentoo-2-269a4dbaa63f198a420238cc5a748693d0164c87.zip
Initial import
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/twitux/twitux-0.61.ebuild')
-rw-r--r--net-misc/twitux/twitux-0.61.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/twitux/twitux-0.61.ebuild b/net-misc/twitux/twitux-0.61.ebuild
new file mode 100644
index 000000000000..44b4b5a48427
--- /dev/null
+++ b/net-misc/twitux/twitux-0.61.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/twitux/twitux-0.61.ebuild,v 1.1 2008/04/20 14:36:03 welp Exp $
+
+EAPI=1
+
+DESCRIPTION="A Twitter client for the Gnome desktop"
+HOMEPAGE="http://live.gnome.org/DanielMorales/Twitux"
+SRC_URI="mirror://sourceforge/twitux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="aspell dbus gnome-keyring"
+
+DEPEND="net-libs/libsoup:2.4
+ dev-libs/libxml2
+ gnome-base/libglade
+ gnome-base/libgnome
+ gnome-base/gconf
+ x11-libs/gtk+:2
+ dev-libs/dbus-glib
+ spell? ( app-text/aspell )
+ gnome-keyring? ( gnome-base/gnome-keyring )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf $(use_enable aspell) \
+ $(use_enable gnome-keyring) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+}