summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-28 09:37:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-28 09:37:05 +0000
commit97c53e730f189e1554a0c24761c965514075b631 (patch)
tree572611bba8db35006ab14e6136ade13fbc9f395a /net-misc/udpcast
parentArptables is used to set up, maintain, and inspect the tables of ARP rules in... (diff)
downloadgentoo-2-97c53e730f189e1554a0c24761c965514075b631.tar.gz
gentoo-2-97c53e730f189e1554a0c24761c965514075b631.tar.bz2
gentoo-2-97c53e730f189e1554a0c24761c965514075b631.zip
initial ebuild #42816
Diffstat (limited to 'net-misc/udpcast')
-rw-r--r--net-misc/udpcast/ChangeLog8
-rw-r--r--net-misc/udpcast/files/digest-udpcast-200402221
-rw-r--r--net-misc/udpcast/metadata.xml13
-rw-r--r--net-misc/udpcast/udpcast-20040222.ebuild39
4 files changed, 61 insertions, 0 deletions
diff --git a/net-misc/udpcast/ChangeLog b/net-misc/udpcast/ChangeLog
new file mode 100644
index 000000000000..3321edbaac12
--- /dev/null
+++ b/net-misc/udpcast/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/udpcast
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udpcast/ChangeLog,v 1.1 2004/02/28 09:37:05 vapier Exp $
+
+*udpcast-20040222 (28 Feb 2004)
+
+ 28 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Daniel Fullmer #42816.
diff --git a/net-misc/udpcast/files/digest-udpcast-20040222 b/net-misc/udpcast/files/digest-udpcast-20040222
new file mode 100644
index 000000000000..11f8ccd01a49
--- /dev/null
+++ b/net-misc/udpcast/files/digest-udpcast-20040222
@@ -0,0 +1 @@
+MD5 76bdc1af944447a969194dbd3e856c26 udpcast-20040222.tar.gz 67161
diff --git a/net-misc/udpcast/metadata.xml b/net-misc/udpcast/metadata.xml
new file mode 100644
index 000000000000..526d84b8a3cd
--- /dev/null
+++ b/net-misc/udpcast/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>
+UDPcast is a file transfer tool that can send data simultaneously to
+many destinations on a LAN. This can for instance be used to install
+entire classrooms of PC's at once. The advantage of UDPcast over using
+other methods (nfs, ftp, whatever) is that UDPcast uses Ethernet's
+multicast abilities: it won't take longer to install 15 machines than it
+would to install just 2.
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/udpcast/udpcast-20040222.ebuild b/net-misc/udpcast/udpcast-20040222.ebuild
new file mode 100644
index 000000000000..734f0e4cff42
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20040222.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udpcast/udpcast-20040222.ebuild,v 1.1 2004/02/28 09:37:05 vapier Exp $
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="http://udpcast.linux.lu/"
+SRC_URI="http://udpcast.linux.lu/current/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ dev-lang/perl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # sed the manpages to only depend on one because the rule that
+ # builds them makes them both ... however, if we build in parallel,
+ # the command may be run twice thus clobbering each other
+ sed -i \
+ -e 's:/sbin:/bin:' \
+ -e "/^CFLAGS =/s:$: ${CFLAGS}:" \
+ -e 's:udp-receiver\.1 udp-sender\.1:udp-receiver.1:' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc Changelog.txt
+}