summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-11-24 19:41:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-11-24 19:41:43 +0000
commitbccf32215ca02e84af6391d450b22d0046205a59 (patch)
tree04034280efbacfa331c0b8c72ebb7ce2e9999530 /net-misc/vidalia
parentVersion bump. (diff)
downloadgentoo-2-bccf32215ca02e84af6391d450b22d0046205a59.tar.gz
gentoo-2-bccf32215ca02e84af6391d450b22d0046205a59.tar.bz2
gentoo-2-bccf32215ca02e84af6391d450b22d0046205a59.zip
Added upstream alpha
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/vidalia')
-rw-r--r--net-misc/vidalia/ChangeLog8
-rw-r--r--net-misc/vidalia/vidalia-0.2.15.ebuild13
-rw-r--r--net-misc/vidalia/vidalia-0.3.0_alpha.ebuild42
3 files changed, 56 insertions, 7 deletions
diff --git a/net-misc/vidalia/ChangeLog b/net-misc/vidalia/ChangeLog
index 692f9e24d5bc..7b6755d54001 100644
--- a/net-misc/vidalia/ChangeLog
+++ b/net-misc/vidalia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vidalia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.25 2011/11/24 19:24:12 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.26 2011/11/24 19:41:43 blueness Exp $
+
+*vidalia-0.3.0_alpha (24 Nov 2011)
+
+ 24 Nov 2011; Anthony G. Basile <blueness@gentoo.org> vidalia-0.2.15.ebuild,
+ +vidalia-0.3.0_alpha.ebuild:
+ Added upstream alpha
*vidalia-0.2.15 (24 Nov 2011)
diff --git a/net-misc/vidalia/vidalia-0.2.15.ebuild b/net-misc/vidalia/vidalia-0.2.15.ebuild
index b23b2fcfb1be..d698cb8e7752 100644
--- a/net-misc/vidalia/vidalia-0.2.15.ebuild
+++ b/net-misc/vidalia/vidalia-0.2.15.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.2.15.ebuild,v 1.1 2011/11/24 19:24:12 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.2.15.ebuild,v 1.2 2011/11/24 19:41:43 blueness Exp $
-EAPI="4"
+EAPI=4
inherit eutils qt4-r2 cmake-utils
# cmake-utils needs to be last, so we get its src_compile()
@@ -23,14 +23,15 @@ RDEPEND="${DEPEND}
DOCS="CHANGELOG CREDITS README"
pkg_postinst() {
- echo
+ ewarn
if use tor; then
ewarn "To have vidalia starting tor, you probably have to copy"
- ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
- ewarn "the settings there and change the socks. Also, in vidalia"
- ewarn "change the default user under which tor will run."
+ ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
+ ewarn "the settings there and change the socks. Also, in vidalia"
+ ewarn "change the default user under which tor will run."
else
ewarn "You have disabled tor USE flag, which means you need to "
ewarn "configure tor on a different host."
fi
+ ewarn
}
diff --git a/net-misc/vidalia/vidalia-0.3.0_alpha.ebuild b/net-misc/vidalia/vidalia-0.3.0_alpha.ebuild
new file mode 100644
index 000000000000..f50d03daf693
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.3.0_alpha.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.3.0_alpha.ebuild,v 1.1 2011/11/24 19:41:43 blueness Exp $
+
+EAPI=4
+
+inherit eutils versionator qt4-r2 cmake-utils
+# cmake-utils needs to be last, so we get its src_compile()
+
+MY_PV="$(replace_version_separator 3 -)"
+MY_PF="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_PF}"
+S="${S%-alpha}"
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="https://www.torproject.org/projects/vidalia.html.en"
+SRC_URI="https://www.torproject.org/dist/${PN}/${MY_PF}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 ) openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug +tor"
+
+DEPEND="x11-libs/qt-gui:4[debug?]"
+RDEPEND="${DEPEND}
+ tor? ( net-misc/tor )"
+
+DOCS="CHANGELOG CREDITS README"
+
+pkg_postinst() {
+ ewarn
+ if use tor; then
+ ewarn "To have vidalia starting tor, you probably have to copy"
+ ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
+ ewarn "the settings there and change the socks. Also, in vidalia"
+ ewarn "change the default user under which tor will run."
+ else
+ ewarn "You have disabled tor USE flag, which means you need to "
+ ewarn "configure tor on a different host."
+ fi
+ ewarn
+}