summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-05-28 14:12:05 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-05-28 14:12:05 +0000
commit14c6c5559f91fed2deca4f87b9c7dc8ca85b8e69 (patch)
tree6c636fd455e60a468451cb61688cfb9e74ab3948 /net-misc/whois/whois-5.0.16.ebuild
parentVersion bump (diff)
downloadgentoo-2-14c6c5559f91fed2deca4f87b9c7dc8ca85b8e69.tar.gz
gentoo-2-14c6c5559f91fed2deca4f87b9c7dc8ca85b8e69.tar.bz2
gentoo-2-14c6c5559f91fed2deca4f87b9c7dc8ca85b8e69.zip
Version bump. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-misc/whois/whois-5.0.16.ebuild')
-rw-r--r--net-misc/whois/whois-5.0.16.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-misc/whois/whois-5.0.16.ebuild b/net-misc/whois/whois-5.0.16.ebuild
deleted file mode 100644
index f4b1de8497f9..000000000000
--- a/net-misc/whois/whois-5.0.16.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.16.ebuild,v 1.2 2012/08/18 23:46:41 vapier Exp $
-
-EAPI=4
-inherit eutils toolchain-funcs
-
-MY_P=${P/-/_}
-DESCRIPTION="improved Whois Client"
-HOMEPAGE="http://www.linux.it/~md/software/"
-SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="iconv idn nls"
-RESTRICT="test" #59327
-
-RDEPEND="idn? ( net-dns/libidn )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- >=dev-lang/perl-5"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
-
- if use nls ; then
- sed -i -e 's:#\(.*pos\):\1:' Makefile || die
- else
- sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die
-
- # don't generate po files when nls is disabled (bug #419889)
- sed -i -e '/^all:/s/ pos//' \
- -e '/^install:/s/ install-pos//' Makefile || die
- fi
-}
-
-src_configure() { :;} # expected no-op
-
-src_compile() {
- unset HAVE_ICONV HAVE_LIBIDN
- use iconv && export HAVE_ICONV=1
- use idn && export HAVE_LIBIDN=1
- tc-export CC
- emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
-}
-
-src_install() {
- emake BASEDIR="${ED}" prefix=/usr install
- insinto /etc
- doins whois.conf
- dodoc README debian/changelog
-
- if [[ ${USERLAND} != "GNU" ]]; then
- mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1 || die
- mv "${ED}"/usr/bin/{whois,mdwhois} || die
- fi
-}