summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-23 09:32:49 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-23 09:32:49 +0000
commit0463f8481afff6a235d0c3c8596df13f7792c6b9 (patch)
treebb903272aea2e69898c6430b2f0f7520984686c9 /net-misc/whois
parentCleanup. (diff)
downloadgentoo-2-0463f8481afff6a235d0c3c8596df13f7792c6b9.tar.gz
gentoo-2-0463f8481afff6a235d0c3c8596df13f7792c6b9.tar.bz2
gentoo-2-0463f8481afff6a235d0c3c8596df13f7792c6b9.zip
Version bump.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/whois-5.0.19.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 35f16099baea..80a479c6a361 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.181 2012/08/18 23:46:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.182 2012/09/23 09:32:49 radhermit Exp $
+
+*whois-5.0.19 (23 Sep 2012)
+
+ 23 Sep 2012; Tim Harder <radhermit@gentoo.org> +whois-5.0.19.ebuild:
+ Version bump.
18 Aug 2012; Mike Frysinger <vapier@gentoo.org> whois-5.0.15.ebuild,
whois-5.0.16.ebuild:
diff --git a/net-misc/whois/whois-5.0.19.ebuild b/net-misc/whois/whois-5.0.19.ebuild
new file mode 100644
index 000000000000..88a6fe0f5326
--- /dev/null
+++ b/net-misc/whois/whois-5.0.19.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.19.ebuild,v 1.1 2012/09/23 09:32:49 radhermit Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="iconv idn nls"
+RESTRICT="test" #59327
+
+RDEPEND="iconv? ( virtual/libiconv )
+ idn? ( net-dns/libidn )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-lang/perl-5
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile || die
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die
+
+ # don't generate po files when nls is disabled (bug #419889)
+ sed -i -e '/^all:/s/ pos//' \
+ -e '/^install:/s/ install-pos//' Makefile || die
+ fi
+}
+
+src_configure() { :;} # expected no-op
+
+src_compile() {
+ unset HAVE_ICONV HAVE_LIBIDN
+ use iconv && export HAVE_ICONV=1
+ use idn && export HAVE_LIBIDN=1
+ tc-export CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ emake BASEDIR="${ED}" prefix=/usr install
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1 || die
+ mv "${ED}"/usr/bin/{whois,mdwhois} || die
+ fi
+}