summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-31 23:08:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-31 23:08:43 +0000
commit4aa2328ca92551670d44f9165224c518c10ed3b9 (patch)
treefeb0f752212e5d2ccb27b6f00fa3bd81bf175f40 /net-misc/whois
parentold (diff)
downloadgentoo-2-4aa2328ca92551670d44f9165224c518c10ed3b9.tar.gz
gentoo-2-4aa2328ca92551670d44f9165224c518c10ed3b9.tar.bz2
gentoo-2-4aa2328ca92551670d44f9165224c518c10ed3b9.zip
Version bump #111004 by Daniel Webert.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/files/digest-whois-4.7.81
-rw-r--r--net-misc/whois/whois-4.7.8.ebuild55
3 files changed, 62 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 18b0ee81daa2..30d38184d27b 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.46 2005/10/08 19:31:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.47 2005/10/31 23:08:43 vapier Exp $
+
+*whois-4.7.8 (31 Oct 2005)
+
+ 31 Oct 2005; Mike Frysinger <vapier@gentoo.org> +whois-4.7.8.ebuild:
+ Version bump #111004 by Daniel Webert.
08 Oct 2005; Diego Pettenò <flameeyes@gentoo.org> whois-4.7.2.ebuild:
Install as mdwhois (Marco d'Itri) instead of gwhois on other userlands, as
diff --git a/net-misc/whois/files/digest-whois-4.7.8 b/net-misc/whois/files/digest-whois-4.7.8
new file mode 100644
index 000000000000..30519d0ef3df
--- /dev/null
+++ b/net-misc/whois/files/digest-whois-4.7.8
@@ -0,0 +1 @@
+MD5 41cc0635976d6d0b33ba3067ad246b97 whois_4.7.8.tar.gz 55784
diff --git a/net-misc/whois/whois-4.7.8.ebuild b/net-misc/whois/whois-4.7.8.ebuild
new file mode 100644
index 000000000000..c037dd7598fb
--- /dev/null
+++ b/net-misc/whois/whois-4.7.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.7.8.ebuild,v 1.1 2005/10/31 23:08:43 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+S=${WORKDIR}/${PN}-4.7.7 #someone screwed this pooch
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.7.2-gentoo-security.patch
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ cd po
+ sed -i -e "s:/usr/bin/install:install:" Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ sed -i -e "s:cd po.*::" Makefile
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake OPTS="${CFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ make BASEDIR="${D}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README
+
+ if [[ "${USERLAND}" != "GNU" ]]; then
+ mv ${D}/usr/share/man/man1/{whois,mdwhois}.1
+ mv ${D}/usr/bin/{whois,mdwhois}
+ fi
+}