summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-02-06 15:44:53 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-02-06 15:44:53 +0000
commit081db5036ae160d535648db8d4ce45100dbbeab7 (patch)
treedd3b001059c5e5f5f1ae21eec2bfb9787aab0c2d /net-misc/wicd
parent/home/william/x (diff)
downloadgentoo-2-081db5036ae160d535648db8d4ce45100dbbeab7.tar.gz
gentoo-2-081db5036ae160d535648db8d4ce45100dbbeab7.tar.bz2
gentoo-2-081db5036ae160d535648db8d4ce45100dbbeab7.zip
version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wicd')
-rw-r--r--net-misc/wicd/ChangeLog10
-rw-r--r--net-misc/wicd/wicd-1.5.9.ebuild54
2 files changed, 63 insertions, 1 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index 5e16822d8e6f..9ad9d627a1db 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.31 2009/01/09 19:54:51 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.32 2009/02/06 15:44:53 darkside Exp $
+
+*wicd-1.5.9 (06 Feb 2009)
+
+ 06 Feb 2009; Jeremy Olexa <darkside@gentoo.org> +wicd-1.5.9.ebuild:
+ 1.5.9
+ * Fixed security hole in DBus configuration file
+ * Fixed the TTLS template
+ * Added support for Crux to the setup.py
09 Jan 2009; Joseph Jezak <josejx@gentoo.org> wicd-1.5.7-r1.ebuild,
wicd-1.5.8.ebuild:
diff --git a/net-misc/wicd/wicd-1.5.9.ebuild b/net-misc/wicd/wicd-1.5.9.ebuild
new file mode 100644
index 000000000000..0beab6f48772
--- /dev/null
+++ b/net-misc/wicd/wicd-1.5.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.5.9.ebuild,v 1.1 2009/02/06 15:44:53 darkside Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python
+ dev-python/pygtk
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ || ( x11-misc/ktsuss x11-libs/gksu kde-base/kdesu )
+ >=sys-power/pm-utils-1.1.1"
+
+src_compile() {
+ ${python} ./setup.py configure --no-install-init --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+ newinitd "${FILESDIR}/wicd-init.d" wicd || die "newinitd failed"
+ keepdir /var/lib/wicd/configurations || die "keepdir failed, critical for this app"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/conf.d/rc"
+ elog "(For example, RC_PLUG_SERVICES=\"!net.eth0 !net.wlan0\")"
+}