summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-06-05 15:33:17 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-06-05 15:33:17 +0000
commit6382b7c53556a5d03d78a1a5f2b3ff6bd99c5ad3 (patch)
tree1f82b26cc6d88c1d8d5bb12684019dc43c0f5b33 /net-misc/wicd
parentNew package, ebuild written by me (diff)
downloadgentoo-2-6382b7c53556a5d03d78a1a5f2b3ff6bd99c5ad3.tar.gz
gentoo-2-6382b7c53556a5d03d78a1a5f2b3ff6bd99c5ad3.tar.bz2
gentoo-2-6382b7c53556a5d03d78a1a5f2b3ff6bd99c5ad3.zip
Version bump, 1.6.0 final, new USE flag to allow ppc64 keyword
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wicd')
-rw-r--r--net-misc/wicd/ChangeLog8
-rw-r--r--net-misc/wicd/metadata.xml2
-rw-r--r--net-misc/wicd/wicd-1.6.0.ebuild (renamed from net-misc/wicd/wicd-1.6.0_beta3.ebuild)14
3 files changed, 15 insertions, 9 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index 198d3bc79806..fa61b827d7eb 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.45 2009/05/28 03:40:04 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.46 2009/06/05 15:33:17 darkside Exp $
+
+*wicd-1.6.0 (05 Jun 2009)
+
+ 05 Jun 2009; Jeremy Olexa <darkside@gentoo.org> metadata.xml,
+ -wicd-1.6.0_beta3.ebuild, +wicd-1.6.0.ebuild:
+ Version bump, 1.6.0 final, new USE flag to allow ppc64 keyword
*wicd-1.6.0_beta3 (28 May 2009)
diff --git a/net-misc/wicd/metadata.xml b/net-misc/wicd/metadata.xml
index a369cf4c5fd5..73c273b15633 100644
--- a/net-misc/wicd/metadata.xml
+++ b/net-misc/wicd/metadata.xml
@@ -9,5 +9,7 @@
<flag name='ioctl'>Installs additional python libraries to use as a backend.
This will improve speed but is experimental.</flag>
<flag name='ncurses'>Installs a ncurses UI</flag>
+ <flag name='pm-utils'>Installs the pm-utils hooks for suspend/resume and
+ requires <pkg>sys-power/pm-utils</pkg></flag>
</use>
</pkgmetadata>
diff --git a/net-misc/wicd/wicd-1.6.0_beta3.ebuild b/net-misc/wicd/wicd-1.6.0.ebuild
index d51282140287..d65a4458ba6b 100644
--- a/net-misc/wicd/wicd-1.6.0_beta3.ebuild
+++ b/net-misc/wicd/wicd-1.6.0.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.6.0_beta3.ebuild,v 1.1 2009/05/28 03:40:04 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.6.0.ebuild,v 1.1 2009/06/05 15:33:17 darkside Exp $
EAPI="2"
inherit distutils eutils
-MY_P=${P/_beta/b}
-
DESCRIPTION="A lightweight wired and wireless network manager for Linux"
HOMEPAGE="http://wicd.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="ioctl libnotify ncurses"
+IUSE="ioctl libnotify ncurses +pm-utils"
DEPEND=""
RDEPEND="
@@ -41,14 +39,14 @@ RDEPEND="
ioctl? ( dev-python/python-iwscan dev-python/python-wpactrl )
libnotify? ( dev-python/notify-python )
ncurses? ( >=dev-python/urwid-0.9.8.4 )
+ pm-utils? ( >=sys-power/pm-utils-1.1.1 )
"
-S="${WORKDIR}/${MY_P}"
-
src_compile() {
local myconf
- use ncurses || myconf="${myconf} --no-install-ncurses"
use libnotify || myconf="${myconf} --no-use-notifications"
+ use ncurses || myconf="${myconf} --no-install-ncurses"
+ use pm-utils || myconf="${myconf} --no-install-pmutils"
${python} ./setup.py configure --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose ${myconf}
distutils_src_compile
}