summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-04-07 15:25:47 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-04-07 15:25:47 +0000
commitd7a90fed470acc22f72a82dfce42c3c024ddb478 (patch)
tree59ea54f3c812c280bee3659be46bfd04042c5bea /net-misc/x2goclient
parentMake USE="granite" which pulls GTK+-3.x dev-libs/granite depend on USE="-depr... (diff)
downloadgentoo-2-d7a90fed470acc22f72a82dfce42c3c024ddb478.tar.gz
gentoo-2-d7a90fed470acc22f72a82dfce42c3c024ddb478.tar.bz2
gentoo-2-d7a90fed470acc22f72a82dfce42c3c024ddb478.zip
Backport fix for 100% CPU usage, thanks Theofilos Intzoglou <int.teo@gmail.com> in bug #506770. Also backport password login fix
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/x2goclient')
-rw-r--r--net-misc/x2goclient/ChangeLog11
-rw-r--r--net-misc/x2goclient/files/x2goclient-4.0.1.3-password_connection.patch27
-rw-r--r--net-misc/x2goclient/files/x2goclient-4.0.1.3-timeout.patch12
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.1.3-r2.ebuild80
4 files changed, 129 insertions, 1 deletions
diff --git a/net-misc/x2goclient/ChangeLog b/net-misc/x2goclient/ChangeLog
index 59d96dc64d4c..9258dc639a3c 100644
--- a/net-misc/x2goclient/ChangeLog
+++ b/net-misc/x2goclient/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/x2goclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.27 2014/02/05 13:15:01 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.28 2014/04/07 15:25:47 voyageur Exp $
+
+*x2goclient-4.0.1.3-r2 (07 Apr 2014)
+
+ 07 Apr 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +x2goclient-4.0.1.3-r2.ebuild,
+ +files/x2goclient-4.0.1.3-password_connection.patch,
+ +files/x2goclient-4.0.1.3-timeout.patch:
+ Backport fix for 100% CPU usage, thanks Theofilos Intzoglou
+ <int.teo@gmail.com> in bug #506770. Also backport password login fix
*x2goclient-4.0.1.3-r1 (05 Feb 2014)
diff --git a/net-misc/x2goclient/files/x2goclient-4.0.1.3-password_connection.patch b/net-misc/x2goclient/files/x2goclient-4.0.1.3-password_connection.patch
new file mode 100644
index 000000000000..53d6fb5a8fec
--- /dev/null
+++ b/net-misc/x2goclient/files/x2goclient-4.0.1.3-password_connection.patch
@@ -0,0 +1,27 @@
+From 083ece20445bf6e1db26a74856185d0c9b1e8b5a Mon Sep 17 00:00:00 2001
+From: Orion Poplawski <orion@cora.nwra.com>
+Date: Tue, 4 Feb 2014 12:28:07 +0100
+Subject: [PATCH] Fix password connection with libssh 0.6.0
+
+---
+ debian/changelog | 3 ++-
+ sshmasterconnection.cpp | 3 +++
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/sshmasterconnection.cpp b/sshmasterconnection.cpp
+index e0266db..827eefe 100755
+--- a/sshmasterconnection.cpp
++++ b/sshmasterconnection.cpp
+@@ -936,6 +936,9 @@ bool SshMasterConnection::userChallengeAuth()
+
+ bool SshMasterConnection::userAuthWithPass()
+ {
++ // Populate the userauth_list
++ ssh_userauth_none(my_ssh_session, NULL);
++
+ int method = ssh_userauth_list(my_ssh_session, NULL);
+
+ if (method& SSH_AUTH_METHOD_INTERACTIVE)
+--
+1.7.9.5
+
diff --git a/net-misc/x2goclient/files/x2goclient-4.0.1.3-timeout.patch b/net-misc/x2goclient/files/x2goclient-4.0.1.3-timeout.patch
new file mode 100644
index 000000000000..e79744776e9f
--- /dev/null
+++ b/net-misc/x2goclient/files/x2goclient-4.0.1.3-timeout.patch
@@ -0,0 +1,12 @@
+diff -up x2goclient-4.0.1.3/sshmasterconnection.cpp.timeout x2goclient-4.0.1.3/sshmasterconnection.cpp
+--- x2goclient-4.0.1.3/sshmasterconnection.cpp.timeout 2014-01-22 00:58:25.000000000 -0700
++++ x2goclient-4.0.1.3/sshmasterconnection.cpp 2014-01-22 14:41:07.754428027 -0700
+@@ -1445,7 +1445,7 @@ void SshMasterConnection::channelLoop()
+ struct timeval tv;
+
+ tv.tv_sec = 0;
+- tv.tv_usec = 500;
++ tv.tv_usec = 500000;
+
+ int retval;
+ int maxsock=-1;
diff --git a/net-misc/x2goclient/x2goclient-4.0.1.3-r2.ebuild b/net-misc/x2goclient/x2goclient-4.0.1.3-r2.ebuild
new file mode 100644
index 000000000000..f1edab7c4675
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.1.3-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.1.3-r2.ebuild,v 1.1 2014/04/07 15:25:47 voyageur Exp $
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-timeout.patch \
+ "${FILESDIR}"/${P}-password_connection.patch
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}