summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-06-24 07:52:42 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-06-24 07:52:42 +0000
commit5af7f56f1f66b0b9031d20a8b6ebcbbc992a5ea0 (patch)
tree2228c1c1de85bb763a86b2e400343830db264d6e /net-misc/yandex-disk
parentAdd Yandex Desktop Software License Agreement (diff)
downloadgentoo-2-5af7f56f1f66b0b9031d20a8b6ebcbbc992a5ea0.tar.gz
gentoo-2-5af7f56f1f66b0b9031d20a8b6ebcbbc992a5ea0.tar.bz2
gentoo-2-5af7f56f1f66b0b9031d20a8b6ebcbbc992a5ea0.zip
Initial commit, wrt bug #483110. Thanks to Dmitry Suloev <SuloevDmitry AT gmail.com> for initial ebuild. Package will be maintained by Vladimir Romanov <blueboar AT gentoo.org> through proxy maintainers
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-misc/yandex-disk')
-rw-r--r--net-misc/yandex-disk/ChangeLog12
-rw-r--r--net-misc/yandex-disk/metadata.xml15
-rw-r--r--net-misc/yandex-disk/yandex-disk-0.1.4.504_p1.ebuild33
3 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/yandex-disk/ChangeLog b/net-misc/yandex-disk/ChangeLog
new file mode 100644
index 000000000000..c05b19511b76
--- /dev/null
+++ b/net-misc/yandex-disk/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-misc/yandex-disk
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yandex-disk/ChangeLog,v 1.1 2014/06/24 07:52:42 pinkbyte Exp $
+
+*yandex-disk-0.1.4.504_p1 (24 Jun 2014)
+
+ 24 Jun 2014; Sergey Popov <pinkbyte@gentoo.org>
+ +yandex-disk-0.1.4.504_p1.ebuild, +metadata.xml:
+ Initial commit, wrt bug #483110. Thanks to Dmitry Suloev <SuloevDmitry AT
+ gmail.com> for initial ebuild. Package will be maintained by Vladimir Romanov
+ <blueboar AT gentoo.org> through proxy maintainers
+
diff --git a/net-misc/yandex-disk/metadata.xml b/net-misc/yandex-disk/metadata.xml
new file mode 100644
index 000000000000..9ef9c615e0c0
--- /dev/null
+++ b/net-misc/yandex-disk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>blueboar@gentoo.org</email>
+ <name>Vladimir Romanov</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/yandex-disk/yandex-disk-0.1.4.504_p1.ebuild b/net-misc/yandex-disk/yandex-disk-0.1.4.504_p1.ebuild
new file mode 100644
index 000000000000..d270b85fd1ad
--- /dev/null
+++ b/net-misc/yandex-disk/yandex-disk-0.1.4.504_p1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yandex-disk/yandex-disk-0.1.4.504_p1.ebuild,v 1.1 2014/06/24 07:52:42 pinkbyte Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 rpm
+
+MY_P="${PN}-${PV/_p/-}"
+
+DESCRIPTION="CLI to access Yandex Disk file storage service"
+HOMEPAGE="https://disk.yandex.ru"
+SRC_URI="
+ amd64? ( http://repo.yandex.ru/yandex-disk/rpm/stable/x86_64/${MY_P}.fedora.x86_64.rpm )
+ x86? ( http://repo.yandex.ru/yandex-disk/rpm/stable/i386/${MY_P}.fedora.i386.rpm )
+"
+
+LICENSE="YDSLA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="sys-libs/zlib"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/bin/yandex-disk"
+
+src_install() {
+ exeinto /opt/bin
+ doexe usr/bin/yandex-disk
+ newbashcomp etc/bash_completion.d/yandex-disk-completion.bash "${PN}"
+}