summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRajiv Aaron Manglani <rajiv@gentoo.org>2008-05-18 14:50:54 +0000
committerRajiv Aaron Manglani <rajiv@gentoo.org>2008-05-18 14:50:54 +0000
commitb0239529bca7bc23f3f83d6b95265940cbb95794 (patch)
tree440b80e105c5680b60e2846a76531d86feff2eb3 /net-misc/zaptel
parentamd64/x86 stable, bug #221063 (diff)
downloadgentoo-2-b0239529bca7bc23f3f83d6b95265940cbb95794.tar.gz
gentoo-2-b0239529bca7bc23f3f83d6b95265940cbb95794.tar.bz2
gentoo-2-b0239529bca7bc23f3f83d6b95265940cbb95794.zip
version bump, bug #216974.
(Portage version: 2.1.5)
Diffstat (limited to 'net-misc/zaptel')
-rw-r--r--net-misc/zaptel/ChangeLog8
-rw-r--r--net-misc/zaptel/files/zaptel-1.2.25-xpputils.diff25
-rw-r--r--net-misc/zaptel/zaptel-1.2.25.ebuild (renamed from net-misc/zaptel/zaptel-1.2.23.ebuild)7
3 files changed, 36 insertions, 4 deletions
diff --git a/net-misc/zaptel/ChangeLog b/net-misc/zaptel/ChangeLog
index 86826a179200..f1fb8e5760e6 100644
--- a/net-misc/zaptel/ChangeLog
+++ b/net-misc/zaptel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/zaptel
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.106 2008/03/07 16:50:36 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.107 2008/05/18 14:50:53 rajiv Exp $
+
+*zaptel-1.2.25 (18 May 2008)
+
+ 18 May 2008; Rajiv Aaron Manglani <rajiv@gentoo.org>
+ -zaptel-1.2.23.ebuild, +zaptel-1.2.25.ebuild:
+ version bump, bug #216974.
07 Mar 2008; Christian Faulhammer <opfer@gentoo.org> zaptel-1.2.24.ebuild:
stable x86, bug 208190
diff --git a/net-misc/zaptel/files/zaptel-1.2.25-xpputils.diff b/net-misc/zaptel/files/zaptel-1.2.25-xpputils.diff
new file mode 100644
index 000000000000..f08c6e26ba0d
--- /dev/null
+++ b/net-misc/zaptel/files/zaptel-1.2.25-xpputils.diff
@@ -0,0 +1,25 @@
+diff -ruN zaptel-1.2.25.orig/xpp/utils/Makefile zaptel-1.2.25/xpp/utils/Makefile
+--- zaptel-1.2.25.orig/xpp/utils/Makefile 2008-04-09 19:27:21.000000000 +0200
++++ zaptel-1.2.25/xpp/utils/Makefile 2008-04-09 19:22:34.000000000 +0200
+@@ -126,8 +126,8 @@
+ test_parse: test_parse.o libhexfile.a
+ $(CC) -L. -o $@ $@.o $(EXTRA_LIBS) -lhexfile -lusb
+
+-print_modes: print_modes.c wctdm_fxomodes.h
+- $(HOSTCC) -o $@ $(CFLAGS) $<
++print_modes: print_modes.c $(ZAP_KERNEL)/fxo_modes.h
++ $(HOSTCC) -I$(ZAP_KERNEL) -o $@ $(CFLAGS) $<
+
+ wctdm_fxomodes.h: $(WCTDM)
+ perl -n -e 'print if (/^static struct fxo_mode {$$/ .. /};$$/)' $(WCTDM) >$@
+diff -ruN zaptel-1.2.25.orig/xpp/utils/print_modes.c zaptel-1.2.25/xpp/utils/print_modes.c
+--- zaptel-1.2.25.orig/xpp/utils/print_modes.c 2008-04-09 19:23:20.000000000 +0200
++++ zaptel-1.2.25/xpp/utils/print_modes.c 2008-04-09 19:23:51.000000000 +0200
+@@ -1,6 +1,6 @@
+ #include <stdio.h>
+
+-#include "wctdm_fxomodes.h"
++#include "fxo_modes.h"
+
+ int main() {
+ size_t i;
diff --git a/net-misc/zaptel/zaptel-1.2.23.ebuild b/net-misc/zaptel/zaptel-1.2.25.ebuild
index 91728f881164..e9c2c2979587 100644
--- a/net-misc/zaptel/zaptel-1.2.23.ebuild
+++ b/net-misc/zaptel/zaptel-1.2.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.2.23.ebuild,v 1.3 2008/02/24 18:25:48 rajiv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.2.25.ebuild,v 1.1 2008/05/18 14:50:53 rajiv Exp $
inherit toolchain-funcs eutils linux-mod flag-o-matic
@@ -25,7 +25,7 @@ S_BRI="${WORKDIR}/bristuff-${BRI_VERSION}"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND="virtual/libc
dev-libs/libusb
@@ -170,8 +170,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-1.2.23-gentoo.diff
epatch "${FILESDIR}"/zaptel-1.2.9.1-ar.patch
+ epatch "${FILESDIR}"/zaptel-1.2.25-xpputils.diff
# try to apply bristuff patch
if use bri; then