summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-08-05 09:30:17 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-08-05 09:30:17 +0000
commit035be8c89828f694f0293756cab27d94bdfc2c4d (patch)
tree927984273afab46d891d40315b5a50de30e14fa3 /net-misc
parentAdd USE=pin-upstream-blobs so people can opt to use any version of seabios/et... (diff)
downloadgentoo-2-035be8c89828f694f0293756cab27d94bdfc2c4d.tar.gz
gentoo-2-035be8c89828f694f0293756cab27d94bdfc2c4d.tar.bz2
gentoo-2-035be8c89828f694f0293756cab27d94bdfc2c4d.zip
Version bump
(Portage version: 2.2.11/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/plowshare/ChangeLog7
-rw-r--r--net-misc/plowshare/plowshare-1.0.4.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-misc/plowshare/ChangeLog b/net-misc/plowshare/ChangeLog
index 19c6e681e8d3..7e60518a2905 100644
--- a/net-misc/plowshare/ChangeLog
+++ b/net-misc/plowshare/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/plowshare
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/plowshare/ChangeLog,v 1.28 2014/05/14 15:41:00 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/plowshare/ChangeLog,v 1.29 2014/08/05 09:30:17 voyageur Exp $
+
+*plowshare-1.0.4 (05 Aug 2014)
+
+ 05 Aug 2014; Bernard Cafarelli <voyageur@gentoo.org> +plowshare-1.0.4.ebuild:
+ Version bump
*plowshare-1.0.2 (14 May 2014)
diff --git a/net-misc/plowshare/plowshare-1.0.4.ebuild b/net-misc/plowshare/plowshare-1.0.4.ebuild
new file mode 100644
index 000000000000..ce4811e32216
--- /dev/null
+++ b/net-misc/plowshare/plowshare-1.0.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/plowshare/plowshare-1.0.4.ebuild,v 1.1 2014/08/05 09:30:17 voyageur Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
+HOMEPAGE="http://code.google.com/p/plowshare/"
+# Fetched from http://${PN}.googlecode.com/archive/v${PV}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="bash-completion +javascript view-captcha"
+
+RDEPEND="
+ >=app-shells/bash-4
+ || ( app-text/recode ( dev-lang/perl dev-perl/HTML-Parser ) )
+ || ( media-gfx/imagemagick[tiff] media-gfx/graphicsmagick[imagemagick,tiff] )
+ net-misc/curl
+ sys-apps/util-linux
+ javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
+ view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
+DEPEND=""
+
+# NOTES:
+# javascript dep should be any javascript interpreter using /usr/bin/js
+
+# Modules using detect_javascript
+JS_MODULES="letitbit nowdownload_co oboom rapidgator zalaa zalil_ru zippyshare"
+
+src_prepare() {
+ if ! use javascript; then
+ for module in ${JS_MODULES}; do
+ sed -i -e "s:^${module}.*::" src/modules/config || die "${module} sed failed"
+ rm src/modules/${module}.sh || die "${module} rm failed"
+ done
+ fi
+
+ # Fix doc install path
+ sed -i -e "/^DOCDIR/s|plowshare4|${P}|" Makefile || die "sed failed"
+
+ if ! use bash-completion
+ then
+ sed -i -e \ "/^install:/s/install_bash_completion//" \
+ Makefile || die "sed failed"
+ fi
+}
+
+src_compile() {
+ # There is a Makefile but it's not compiling anything, let's not try.
+ :
+}
+
+src_test() {
+ # Disable tests because all of them need a working Internet connection.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" \
+ PLOWSHARE_FORCE_VERSION="${PV}" install
+}
+
+pkg_postinst() {
+ if ! use javascript; then
+ ewarn "Without javascript you will not be able to use:"
+ ewarn " ${JS_MODULES}"
+ fi
+}