summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2004-09-21 20:20:38 +0000
committerStefan Knoblich <stkn@gentoo.org>2004-09-21 20:20:38 +0000
commit0778636ab8ad1b13ddb4ced34351b5730980ecd2 (patch)
tree7b9f0322da50d00791d988389106c1dbea73effe /net-misc
parentminor issue (Manifest recommit) (diff)
downloadgentoo-2-0778636ab8ad1b13ddb4ced34351b5730980ecd2.tar.gz
gentoo-2-0778636ab8ad1b13ddb4ced34351b5730980ecd2.tar.bz2
gentoo-2-0778636ab8ad1b13ddb4ced34351b5730980ecd2.zip
found a fix in the partysip cvs, works with >=libosip-2.0.7 and previous versions
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/partysip/ChangeLog7
-rw-r--r--net-misc/partysip/files/partysip-2.1.1-libosip2fix.diff62
-rw-r--r--net-misc/partysip/partysip-2.1.1.ebuild11
3 files changed, 78 insertions, 2 deletions
diff --git a/net-misc/partysip/ChangeLog b/net-misc/partysip/ChangeLog
index f571b5d9bfcd..f79033d82f18 100644
--- a/net-misc/partysip/ChangeLog
+++ b/net-misc/partysip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/partysip
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/ChangeLog,v 1.5 2004/09/21 19:46:44 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/ChangeLog,v 1.6 2004/09/21 20:20:38 stkn Exp $
+
+ 21 Sep 2004; <stkn@gentoo.org> +files/partysip-2.1.1-libosip2fix.diff,
+ partysip-2.1.1.ebuild:
+ found a fix in the partysip cvs, works with >=libosip-2.0.7 and previous
+ versions
21 Sep 2004; <stkn@gentoo.org> partysip-2.1.1.ebuild:
partysip won't compile with >=libosip-2.0.7, changing dependency to
diff --git a/net-misc/partysip/files/partysip-2.1.1-libosip2fix.diff b/net-misc/partysip/files/partysip-2.1.1-libosip2fix.diff
new file mode 100644
index 000000000000..39b91dc6517e
--- /dev/null
+++ b/net-misc/partysip/files/partysip-2.1.1-libosip2fix.diff
@@ -0,0 +1,62 @@
+===================================================================
+RCS file: /cvsroot/partysip/cvsroot/partysip/partysip/ppl/unix/ppldso.c,v
+retrieving revision 1.7
+retrieving revision 1.8
+diff -u -r1.7 -r1.8
+--- partysip/partysip/ppl/unix/ppldso.c 2003/05/14 15:40:14 1.7
++++ partysip/partysip/ppl/unix/ppldso.c 2004/02/13 18:50:24 1.8
+@@ -80,6 +80,7 @@
+ */
+
+ #include <ppl/ppl_dso.h>
++#include <osipparser2/osip_port.h>
+
+ #if !defined(DSO_USE_DLFCN) && !defined(DSO_USE_SHL) && !defined(DSO_USE_DYLD)
+ #error No DSO implementation specified.
+@@ -94,9 +95,6 @@
+ #if HAVE_STRING_H
+ #include <string.h> /* for strerror() on HP-UX */
+ #endif
+-
+-void *osip_malloc (int len);
+-void osip_free (void *);
+
+ ppl_status_t
+ ppl_dso_unload (ppl_dso_handle_t * thedso)
+===================================================================
+RCS file: /cvsroot/partysip/cvsroot/partysip/partysip/ppl/unix/pplgetopt.c,v
+retrieving revision 1.7
+retrieving revision 1.8
+diff -u -r1.7 -r1.8
+--- partysip/partysip/ppl/unix/pplgetopt.c 2003/05/14 15:40:14 1.7
++++ partysip/partysip/ppl/unix/pplgetopt.c 2004/02/13 18:50:24 1.8
+@@ -53,9 +53,7 @@
+ */
+
+ #include <ppl/ppl_getopt.h>
+-
+-void *osip_malloc (int size);
+-void osip_free (void *);
++#include <osipparser2/osip_port.h>
+
+ #define EMSG ""
+
+ /* This is a modified version from Aymeric MOIZARD
+===================================================================
+RCS file: /cvsroot/partysip/cvsroot/partysip/partysip/ppl/unix/pplpipe.c,v
+retrieving revision 1.8
+retrieving revision 1.9
+diff -u -r1.8 -r1.9
+--- partysip/partysip/ppl/unix/pplpipe.c 2004/01/30 23:44:45 1.8
++++ partysip/partysip/ppl/unix/pplpipe.c 2004/02/13 18:50:24 1.9
+@@ -20,9 +20,8 @@
+
+
+ #include <ppl/ppl_pipe.h>
++#include <osipparser2/osip_port.h>
+
+-void *osip_malloc (int size);
+-void osip_free (void *);
+
+ PPL_DECLARE (ppl_pipe_t *) ppl_pipe ()
+ {
diff --git a/net-misc/partysip/partysip-2.1.1.ebuild b/net-misc/partysip/partysip-2.1.1.ebuild
index 2f4495d1e5ce..70868cdbc867 100644
--- a/net-misc/partysip/partysip-2.1.1.ebuild
+++ b/net-misc/partysip/partysip-2.1.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/partysip-2.1.1.ebuild,v 1.5 2004/09/21 19:46:44 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/partysip-2.1.1.ebuild,v 1.6 2004/09/21 20:20:38 stkn Exp $
#IUSE="gdbm berkdb debug"
IUSE="debug"
+inherit eutils
+
DESCRIPTION="Modular and extensible SIP proxy"
HOMEPAGE="http://savannah.nongnu.org/projects/partysip/"
SRC_URI="http://osip.atosc.org/download/partysip/${P}.tar.gz"
@@ -21,6 +23,13 @@ DEPEND="virtual/libc
# gdbm? ( >=sys-libs/gdbm-1.8.0 )
# berkdb? ( >=sys-libs/db-4.1.20 )"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/partysip-2.1.1-libosip2fix.diff
+}
+
src_compile() {
local myconf