summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-06-05 05:40:52 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-06-05 05:40:52 +0000
commit20eeca48a8fbd006426e9d6c7b6cdfc0ab20cc3a (patch)
tree7d599b9b83c90ba4b23c999545199781348bf7d8 /net-misc
parentAdd patch from mailing list to fix memory leak on receiving messages. (diff)
downloadgentoo-2-20eeca48a8fbd006426e9d6c7b6cdfc0ab20cc3a.tar.gz
gentoo-2-20eeca48a8fbd006426e9d6c7b6cdfc0ab20cc3a.tar.bz2
gentoo-2-20eeca48a8fbd006426e9d6c7b6cdfc0ab20cc3a.zip
Version bump. Dropped old.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/aria2/ChangeLog9
-rw-r--r--net-misc/aria2/aria2-1.6.3.ebuild73
-rw-r--r--net-misc/aria2/aria2-1.9.0.ebuild85
-rw-r--r--net-misc/aria2/aria2-1.9.2.ebuild85
-rw-r--r--net-misc/aria2/aria2-1.9.4.ebuild (renamed from net-misc/aria2/aria2-1.8.3.ebuild)2
5 files changed, 9 insertions, 245 deletions
diff --git a/net-misc/aria2/ChangeLog b/net-misc/aria2/ChangeLog
index f7f906678f64..6713bbbe621e 100644
--- a/net-misc/aria2/ChangeLog
+++ b/net-misc/aria2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/aria2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.62 2010/05/23 14:23:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.63 2010/06/05 05:40:52 dev-zero Exp $
+
+*aria2-1.9.4 (05 Jun 2010)
+
+ 05 Jun 2010; Tiziano Müller <dev-zero@gentoo.org> -aria2-1.6.3.ebuild,
+ -aria2-1.8.3.ebuild, -aria2-1.9.0.ebuild, -aria2-1.9.2.ebuild,
+ +aria2-1.9.4.ebuild:
+ Version bump. Dropped old.
23 May 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> aria2-1.9.3.ebuild:
x86 stable wrt security bug #320975
diff --git a/net-misc/aria2/aria2-1.6.3.ebuild b/net-misc/aria2/aria2-1.6.3.ebuild
deleted file mode 100644
index e185ca380f73..000000000000
--- a/net-misc/aria2/aria2-1.6.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.6.3.ebuild,v 1.4 2009/11/14 19:12:21 dev-zero Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="A download utility with resuming and segmented downloading with HTTP/HTTPS/FTP/BitTorrent support."
-HOMEPAGE="http://aria2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
-SLOT="0"
-IUSE="ares bittorrent expat gnutls metalink nls sqlite ssl test"
-
-CDEPEND="sys-libs/zlib
- ssl? (
- gnutls? ( >=net-libs/gnutls-1.2.9 )
- !gnutls? ( dev-libs/openssl ) )
- ares? ( >=net-dns/c-ares-1.5.0 )
- bittorrent? (
- gnutls? ( >=net-libs/gnutls-1.2.9 >=dev-libs/libgcrypt-1.2.2 )
- !gnutls? ( dev-libs/openssl ) )
- metalink? (
- !expat? ( >=dev-libs/libxml2-2.6.26 )
- expat? ( dev-libs/expat )
- )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0 )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libiconv virtual/libintl )"
-
-src_prepare() {
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-
- epatch "${FILESDIR}/${PV}-unaligned_pointers.patch"
-}
-
-src_configure() {
- local myconf="--without-gnutls --without-openssl"
- use ssl && \
- myconf="$(use_with gnutls) $(use_with !gnutls openssl)"
-
- # Note:
- # - depends on libgcrypt only when using gnutls
- # - links only against libxml2 and libexpat when metalink is enabled
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf \
- --enable-epoll \
- --enable-threads=posix \
- --with-libz \
- $(use_enable nls) \
- $(use_enable metalink) \
- $(use_with expat libexpat) \
- $(use_with !expat libxml2) \
- $(use_with sqlite sqlite3) \
- $(use_enable bittorrent) \
- $(use_with ares libcares) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- rm -rf "${D}/usr/share/doc/aria2"
- dodoc ChangeLog README AUTHORS NEWS
- dohtml README.html doc/aria2c.1.html
-}
diff --git a/net-misc/aria2/aria2-1.9.0.ebuild b/net-misc/aria2/aria2-1.9.0.ebuild
deleted file mode 100644
index e79734bfa854..000000000000
--- a/net-misc/aria2/aria2-1.9.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.9.0.ebuild,v 1.1 2010/03/27 09:06:25 dev-zero Exp $
-
-EAPI="2"
-
-DESCRIPTION="A download utility with resuming and segmented downloading with HTTP/HTTPS/FTP/BitTorrent support."
-HOMEPAGE="http://aria2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="ares bittorrent expat gnutls metalink nls scripts sqlite ssl test xmlrpc"
-
-CDEPEND="sys-libs/zlib
- ssl? (
- gnutls? ( >=net-libs/gnutls-1.2.9 )
- !gnutls? ( dev-libs/openssl ) )
- ares? ( >=net-dns/c-ares-1.5.0 )
- bittorrent? (
- gnutls? ( >=net-libs/gnutls-1.2.9 >=dev-libs/libgcrypt-1.2.2 )
- !gnutls? ( dev-libs/openssl ) )
- metalink? (
- !expat? ( >=dev-libs/libxml2-2.6.26 )
- expat? ( dev-libs/expat ) )
- sqlite? ( dev-db/sqlite:3 )
- xmlrpc? (
- !expat? ( >=dev-libs/libxml2-2.6.26 )
- expat? ( dev-libs/expat ) )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0 )"
-RDEPEND="${CDEPEND}
- scripts? ( dev-lang/ruby )
- nls? ( virtual/libiconv virtual/libintl )"
-
-pkg_setup() {
- if use scripts && use !xmlrpc && use !metalink; then
- ewarn "Please also enable the 'xmlrpc' USE flag to actually use the additional scripts"
- fi
-}
-
-src_prepare() {
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-}
-
-src_configure() {
- local myconf="--without-gnutls --without-openssl"
- use ssl && \
- myconf="$(use_with gnutls) $(use_with !gnutls openssl)"
-
- local xmllib="--without-libexpat --without-libxml2"
- if use metalink || use xmlrpc ; then
- xmllib="$(use_with expat libexpat) $(use_with !expat libxml2)"
- fi
-
- # Note:
- # - depends on libgcrypt only when using gnutls
- # - if --without-libexpat or --without-libxml2 are not given, it links against
- # one of them to provide xmlrpc-functionality
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf \
- --enable-epoll \
- --enable-threads=posix \
- --with-libz \
- $(use_enable nls) \
- $(use_enable metalink) \
- $(use_with sqlite sqlite3) \
- $(use_enable bittorrent) \
- $(use_with ares libcares) \
- ${xmllib} \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- rm -rf "${D}/usr/share/doc/aria2"
- dodoc ChangeLog README AUTHORS NEWS
- dohtml README.html doc/aria2c.1.html
-
- use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
-}
diff --git a/net-misc/aria2/aria2-1.9.2.ebuild b/net-misc/aria2/aria2-1.9.2.ebuild
deleted file mode 100644
index 3d4a59e7ea83..000000000000
--- a/net-misc/aria2/aria2-1.9.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.9.2.ebuild,v 1.1 2010/05/06 07:02:54 dev-zero Exp $
-
-EAPI="2"
-
-DESCRIPTION="A download utility with resuming and segmented downloading with HTTP/HTTPS/FTP/BitTorrent support."
-HOMEPAGE="http://aria2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="ares bittorrent expat gnutls metalink nls scripts sqlite ssl test xmlrpc"
-
-CDEPEND="sys-libs/zlib
- ssl? (
- gnutls? ( >=net-libs/gnutls-1.2.9 )
- !gnutls? ( dev-libs/openssl ) )
- ares? ( >=net-dns/c-ares-1.5.0 )
- bittorrent? (
- gnutls? ( >=net-libs/gnutls-1.2.9 >=dev-libs/libgcrypt-1.2.2 )
- !gnutls? ( dev-libs/openssl ) )
- metalink? (
- !expat? ( >=dev-libs/libxml2-2.6.26 )
- expat? ( dev-libs/expat ) )
- sqlite? ( dev-db/sqlite:3 )
- xmlrpc? (
- !expat? ( >=dev-libs/libxml2-2.6.26 )
- expat? ( dev-libs/expat ) )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0 )"
-RDEPEND="${CDEPEND}
- scripts? ( dev-lang/ruby )
- nls? ( virtual/libiconv virtual/libintl )"
-
-pkg_setup() {
- if use scripts && use !xmlrpc && use !metalink; then
- ewarn "Please also enable the 'xmlrpc' USE flag to actually use the additional scripts"
- fi
-}
-
-src_prepare() {
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-}
-
-src_configure() {
- local myconf="--without-gnutls --without-openssl"
- use ssl && \
- myconf="$(use_with gnutls) $(use_with !gnutls openssl)"
-
- local xmllib="--without-libexpat --without-libxml2"
- if use metalink || use xmlrpc ; then
- xmllib="$(use_with expat libexpat) $(use_with !expat libxml2)"
- fi
-
- # Note:
- # - depends on libgcrypt only when using gnutls
- # - if --without-libexpat or --without-libxml2 are not given, it links against
- # one of them to provide xmlrpc-functionality
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf \
- --enable-epoll \
- --enable-threads=posix \
- --with-libz \
- $(use_enable nls) \
- $(use_enable metalink) \
- $(use_with sqlite sqlite3) \
- $(use_enable bittorrent) \
- $(use_with ares libcares) \
- ${xmllib} \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- rm -rf "${D}/usr/share/doc/aria2"
- dodoc ChangeLog README AUTHORS NEWS
- dohtml README.html doc/aria2c.1.html
-
- use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
-}
diff --git a/net-misc/aria2/aria2-1.8.3.ebuild b/net-misc/aria2/aria2-1.9.4.ebuild
index 9e1a9b3fdfe9..20ad51c466f4 100644
--- a/net-misc/aria2/aria2-1.8.3.ebuild
+++ b/net-misc/aria2/aria2-1.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.8.3.ebuild,v 1.1 2010/02/22 10:37:32 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.9.4.ebuild,v 1.1 2010/06/05 05:40:52 dev-zero Exp $
EAPI="2"