summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-10-05 18:37:40 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-10-05 18:37:40 +0000
commit246a0626bb01c37940ce4eaf7abd04aaadad23cb (patch)
tree394cf38bdad28095ac439d381093973a7d8eee42 /net-misc
parentAccepting maintainer role (diff)
downloadgentoo-2-246a0626bb01c37940ce4eaf7abd04aaadad23cb.tar.gz
gentoo-2-246a0626bb01c37940ce4eaf7abd04aaadad23cb.tar.bz2
gentoo-2-246a0626bb01c37940ce4eaf7abd04aaadad23cb.zip
revision bump thanks to armin76, fixes bug 78385
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tightvnc/ChangeLog8
-rw-r--r--net-misc/tightvnc/files/digest-tightvnc-1.2.9-r33
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.9-r3.ebuild105
3 files changed, 115 insertions, 1 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index d3fb91d16cb9..ec67bd1630bf 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.73 2006/10/04 18:40:25 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.74 2006/10/05 18:37:40 genstef Exp $
+
+*tightvnc-1.2.9-r3 (05 Oct 2006)
+
+ 05 Oct 2006; Stefan Schweizer <genstef@gentoo.org>
+ +tightvnc-1.2.9-r3.ebuild:
+ revision bump thanks to armin76, fixes bug 78385
*tightvnc-1.3.8 (04 Oct 2006)
diff --git a/net-misc/tightvnc/files/digest-tightvnc-1.2.9-r3 b/net-misc/tightvnc/files/digest-tightvnc-1.2.9-r3
new file mode 100644
index 000000000000..d72709d4f9b6
--- /dev/null
+++ b/net-misc/tightvnc/files/digest-tightvnc-1.2.9-r3
@@ -0,0 +1,3 @@
+MD5 f804b26c098625e3a2675a0aa7709e31 tightvnc-1.2.9_unixsrc.tar.bz2 1738256
+RMD160 57c4d24bbc008b7188ae4bb177fbb409bc1d26d3 tightvnc-1.2.9_unixsrc.tar.bz2 1738256
+SHA256 c1ba77f832d6c81349f05219802c48b3435cfb6db88f496c9bb08b52b8405548 tightvnc-1.2.9_unixsrc.tar.bz2 1738256
diff --git a/net-misc/tightvnc/tightvnc-1.2.9-r3.ebuild b/net-misc/tightvnc/tightvnc-1.2.9-r3.ebuild
new file mode 100644
index 000000000000..040aa221c18a
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.2.9-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.2.9-r3.ebuild,v 1.1 2006/10/05 18:37:40 genstef Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE="java tcpd server"
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
+HOMEPAGE="http://www.tightvnc.com/"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/xproto
+ server? (
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/printproto
+ )
+ >=x11-misc/imake-1
+ x11-misc/gccmakedep
+ ~media-libs/jpeg-6b
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+ !net-misc/vnc"
+
+RDEPEND="${DEPEND}
+ server? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ x11-apps/rgb
+ x11-apps/xauth
+ )
+ java? ( || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 ) )"
+
+src_unpack() {
+
+ if ! use server;
+ then
+ echo
+ einfo "The 'server' USE flag will build tightvnc's server."
+ einfo "If '-server' is chosen only the client is built to save space."
+ einfo "Stop the build now if you need to add 'server' to USE flags.\n"
+ ebeep
+ epause 5
+ fi
+
+ unpack ${A} && cd ${S}
+ epatch "${FILESDIR}/${P}-gentoo.security.patch"
+ epatch "${FILESDIR}/${P}-imake-tmpdir.patch"
+ [[ "$(gcc-version)" == "3.4" ]] || [[ "$(gcc-major-version)" == "4" ]] && epatch ${FILESDIR}/${P}-gcc34.patch
+ epatch "${FILESDIR}/x86.patch"
+ epatch "${FILESDIR}/${P}-amd64.patch"
+ epatch "${FILESDIR}/${PN}-ppcsparc-server.patch"
+ epatch "${FILESDIR}/${P}-pathfixes.patch" # fixes bug 78385 and 146099
+}
+
+src_compile() {
+ xmkmf -a || die "xmkmf failed"
+
+ make CDEBUGFLAGS="${CFLAGS}" World || die
+
+ if use server; then
+ cd Xvnc && ./configure || die "Configure failed."
+ if use tcpd; then
+ local myextra="-lwrap"
+ use userland_Darwin || myextra="${myextra} -lnss_nis"
+ make EXTRA_LIBRARIES="${myextra}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_DEFINES="-DUSE_LIBWRAP=1" || die
+ else
+ make CDEBUGFLAGS="${CFLAGS}" || die
+ fi
+ fi
+
+}
+
+src_install() {
+ # the web based interface and the java viewer need the java class files
+ if use java; then
+ insinto /usr/share/tightvnc/classes
+ doins classes/*
+ fi
+
+ dodir /usr/share/man/man1 /usr/bin
+ ./vncinstall ${D}/usr/bin ${D}/usr/share/man || die "vncinstall failed"
+
+ if ! use server; then
+ rm -f ${D}/usr/bin/vncserver
+ rm -f ${D}/usr/share/man/man1/{Xvnc,vncserver}*
+ fi
+
+ dodoc ChangeLog README WhatsNew
+ use java && dodoc ${FILESDIR}/README.JavaViewer
+ newdoc vncviewer/README README.vncviewer
+}