summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-26 20:38:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-26 20:38:48 +0000
commit41f84f1c71ec26411761b88e5c6d64eb7531a363 (patch)
tree9b43c98ea838b798e0e7cbb74f1c1e04276567ad /net-misc
parentVersion bump to 3.2.3. See bug #526994. (diff)
downloadgentoo-2-41f84f1c71ec26411761b88e5c6d64eb7531a363.tar.gz
gentoo-2-41f84f1c71ec26411761b88e5c6d64eb7531a363.tar.bz2
gentoo-2-41f84f1c71ec26411761b88e5c6d64eb7531a363.zip
Version bump
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cgminer/ChangeLog7
-rw-r--r--net-misc/cgminer/cgminer-4.8.0.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index 20fa0c8d6a55..9fa291043502 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/cgminer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.81 2014/10/15 23:40:37 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.82 2014/11/26 20:38:48 blueness Exp $
+
+*cgminer-4.8.0 (26 Nov 2014)
+
+ 26 Nov 2014; Anthony G. Basile <blueness@gentoo.org> +cgminer-4.8.0.ebuild:
+ Version bump
*cgminer-4.7.0 (15 Oct 2014)
diff --git a/net-misc/cgminer/cgminer-4.8.0.ebuild b/net-misc/cgminer/cgminer-4.8.0.ebuild
new file mode 100644
index 000000000000..4cd361844fb8
--- /dev/null
+++ b/net-misc/cgminer/cgminer-4.8.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.8.0.ebuild,v 1.1 2014/11/26 20:38:48 blueness Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.5/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+HARDWARE="ants1 ants2 avalon avalon2 bab bitmine_A1 bflsc bitforce bitfury cointerra drillbit hashfast hashratio icarus klondike knc minion modminer spondoolies"
+IUSE="doc examples udev hardened ncurses ${HARDWARE}"
+
+REQUIRED_USE="|| ( ${HARDWARE} )"
+
+RDEPEND="net-misc/curl
+ >=dev-libs/jansson-2.6
+ ncurses? ( sys-libs/ncurses )
+ avalon? ( virtual/libusb:1[udev] )
+ bflsc? ( virtual/libusb:1[udev] )
+ bitforce? ( virtual/libusb:1[udev] )
+ bitfury? ( virtual/libusb:1[udev] )
+ cointerra? ( virtual/libusb:1[udev] )
+ drillbit? ( virtual/libusb:1[udev] )
+ hashfast? ( virtual/libusb:1[udev] )
+ hashratio? ( virtual/libusb:1[udev] )
+ icarus? ( virtual/libusb:1[udev] )
+ klondike? ( virtual/libusb:1[udev] )
+ modminer? ( virtual/libusb:1[udev] )
+ spondoolies? ( virtual/libusb:1[udev] )
+ udev? ( virtual/libudev )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.4.2-system-jansson.patch
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable ants1) \
+ $(use_enable ants2) \
+ $(use_enable avalon) \
+ $(use_enable avalon2) \
+ $(use_enable bab) \
+ $(use_enable bitmine_A1) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable drillbit) \
+ $(use_enable hashfast) \
+ $(use_enable hashratio) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable knc) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable spondoolies) \
+ $(use_enable udev) \
+ --disable-forcecombo \
+ --with-system-libusb
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+
+ if use udev; then
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+ fi
+
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}