summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-21 21:34:45 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-21 21:34:45 +0000
commit48dfafbf5d0af2aeef5946e0873ba2fda1080f50 (patch)
treef6ef1ccc94c67e853d58bd6ae6c92c095fbdbf15 /net-misc
parentRemove old. (diff)
downloadgentoo-2-48dfafbf5d0af2aeef5946e0873ba2fda1080f50.tar.gz
gentoo-2-48dfafbf5d0af2aeef5946e0873ba2fda1080f50.tar.bz2
gentoo-2-48dfafbf5d0af2aeef5946e0873ba2fda1080f50.zip
Revision bump to EAPI 5.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ksshaskpass/ChangeLog10
-rw-r--r--net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild54
2 files changed, 61 insertions, 3 deletions
diff --git a/net-misc/ksshaskpass/ChangeLog b/net-misc/ksshaskpass/ChangeLog
index 6440dd585843..993afd86eb6e 100644
--- a/net-misc/ksshaskpass/ChangeLog
+++ b/net-misc/ksshaskpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ksshaskpass
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ksshaskpass/ChangeLog,v 1.2 2011/05/13 09:44:18 scarabeus Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ksshaskpass/ChangeLog,v 1.3 2014/03/21 21:34:45 johu Exp $
+
+*ksshaskpass-0.5.3-r1 (21 Mar 2014)
+
+ 21 Mar 2014; Johannes Huber <johu@gentoo.org> +ksshaskpass-0.5.3-r1.ebuild:
+ Revision bump to EAPI 5.
13 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
ksshaskpass-0.5.3.ebuild:
@@ -12,4 +17,3 @@
+ksshaskpass-0.5.3.ebuild, +metadata.xml:
Initial commit, ebuild by Leo, Jean-Baptiste Rouault and Vadim Fint, bug
159684
-
diff --git a/net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild b/net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..f65c16f93f7d
--- /dev/null
+++ b/net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild,v 1.1 2014/03/21 21:34:45 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=50971&forumpage=0"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/50971-${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="net-misc/openssh"
+
+CFG="ksshaskpass.sh"
+
+src_prepare() {
+ STARTUPDIR=/etc/kde/startup
+ SHUTDOWNDIR=/etc/kde/shutdown
+
+ kde4-base_src_prepare
+}
+
+src_install() {
+ kde4-base_src_install
+
+ cat <<-EOF > "${T}/${CFG}"
+export SSH_ASKPASS="${PREFIX}/bin/ksshaskpass"
+EOF
+ insinto "${STARTUPDIR}"
+ doins "${T}/${CFG}"
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ elog
+ elog "In order to have ksshagent start at kde startup,"
+ elog "edit ${STARTUPDIR}/agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in ${SHUTDOWNDIR}/agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${P} has been installed as your default askpass application in KDE4 session."
+ elog "If it's not desired, point the one you want to use in ${STARTUPDIR}/${CFG}"
+ elog
+}