summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-21 16:35:30 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-21 16:35:30 +0000
commit4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed (patch)
treeb61465d6a7c6cbe5e89ed0ea532cd8ad079c35a0 /net-misc
parentUpgrade. Fixes string vulnerability exploit. (diff)
downloadgentoo-2-4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed.tar.gz
gentoo-2-4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed.tar.bz2
gentoo-2-4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed.zip
New version
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/files/digest-openssh-2.9_p2-r11
-rw-r--r--net-misc/openssh/openssh-2.9_p2-r1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/openssh/files/digest-openssh-2.9_p2-r1 b/net-misc/openssh/files/digest-openssh-2.9_p2-r1
new file mode 100644
index 000000000000..9c8a76bd9f29
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-2.9_p2-r1
@@ -0,0 +1 @@
+MD5 fb5ea44cb5a894bed7b610c5a517542d openssh-2.9p2.tar.gz
diff --git a/net-misc/openssh/openssh-2.9_p2-r1.ebuild b/net-misc/openssh/openssh-2.9_p2-r1.ebuild
new file mode 100644
index 000000000000..1cd169cdf5fe
--- /dev/null
+++ b/net-misc/openssh/openssh-2.9_p2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2-r1.ebuild,v 1.1 2001/06/21 16:35:30 achim Exp $
+
+P=openssh-2.9p2
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Port of OpenBSD's free SSH release"
+SRC_URI="ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/"${A}
+HOMEPAGE="http://www.openssh.com/"
+
+DEPEND="virtual/glibc sys-devel/perl sys-apps/groff
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ pam? ( >=sys-libs/pam-0.73 )
+ >=dev-libs/openssl-0.9.6"
+
+RDEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.73 )
+ >=dev-libs/openssl-0.9.6"
+
+src_compile() {
+ local myconf
+ if [ "`use tcpd`" ]
+ then
+ myconf="--with-tcp-wrappers"
+ else
+ myconf="--without-tcp-wrappers"
+ fi
+ if [ "`use pam`" ]
+ then
+ myconf="${myconf} --with-pam"
+ else
+ myconf="${myconf} --without-pam"
+ fi
+
+ try ./configure --prefix=/usr --sysconfdir=/etc/ssh \
+ --libexecdir=/usr/lib/misc --mandir=/usr/share/man \
+ --with-ipv4-default --disable-suid-ssh --host=${CHOST} ${myconf}
+ try make
+}
+
+src_install() {
+
+ try make install-files DESTDIR=${D}
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO
+ insinto /etc/pam.d
+ donewins ${FILESDIR}/sshd.pam sshd
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/openssh sshd
+ newexe ${FILESDIR}/svc-openssh svc-sshd
+ exeinto /var/lib/supervise/services/sshd
+ newexe ${FILESDIR}/sshd-run run
+}
+
+
+pkg_postinst() {
+ # Make ssh start at boot
+ . /etc/rc.d/config/functions
+ einfo ">>> Generating symlinks"
+ ${ROOT}/usr/sbin/rc-update add svc-sshd
+}
+