summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-05-26 11:41:53 +0000
committerThilo Bangert <bangert@gentoo.org>2010-05-26 11:41:53 +0000
commit59d0b3d704286842f60292c49aa58df9fc951e2c (patch)
tree81b8cfbb15eb2077edadd98dd40a078996a12710 /net-misc
parentstable amd64, bug 321513 (diff)
downloadgentoo-2-59d0b3d704286842f60292c49aa58df9fc951e2c.tar.gz
gentoo-2-59d0b3d704286842f60292c49aa58df9fc951e2c.tar.bz2
gentoo-2-59d0b3d704286842f60292c49aa58df9fc951e2c.zip
version bump (#154994)
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/xsupplicant/ChangeLog9
-rw-r--r--net-misc/xsupplicant/xsupplicant-2.2.0.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/net-misc/xsupplicant/ChangeLog b/net-misc/xsupplicant/ChangeLog
index 7d12ea5ce7d8..41dc70cdf2df 100644
--- a/net-misc/xsupplicant/ChangeLog
+++ b/net-misc/xsupplicant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/xsupplicant
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/ChangeLog,v 1.15 2009/05/10 08:35:42 volkmar Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/ChangeLog,v 1.16 2010/05/26 11:41:53 bangert Exp $
+
+*xsupplicant-2.2.0 (26 May 2010)
+
+ 26 May 2010; Thilo Bangert <bangert@gentoo.org> +xsupplicant-2.2.0.ebuild:
+ version bump (#154994)
10 May 2009; Mounir Lamouri <volkmar@gentoo.org> xsupplicant-1.2.2.ebuild:
Forgot to change gsm->eap-sim into the ebuild. Thank Mr_Bones.
diff --git a/net-misc/xsupplicant/xsupplicant-2.2.0.ebuild b/net-misc/xsupplicant/xsupplicant-2.2.0.ebuild
new file mode 100644
index 000000000000..621d60356c29
--- /dev/null
+++ b/net-misc/xsupplicant/xsupplicant-2.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/xsupplicant-2.2.0.ebuild,v 1.1 2010/05/26 11:41:53 bangert Exp $
+
+EAPI=3
+
+inherit autotools
+
+MY_P="XSupplicant-${PV}-src"
+DESCRIPTION="Open1X xsupplicant is an open source implementation of the IEEE 802.1X
+protocol."
+HOMEPAGE="http://open1x.sourceforge.net/"
+SRC_URI="mirror://sourceforge/open1x/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ dev-libs/openssl
+ net-wireless/wireless-tools
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/xsupplicant"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README TODO || die
+
+ newconfd "${FILESDIR}"/${PN}-1.2.2-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-1.2.2-init.d ${PN}
+
+ docinto examples
+ dodoc etc/md5-example.conf etc/peap-example.conf etc/tls-example.conf \
+ etc/ttls-example.conf etc/wpa-psk-example.conf
+}
+
+pkg_postinst() {
+ einfo
+ elog "To use ${P} you must create the configuration file"
+ elog " /etc/xsupplicant.conf"
+ einfo
+ elog "Example configuration files have been installed at"
+ elog " /usr/share/doc/${P}/examples"
+ einfo
+}