summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-08-28 23:01:09 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-08-28 23:01:09 +0000
commit63db97c220f92e39cca4d9496bfe5541a37d676e (patch)
treef15afdf7c8b1be0a185375da8e191c807319b3c6 /net-misc
parentmove net-ftp/atftp net-misc (diff)
downloadgentoo-2-63db97c220f92e39cca4d9496bfe5541a37d676e.tar.gz
gentoo-2-63db97c220f92e39cca4d9496bfe5541a37d676e.tar.bz2
gentoo-2-63db97c220f92e39cca4d9496bfe5541a37d676e.zip
move net-ftp/atftp net-misc
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/atftp/ChangeLog4
-rw-r--r--net-misc/atftp/Manifest2
-rw-r--r--net-misc/atftp/atftp-0.6-r1.ebuild30
-rw-r--r--net-misc/atftp/atftp-0.6-r2.ebuild37
-rw-r--r--net-misc/atftp/atftp-0.6.ebuild31
-rw-r--r--net-misc/atftp/files/atftp-0.6-security.patch23
-rw-r--r--net-misc/atftp/files/digest-atftp-0.61
-rw-r--r--net-misc/atftp/files/digest-atftp-0.6-r11
-rw-r--r--net-misc/atftp/files/digest-atftp-0.6-r21
9 files changed, 127 insertions, 3 deletions
diff --git a/net-misc/atftp/ChangeLog b/net-misc/atftp/ChangeLog
index 647b73cb8117..f2b16ae20d53 100644
--- a/net-misc/atftp/ChangeLog
+++ b/net-misc/atftp/ChangeLog
@@ -1,6 +1,6 @@
-# ChangeLog for net-ftp/atftp
+# ChangeLog for net-misc/atftp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/ChangeLog,v 1.3 2003/08/28 22:58:27 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/ChangeLog,v 1.4 2003/08/28 22:59:10 mholzer Exp $
*atftp-0.6-r1 (29 Aug 2003)
diff --git a/net-misc/atftp/Manifest b/net-misc/atftp/Manifest
index 918ed748c472..1574fb6504ff 100644
--- a/net-misc/atftp/Manifest
+++ b/net-misc/atftp/Manifest
@@ -1,4 +1,4 @@
-MD5 46ff9e85294fc32ac629f54440df6a22 ChangeLog 982
+MD5 b373e806adb750603089517d09429902 ChangeLog 983
MD5 aa6a5bb722b019156d5ba4130ec1d6ca atftp-0.6-r1.ebuild 868
MD5 6a791122efed0994827d3febbbe34608 atftp-0.6-r2.ebuild 965
MD5 765392dc63557140fec21143c8cb50f5 atftp-0.6.ebuild 760
diff --git a/net-misc/atftp/atftp-0.6-r1.ebuild b/net-misc/atftp/atftp-0.6-r1.ebuild
new file mode 100644
index 000000000000..a3c301884564
--- /dev/null
+++ b/net-misc/atftp/atftp-0.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.6-r1.ebuild,v 1.1 2003/08/28 22:58:27 mholzer Exp $
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
+LICENSE="GPL-2"
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+SLOT="0"
+KEYWORDS="x86"
+SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_compile () {
+ myconf=""
+ use tcpd && myconf="${myconf} --enable-libwrap" \
+ || myconf="${myconf} --disable-libwrap"
+
+ econf ${myconf} || die "./configure failed"
+
+ cp Makefile Makefile.orig
+ sed "s:CFLAGS = -g -Wall -D_REENTRANT -O2:CFLAGS = -g -Wall -D_REENTRANT ${CFLAGS}:" Makefile.orig >Makefile
+
+ emake || die
+}
+
+src_install () {
+ einstall || die "Installation failed"
+}
+
diff --git a/net-misc/atftp/atftp-0.6-r2.ebuild b/net-misc/atftp/atftp-0.6-r2.ebuild
new file mode 100644
index 000000000000..56b8d63b8b47
--- /dev/null
+++ b/net-misc/atftp/atftp-0.6-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.6-r2.ebuild,v 1.1 2003/08/28 22:58:27 mholzer Exp $
+
+inherit eutils
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
+LICENSE="GPL-2"
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+SLOT="0"
+KEYWORDS="x86"
+SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ epatch ${FILESDIR}/${P}-security.patch
+}
+
+src_compile () {
+ myconf=""
+ use tcpd && myconf="${myconf} --enable-libwrap" \
+ || myconf="${myconf} --disable-libwrap"
+
+ econf ${myconf} || die "./configure failed"
+
+ cp Makefile Makefile.orig
+ sed "s:CFLAGS = -g -Wall -D_REENTRANT -O2:CFLAGS = -g -Wall -D_REENTRANT ${CFLAGS}:" Makefile.orig >Makefile
+
+ emake || die
+}
+
+src_install () {
+ einstall || die "Installation failed"
+}
+
diff --git a/net-misc/atftp/atftp-0.6.ebuild b/net-misc/atftp/atftp-0.6.ebuild
new file mode 100644
index 000000000000..8f11fb550848
--- /dev/null
+++ b/net-misc/atftp/atftp-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.6.ebuild,v 1.4 2003/08/28 22:58:27 mholzer Exp $
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
+LICENSE="GPL-2"
+DEPEND=""
+SLOT="0"
+KEYWORDS="x86"
+SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+
+}
+
+src_compile () {
+ econf || die "./configure failed"
+
+ cp Makefile Makefile.orig
+ sed "s:CFLAGS = -g -Wall -D_REENTRANT -O2:CFLAGS = -g -Wall -D_REENTRANT ${CFLAGS}:" Makefile.orig >Makefile
+
+ emake || die
+}
+
+src_install () {
+ einstall || die "Installation failed"
+}
diff --git a/net-misc/atftp/files/atftp-0.6-security.patch b/net-misc/atftp/files/atftp-0.6-security.patch
new file mode 100644
index 000000000000..5bf58699c74c
--- /dev/null
+++ b/net-misc/atftp/files/atftp-0.6-security.patch
@@ -0,0 +1,23 @@
+--- tftp.c 2003-06-17 00:13:52.000000000 +0200
++++ tftp.patch.c 2003-06-17 00:09:50.000000000 +0200
+@@ -827,17 +827,17 @@ int tftp_cmd_line_options(int argc, char
+ process_cmd(ac, av);
+ break;
+ case 'T':
+- sprintf(string, "timeout %s", optarg);
++ snprintf(string, sizeof(string), "timeout %s", optarg);
+ make_arg(string, &ac, &av);
+ process_cmd(ac, av);
+ break;
+ case 't':
+- sprintf(string, "option timeout %s", optarg);
++ snprintf(string, sizeof(string), "option timeout %s", optarg);
+ make_arg(string, &ac, &av);
+ process_cmd(ac, av);
+ break;
+ case 'b':
+- sprintf(string, "option blksize %s", optarg);
++ snprintf(string, sizeof(string), "option blksize %s", optarg);
+ make_arg(string, &ac, &av);
+ process_cmd(ac, av);
+ break;
diff --git a/net-misc/atftp/files/digest-atftp-0.6 b/net-misc/atftp/files/digest-atftp-0.6
new file mode 100644
index 000000000000..5cfcb463e4a5
--- /dev/null
+++ b/net-misc/atftp/files/digest-atftp-0.6
@@ -0,0 +1 @@
+MD5 fcbc9118b02fa2090046be987b1e1aec atftp-0.6.tar.gz 119898
diff --git a/net-misc/atftp/files/digest-atftp-0.6-r1 b/net-misc/atftp/files/digest-atftp-0.6-r1
new file mode 100644
index 000000000000..5cfcb463e4a5
--- /dev/null
+++ b/net-misc/atftp/files/digest-atftp-0.6-r1
@@ -0,0 +1 @@
+MD5 fcbc9118b02fa2090046be987b1e1aec atftp-0.6.tar.gz 119898
diff --git a/net-misc/atftp/files/digest-atftp-0.6-r2 b/net-misc/atftp/files/digest-atftp-0.6-r2
new file mode 100644
index 000000000000..5cfcb463e4a5
--- /dev/null
+++ b/net-misc/atftp/files/digest-atftp-0.6-r2
@@ -0,0 +1 @@
+MD5 fcbc9118b02fa2090046be987b1e1aec atftp-0.6.tar.gz 119898