summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-11-30 09:59:39 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-11-30 09:59:39 +0000
commit7681e1438950a86c227f7256e882a5712d03c689 (patch)
treed73816a6f7771071cb57e110b39f178e337f1ef0 /net-misc
parentadd sh KEYWORD to get mr bones off my back (diff)
downloadgentoo-2-7681e1438950a86c227f7256e882a5712d03c689.tar.gz
gentoo-2-7681e1438950a86c227f7256e882a5712d03c689.tar.bz2
gentoo-2-7681e1438950a86c227f7256e882a5712d03c689.zip
version bump: mostly bug fixes
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vpnc/ChangeLog7
-rw-r--r--net-misc/vpnc/vpnc-0.5.3.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-misc/vpnc/ChangeLog b/net-misc/vpnc/ChangeLog
index b09f5a2909b4..870874b8f95a 100644
--- a/net-misc/vpnc/ChangeLog
+++ b/net-misc/vpnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vpnc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.78 2008/11/28 12:40:24 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.79 2008/11/30 09:59:39 fauli Exp $
+
+*vpnc-0.5.3 (30 Nov 2008)
+
+ 30 Nov 2008; Christian Faulhammer <fauli@gentoo.org> +vpnc-0.5.3.ebuild:
+ version bump: mostly bug fixes
28 Nov 2008; Christian Faulhammer <fauli@gentoo.org> metadata.xml:
Change my email address
diff --git a/net-misc/vpnc/vpnc-0.5.3.ebuild b/net-misc/vpnc/vpnc-0.5.3.ebuild
new file mode 100644
index 000000000000..2c782c7e91b0
--- /dev/null
+++ b/net-misc/vpnc/vpnc-0.5.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3.ebuild,v 1.1 2008/11/30 09:59:39 fauli Exp $
+
+DESCRIPTION="Free client for Cisco VPN routing software"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
+SRC_URI="http://www.unix-ag.uni-kl.de/~massar/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hybrid-auth bindist resolvconf"
+
+DEPEND=">=dev-libs/libgcrypt-1.1.91
+ >=sys-apps/iproute2-2.6.19.20061214
+ !bindist? ( hybrid-auth? ( dev-libs/openssl ) )"
+
+RDEPEND="${DEPEND}
+ resolvconf? ( net-dns/openresolv )"
+
+pkg_setup() {
+ if use hybrid-auth && use bindist; then
+ ewarn "Hybrid authentication will be disabled for this packages as you will"
+ ewarn "redistribute it in binary form. This is not allowed due to linking"
+ ewarn "of OpenSSL."
+ fi
+}
+
+src_compile() {
+ # only allowed if not distributed in binary form!
+ if use hybrid-auth && ! use bindist; then
+ hybridauthopts="OPENSSL_GPL_VIOLATION=-DOPENSSL_GPL_VIOLATION OPENSSLLIBS=-lcrypto"
+ fi
+ emake ${hybridauthopts} || die
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install || die
+ dodoc README TODO VERSION
+ keepdir /var/run/vpnc
+ keepdir /etc/vpnc/scripts.d
+ newinitd "${FILESDIR}/vpnc-2.init" vpnc
+ newconfd "${FILESDIR}/vpnc.confd" vpnc
+ sed -e "s:/usr/local:/usr:" -i "${D}"/etc/vpnc/vpnc-script || die
+ # COPYING file resides here, should not be installed
+ rm -rf "${D}"/usr/share/doc/vpnc/
+}
+
+pkg_postinst() {
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is to be found in http://www.gentoo.org/doc/en/vpnc-howto.xml"
+ echo
+ elog "Don't forget to turn on TUN support in the kernel."
+}