summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-10-02 18:23:00 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-10-02 18:23:00 +0000
commit9b90b1b620ccbf30799b8a79c40cdfd7f6706a9d (patch)
treefc9ca5e2509d06c94862c2eb5b5d075b2a812952 /net-misc
parentRe-adding the intltool DEPEND. Thanks to Sven Wegener. (diff)
downloadgentoo-2-9b90b1b620ccbf30799b8a79c40cdfd7f6706a9d.tar.gz
gentoo-2-9b90b1b620ccbf30799b8a79c40cdfd7f6706a9d.tar.bz2
gentoo-2-9b90b1b620ccbf30799b8a79c40cdfd7f6706a9d.zip
Fix #107886 and remove --with-db=no.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/partysip/ChangeLog8
-rw-r--r--net-misc/partysip/files/partysip-2.2.3-fix_auth.diff19
-rw-r--r--net-misc/partysip/partysip-2.2.3.ebuild11
3 files changed, 33 insertions, 5 deletions
diff --git a/net-misc/partysip/ChangeLog b/net-misc/partysip/ChangeLog
index 7b7bafa4658d..153859890aad 100644
--- a/net-misc/partysip/ChangeLog
+++ b/net-misc/partysip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/partysip
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/ChangeLog,v 1.11 2005/10/02 18:00:09 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/ChangeLog,v 1.12 2005/10/02 18:23:00 stkn Exp $
+
+ 02 Oct 2005; Stefan Knoblich <stkn@gentoo.org>
+ +files/partysip-2.2.3-fix_auth.diff, partysip-2.2.3.ebuild:
+ Remove unused code in auth plugin, breaks authentication otherwise
+ (#107886), thanks to White_Angel@gmx.de for submitting this fix. Using
+ --with-db=no does not work, fix that too.
02 Oct 2005; Stefan Knoblich <stkn@gentoo.org>
+files/partysip-2.2.3-libresolv-check.diff, partysip-2.2.3.ebuild:
diff --git a/net-misc/partysip/files/partysip-2.2.3-fix_auth.diff b/net-misc/partysip/files/partysip-2.2.3-fix_auth.diff
new file mode 100644
index 000000000000..ada13790bef7
--- /dev/null
+++ b/net-misc/partysip/files/partysip-2.2.3-fix_auth.diff
@@ -0,0 +1,19 @@
+--- partysip-2.2.3/plugin/auth/auth.c.orig 2005-10-02 20:13:36.000000000 +0000
++++ partysip-2.2.3/plugin/auth/auth.c 2005-10-02 20:13:55.000000000 +0000
+@@ -65,15 +65,13 @@
+ /* find the pending_auth element */
+ char *response;
+ char *nonce;
+- char *opaque;
+ char *realm;
+
+ /* char *qop; */
+ char *uri;
+
+ nonce = osip_proxy_authorization_get_nonce (p_auth);
+- opaque = osip_proxy_authorization_get_opaque (p_auth);
+- if (opaque == NULL || nonce == NULL)
++ if (nonce == NULL)
+ return -1;
+
+ realm = osip_proxy_authorization_get_realm (p_auth);
diff --git a/net-misc/partysip/partysip-2.2.3.ebuild b/net-misc/partysip/partysip-2.2.3.ebuild
index 6f76ef9c2524..47bd594be1b8 100644
--- a/net-misc/partysip/partysip-2.2.3.ebuild
+++ b/net-misc/partysip/partysip-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/partysip-2.2.3.ebuild,v 1.3 2005/10/02 18:00:09 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/partysip-2.2.3.ebuild,v 1.4 2005/10/02 18:23:00 stkn Exp $
IUSE="berkdb debug syslog"
@@ -17,7 +17,6 @@ KEYWORDS="~ppc ~sparc ~x86"
DEPEND="virtual/libc
>=net-libs/libosip-2.2.1
berkdb? ( =sys-libs/db-3* )"
-# gdbm? ( sys-libs/gdbm )"
src_unpack() {
unpack ${A}
@@ -31,6 +30,10 @@ src_unpack() {
# list of libresolv on amd64
epatch ${FILESDIR}/${P}-libresolv-check.diff
+ # remove unused check in auth plugin (#107886)
+ # breaks authentication otherwise
+ epatch ${FILESDIR}/${P}-fix_auth.diff
+
# put partysip binary into /usr/sbin
sed -i -e "s:^bin_PROGRAMS:sbin_PROGRAMS:" \
src/Makefile.am tools/Makefile.am
@@ -48,8 +51,8 @@ src_compile() {
myconf="--with-db=susedb3"
# elif use gdbm; then
# myconf="--with-db=gdbm"
- else
- myconf="--with-db=no"
+# else
+# myconf="--with-db=no"
fi
econf \