summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-07-21 11:28:46 +0000
committerChristoph Mende <angelos@gentoo.org>2011-07-21 11:28:46 +0000
commitba6aa7ef4ed1acd1338a730550b53c477babb177 (patch)
tree7bf312075d12e3d1ce87ab93c458925ae94947d1 /net-misc
parentMisc updates to set-opacity-1.0, add 9999. See #276913 (diff)
downloadgentoo-2-ba6aa7ef4ed1acd1338a730550b53c477babb177.tar.gz
gentoo-2-ba6aa7ef4ed1acd1338a730550b53c477babb177.tar.bz2
gentoo-2-ba6aa7ef4ed1acd1338a730550b53c477babb177.zip
Fix cross compilation with differing long integer sizes (bug #365375)
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.21.7-r1.ebuild125
-rw-r--r--net-misc/curl/files/config.h.ed29
-rw-r--r--net-misc/curl/files/curlbuild.h.ed15
4 files changed, 176 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index dadfecf0da33..00632b358584 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.186 2011/07/21 08:11:48 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.187 2011/07/21 11:28:46 angelos Exp $
+
+*curl-7.21.7-r1 (21 Jul 2011)
+
+ 21 Jul 2011; Christoph Mende <angelos@gentoo.org> +curl-7.21.7-r1.ebuild,
+ +files/config.h.ed, +files/curlbuild.h.ed:
+ Fix cross compilation with differing long integer sizes (bug #365375)
21 Jul 2011; Christoph Mende <angelos@gentoo.org> curl-7.21.7.ebuild:
Bump c-ares dep to 1.6 (bug #369501)
diff --git a/net-misc/curl/curl-7.21.7-r1.ebuild b/net-misc/curl/curl-7.21.7-r1.ebuild
new file mode 100644
index 000000000000..121774d05762
--- /dev/null
+++ b/net-misc/curl/curl-7.21.7-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.21.7-r1.ebuild,v 1.1 2011/07/21 11:28:46 angelos Exp $
+
+EAPI=4
+
+inherit autotools multilib eutils libtool prefix
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ares gnutls idn ipv6 kerberos ldap libssh2 nss ssl static-libs test threads"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ ssl? (
+ gnutls? ( net-libs/gnutls dev-libs/libgcrypt app-misc/ca-certificates )
+ nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
+ !gnutls? ( !nss? ( dev-libs/openssl ) )
+ )
+ idn? ( net-dns/libidn )
+ ares? ( >=net-dns/c-ares-1.6 )
+ kerberos? ( virtual/krb5 )
+ libssh2? ( >=net-libs/libssh2-0.16 )"
+
+# rtmpdump ( media-video/rtmpdump ) / --with-librtmp
+# fbopenssl (not in gentoo) --with-spnego
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ sys-apps/ed
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+# ares must be disabled for threads and both can be disabled
+# one can use wether gnutls or nss if ssl is enabled
+REQUIRED_USE="threads? ( !ares )
+ gnutls? ( ssl )
+ nss? ( ssl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.20.0-strip-ldflags.patch \
+ "${FILESDIR}"/${PN}-7.19.7-test241.patch \
+ "${FILESDIR}"/${PN}-7.18.2-prefix.patch \
+ "${FILESDIR}"/${PN}-respect-cflags-2.patch
+
+ eprefixify curl-config.in
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
+ $(use_with idn libidn)
+ $(use_with kerberos gssapi "${EPREFIX}"/usr)
+ $(use_with libssh2)
+ $(use_enable static-libs static)
+ $(use_enable ipv6)
+ $(use_enable threads threaded-resolver)
+ $(use_enable ares)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-smtp
+ --enable-pop3
+ --enable-imap
+ --enable-rtsp
+ --enable-nonblocking
+ --enable-largefile
+ --enable-maintainer-mode
+ --disable-sspi
+ --without-krb4
+ --without-librtmp
+ --without-spnego"
+
+ if use ssl ; then
+ if use gnutls; then
+ myconf+=" --without-ssl --with-gnutls --without-nss"
+ myconf+=" --with-ca-bundle=${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
+ elif use nss; then
+ myconf+=" --without-ssl --without-gnutls --with-nss"
+ myconf+=" --with-ca-bundle=${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
+ else
+ myconf+=" --without-gnutls --without-nss --with-ssl"
+ myconf+=" --without-ca-bundle --with-ca-path=${EPREFIX}/etc/ssl/certs"
+ fi
+ else
+ myconf+=" --without-gnutls --without-nss --without-ssl"
+ fi
+
+ econf ${myconf}
+}
+
+src_compile() {
+ default
+ ed - lib/curl_config.h < "${FILESDIR}"/config.h.ed || die
+ ed - src/curl_config.h < "${FILESDIR}"/config.h.ed || die
+ ed - include/curl/curlbuild.h < "${FILESDIR}"/curlbuild.h.ed || die
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+ rm -rf "${ED}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/config.h.ed b/net-misc/curl/files/config.h.ed
new file mode 100644
index 000000000000..caf6d43cf247
--- /dev/null
+++ b/net-misc/curl/files/config.h.ed
@@ -0,0 +1,29 @@
+/SIZEOF_LONG/c
+#ifdef __LP64__
+#define SIZEOF_LONG 8
+#else /* !__LP64__ */
+#define SIZEOF_LONG 4
+#endif /* __LP64__ */
+.
+/SIZEOF_SIZE_T/c
+#ifdef __LP64__
+#define SIZEOF_SIZE_T 8
+#else /* !__LP64__ */
+#define SIZEOF_SIZE_T 4
+#endif /* __LP64__ */
+.
+/SIZEOF_TIME_T/c
+#ifdef __LP64__
+#define SIZEOF_TIME_T 8
+#else /* !__LP64__ */
+#define SIZEOF_TIME_T 4
+#endif /* __LP64__ */
+.
+/SIZEOF_VOIDP/c
+#ifdef __LP64__
+#define SIZEOF_VOIDP 8
+#else /* !__LP64__ */
+#define SIZEOF_VOIDP 4
+#endif /* __LP64__ */
+.
+w
diff --git a/net-misc/curl/files/curlbuild.h.ed b/net-misc/curl/files/curlbuild.h.ed
new file mode 100644
index 000000000000..5f076e6e8ffc
--- /dev/null
+++ b/net-misc/curl/files/curlbuild.h.ed
@@ -0,0 +1,15 @@
+/define CURL_SIZEOF_LONG/c
+#ifdef __LP64__
+#define CURL_SIZEOF_LONG 8
+#else /* !__LP64__ */
+#define CURL_SIZEOF_LONG 4
+#endif /* __LP64__ */
+.
+/define CURL_SIZEOF_CURL_OFF_T/c
+#ifdef __LP64__
+#define CURL_SIZEOF_CURL_OFF_T 8
+#else /* !__LP64__ */
+#define CURL_SIZEOF_CURL_OFF_T 4
+#endif /* __LP64__ */
+.
+w