summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-10-19 08:37:10 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-10-19 08:37:10 +0000
commitc258b35ba9cff0db3bca9b7dc13ed6ee8a758f72 (patch)
tree3c31d3e69ee5b7864b90d22ffeb2a47798e33688 /net-misc
parentDownload the patches from the mirrors, don't use git (diff)
downloadgentoo-2-c258b35ba9cff0db3bca9b7dc13ed6ee8a758f72.tar.gz
gentoo-2-c258b35ba9cff0db3bca9b7dc13ed6ee8a758f72.tar.bz2
gentoo-2-c258b35ba9cff0db3bca9b7dc13ed6ee8a758f72.zip
Added vala USE-flag to regenerate the pre-generated code if requested. Fixed bug #377051 by adding -j1 to 'emake install' (final solution will be upstream once spice-gtk is integrated in spice). Fixed bug #377041 by updating the spice-protocol dependency.
(Portage version: 2.1.10.27/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/ChangeLog9
-rw-r--r--net-misc/spice-gtk/metadata.xml1
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.7.ebuild14
3 files changed, 19 insertions, 5 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index c6d4706d872e..5e81cff1f913 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.5 2011/07/25 12:32:11 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.6 2011/10/19 08:37:10 dev-zero Exp $
+
+ 19 Oct 2011; Tiziano Müller <dev-zero@gentoo.org> spice-gtk-0.7.ebuild,
+ metadata.xml:
+ Added vala USE-flag to regenerate the pre-generated code if requested. Fixed
+ bug #377051 by adding -j1 to 'emake install' (final solution will be upstream
+ once spice-gtk is integrated in spice). Fixed bug #377041 by updating the
+ spice-protocol dependency.
*spice-gtk-0.7 (25 Jul 2011)
diff --git a/net-misc/spice-gtk/metadata.xml b/net-misc/spice-gtk/metadata.xml
index 73ec72a383f5..666c5bddaafa 100644
--- a/net-misc/spice-gtk/metadata.xml
+++ b/net-misc/spice-gtk/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="gtk3">Link against <pkg>x11-libs/gtk+:3</pkg> instead of <pkg>x11-libs/gtk+:2</pkg></flag>
<flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ <flag name="vala">Regenerate pre-generated vala code using <pkg>dev-lang/vala:0.12</pkg></flag>
</use>
</pkgmetadata>
diff --git a/net-misc/spice-gtk/spice-gtk-0.7.ebuild b/net-misc/spice-gtk/spice-gtk-0.7.ebuild
index 7f7aab6f35da..3c13958bb931 100644
--- a/net-misc/spice-gtk/spice-gtk-0.7.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.7.ebuild,v 1.1 2011/07/25 12:32:11 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.7.ebuild,v 1.2 2011/10/19 08:37:10 dev-zero Exp $
EAPI=3
@@ -15,11 +15,11 @@ SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+cairo doc gnome gstreamer gtk3 introspection kde +pulseaudio python sasl static-libs"
+IUSE="+cairo doc gnome gstreamer gtk3 introspection kde +pulseaudio python sasl static-libs vala"
RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
gstreamer? ( media-libs/gstreamer )
- >=app-emulation/spice-protocol-0.8.0-r1
+ >=app-emulation/spice-protocol-0.8.1
>=x11-libs/pixman-0.17.7
>=media-libs/celt-0.5.1.1:0.5.1
dev-libs/openssl
@@ -34,6 +34,7 @@ RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
sasl? ( dev-libs/cyrus-sasl )
gnome? ( gnome-base/gconf )"
DEPEND="${RDEPEND}
+ vala? ( dev-lang/vala:0.12 )
dev-lang/python
dev-lang/perl
dev-perl/Text-CSV
@@ -53,6 +54,10 @@ src_configure() {
use pulseaudio && audio="pulse"
use gstreamer && audio="gstreamer"
use gtk3 && gtk="3.0"
+ if use vala ; then
+ rm gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c # force vala regen
+ export VALAC=$(which valac-0.12)
+ fi
econf \
$(use_enable static-libs static) \
@@ -61,12 +66,13 @@ src_configure() {
$(use_with !cairo x11) \
$(use_with python) \
$(use_with sasl) \
+ $(use_enable vala) \
--with-gtk="${gtk}" \
--disable-smartcard
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
use static-libs || rm -rf "${D}"/usr/lib*/*.la
use python && rm -rf "${D}"/usr/lib*/python*/site-packages/*.la