summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-07-07 17:46:20 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-07-07 17:46:20 +0000
commitc53bdb3854893ead1031c7deaca7373f0d9485c3 (patch)
tree621359e5d3292d4a5446c79f7d2807d2376e7489 /net-misc
parentppc64 stable wrt #321447 (diff)
downloadgentoo-2-c53bdb3854893ead1031c7deaca7373f0d9485c3.tar.gz
gentoo-2-c53bdb3854893ead1031c7deaca7373f0d9485c3.tar.bz2
gentoo-2-c53bdb3854893ead1031c7deaca7373f0d9485c3.zip
Add netcf to the tree but it doesn't actually support Gentoo yet
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netcf/ChangeLog10
-rw-r--r--net-misc/netcf/metadata.xml12
-rw-r--r--net-misc/netcf/netcf-0.1.6.ebuild31
3 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/netcf/ChangeLog b/net-misc/netcf/ChangeLog
new file mode 100644
index 000000000000..3d048c5c42ce
--- /dev/null
+++ b/net-misc/netcf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/netcf
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netcf/ChangeLog,v 1.1 2010/07/07 17:46:20 cardoe Exp $
+
+*netcf-0.1.6 (07 Jul 2010)
+
+ 07 Jul 2010; Doug Goldstein <cardoe@gentoo.org> +netcf-0.1.6.ebuild,
+ +metadata.xml:
+ Add netcf to the tree but it doesn't actually support Gentoo yet
+
diff --git a/net-misc/netcf/metadata.xml b/net-misc/netcf/metadata.xml
new file mode 100644
index 000000000000..0b48d6a1fd46
--- /dev/null
+++ b/net-misc/netcf/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ <description>Anyone can take over this package if they
+ want</description>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-misc/netcf/netcf-0.1.6.ebuild b/net-misc/netcf/netcf-0.1.6.ebuild
new file mode 100644
index 000000000000..98a0c567f4d3
--- /dev/null
+++ b/net-misc/netcf/netcf-0.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netcf/netcf-0.1.6.ebuild,v 1.1 2010/07/07 17:46:20 cardoe Exp $
+
+EAPI=2
+
+DESCRIPTION="netcf is a cross-platform network configuration library"
+HOMEPAGE="https://fedorahosted.org/netcf/"
+SRC_URI="https://fedorahosted.org/released/netcf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-admin/augeas-0.5.0
+ dev-libs/libnl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # static libs are a waste of time and disk for this
+ econf --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}