summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-07-16 06:54:46 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-07-16 06:54:46 +0000
commitccaec9ef3af2b5892e64b67e3a58e2663342b781 (patch)
tree64e440ccc066469f1a694e1a52ee3080b33ebf7c /net-misc
parentFix for brokentest fix (diff)
downloadgentoo-2-ccaec9ef3af2b5892e64b67e3a58e2663342b781.tar.gz
gentoo-2-ccaec9ef3af2b5892e64b67e3a58e2663342b781.tar.bz2
gentoo-2-ccaec9ef3af2b5892e64b67e3a58e2663342b781.zip
Version bump (finally works with cmake).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pino/ChangeLog7
-rw-r--r--net-misc/pino/pino-0.2.11.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-misc/pino/ChangeLog b/net-misc/pino/ChangeLog
index 09c1a35e1364..bc44e28fd531 100644
--- a/net-misc/pino/ChangeLog
+++ b/net-misc/pino/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/pino
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/ChangeLog,v 1.4 2010/05/27 05:47:45 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/ChangeLog,v 1.5 2010/07/16 06:54:46 dev-zero Exp $
+
+*pino-0.2.11 (16 Jul 2010)
+
+ 16 Jul 2010; Tiziano Müller <dev-zero@gentoo.org> +pino-0.2.11.ebuild:
+ Version bump (finally works with cmake).
*pino-0.2.10 (27 May 2010)
diff --git a/net-misc/pino/pino-0.2.11.ebuild b/net-misc/pino/pino-0.2.11.ebuild
new file mode 100644
index 000000000000..e624d4287899
--- /dev/null
+++ b/net-misc/pino/pino-0.2.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pino/pino-0.2.11.ebuild,v 1.1 2010/07/16 06:54:46 dev-zero Exp $
+
+EAPI="3"
+
+inherit cmake-utils
+
+DESCRIPTION="Twitter and Identi.ca desktop client written in Vala"
+HOMEPAGE="http://pino-app.appspot.com/ http://code.google.com/p/pino-twitter/"
+SRC_URI="http://pino-twitter.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug indicate"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ >=x11-libs/gtk+-2.10:2
+ >=dev-libs/libgee-0.5.0
+ x11-libs/libnotify
+ net-libs/libsoup:2.4
+ dev-libs/libxml2:2
+ >=net-libs/webkit-gtk-1.1
+ dev-libs/libunique
+ app-text/gtkspell
+ indicate? ( dev-libs/libindicate )"
+DEPEND="${RDEPEND}
+ >=dev-lang/vala-0.7.9
+ dev-util/pkgconfig
+ sys-devel/gettext
+ dev-util/intltool"
+
+# TODO:
+# write a patch (for CMakeLists.txt) to not ignore LINGUAS
+
+DOCS="AUTHORS README"
+
+# upstream forgot to update the directory (again)
+S="${WORKDIR}/${PN}-0.2.10"
+
+src_configure() {
+ local myconf=""
+ use debug && myconf="--debug"
+
+ if ! use indicate ; then
+ # sabotage the detection since no configure option
+ sed -i \
+ -e 's|"indicate|"indicate-false|' \
+ CMakeLists.txt || die "sed failed"
+ fi
+
+ mycmakeargs=(
+ $(cmake-utils_use_enable debug DEBUG)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${D}/usr/share/doc"
+ dodoc ${DOCS}
+}
+